1 2 Previous Next 17 Replies Latest reply: Mar 29, 2014 1:56 PM by riiiic
AlexR688 Level 1 Level 1 (0 points)
HI everyone!

I'm having a bit of a hard time with Snow Leopard and my Buffalo Linkstation Pro. I have set up the NAS exactly how I want, and it has been working great up until now. I cancelled a file copy to the NAS via the Finder, and now the file that was half-way through copying is stuck on the drive. Every time i try to delete the file the following error message is returned:

"The operation can’t be completed because an unexpected error occurred (error code -8072)."

I have tried force deleting the file using the terminal (rm -rf then dragging the file into Terminal), and I have also tried deleting the file as each of the users on my NAS, including admin and guest.
In addition to this, I have also tried accessing the NAS by afp, ftp and smb just to see if a change of protocol would work, but as expected, nothing.

Essentially I am now stumped and have no idea what to do!

If anybody could help me figure out what it is that's causing this issue, I would be forever grateful!

Thanks, Alex

Mac Mini Late 2009, Mac OS X (10.6.4), Mac Mini (Late 2009), iMac 20" (Early 2009), MacBook Pro (Late 2009), iPhone 3GS 16GB
  • 1. Re: Finder Error -8072
    Kappy Level 10 Level 10 (226,855 points)
    If feasible try copying the file again but allow it to go to completion. Most likely you will be asked if it''s OK to replace a file of the same name to which you should answer, 'Yes.'

    If that doesn't work then you might try restarting the computer and the NAS then see if you are able to remove the file. Turn them both off before restarting.
  • 2. Re: Finder Error -8072
    AlexR688 Level 1 Level 1 (0 points)
    Hi Kappy,

    Thanks for your reply!

    Unfortunately I had already tried restarting all 3 of my computers that I've been trying this with and my NAs before posting to the forum.

    I also tried to copy across the file again, but it reports that "The operation can’t be completed because you don’t have permission to access some of the items."

    Just in case this helps, I originally saved the file to my computer from the Internet, and then copied it across to my NAS from there. I then stopped the copy mid-way because I decided I no longer wanted the file there. It then gave me the error code -8072, and since then I have renamed the file several times in order to try and delete, but still to no avail. Unfortunately I can't remember the original file name (it was something nasty as often downloads are from the Web).

    If you have any other suggestions, please fire away!
  • 3. Re: Finder Error -8072
    Kappy Level 10 Level 10 (226,855 points)
    Can you determine what the file's permissions are? Both the original and whatever scrap of it is on your NAS. If you don't have permission for the operation then it means either the file's permissions need to be changed and/or the NAS' permissions. Do you know how to change permissions using the Get Info window? I assume you know how to use the Terminal. You tried removing the file already, but did you precede the command with 'sudo'? See the following:
    sudo rm -rf /pathto/filename
  • 4. Re: Finder Error -8072
    AlexR688 Level 1 Level 1 (0 points)
    I have tried looking at this, and the permissions for the "scrap" of the file left are "custom" for the users "everyone." How unhelpful is that!

    I no longer have the original file, as it was not the correct version of MySQL for my needs, hence I deleted it and emptied the Trash. I've also tried checking the NAS drive's permissions and both read & write are enabled. (If this helps at all, it's a Buffalo LinkStation Pro, formatted as XFS).
    I do know how to change permissions for files using the Get Info window, but every time I try adding my User name to the list of users with specific permissions for the file it says that I have entered an invalid user name. (I am trying this with my shortname - do I need to use the full name of the account instead?).

    As for the Terminal command, I have just tried it now, and it still returns the error message that permission is denied.

    Thanks again for your help!
  • 5. Re: Finder Error -8072
    Kappy Level 10 Level 10 (226,855 points)
    What are the permissions for the file from the Get Info window? I'm not familiar with using XFS, so I'm not sure how you go about changing file permissions on the NAS. Perhaps the issue is that you cannot change permissions of items on the NAS.
  • 6. Re: Finder Error -8072
    AlexR688 Level 1 Level 1 (0 points)
    The permissions on the NAS just say that "everyone" has "custom" permissions, and I can't change the permissions from that.. It's really frustrating!

    I'm afraid I know nothing about XFS either - too far into the world of Linux for me!

    It seems I might have to do a complete reformat of the disk at this rate if I want to get rid of this folder.. Permissions really can get on my nerves!

    Thanks again for your help.
  • 7. Re: Finder Error -8072
    Kappy Level 10 Level 10 (226,855 points)
    If your NAS is running Linux, then either it's a Linux issue or the files have the wrong permissions while still on your Mac. If this be the case, then you can fix them, then try moving them to the NAS. If it's a Linux issue then I'm at a loss as to how to fix that on the NAS since the OS is in firmware on the NAS. I don't know how you access it, but most likely the tech support of its manufacturer should know.

    Does the NAS support AFP? If so then I would reconfigure it to use AFP which is compatible with the Mac.
  • 8. Re: Finder Error -8072
    AlexR688 Level 1 Level 1 (0 points)
    I think I will try their customer support tomorrow - good idea!

    I have set up the NAS so that it uses AFP, FTP and SMB so that all bases are covered (I've still got to have one Windows PC on the network to keep the parents happy!). But from what you've said, I think I would agree that it is a Linux issue, as I have never had this problem with HFS+ drives (or NTFS/FAT32 drives for that matter).

    I access the drive via Gigabit Ethernet (it is plugged into the same switch as my Mac), and then I use the web browser to access settings and so on. This doesn't seem to give me access to specific files however - I manage the files from within Finder/Windows Explorer.

    Thanks
  • 9. Re: Finder Error -8072
    Kappy Level 10 Level 10 (226,855 points)
    Can't be more help. I did search Google and Apple support but found nothing helpful about the particular error number. Maybe their tech support can help.
  • 10. Re: Finder Error -8072
    AlexR688 Level 1 Level 1 (0 points)
    Not a problem, I guess it's just one of those "1 in a million issues" that just creep up on you occasionally.

    I spoke to Buffalo and they weren't sure how to solve the problem either. Looks like it's gonna have to stay on the drive for the time being, or I'll have to re-do the drive completely at some point.

    Thanks for your continued support.

    Alex
  • 11. Re: Finder Error -8072
    Benjamin Frain Level 2 Level 2 (255 points)
    Make that 2 in a million! I have a Buffalo Linkstation Mini and just encountered this problem trying to access my iTunes library on the NAS.

    'The operation can’t be completed because an unexpected error occurred (error code -1407).'

    Everything was working fine yesterday running firmware 1.31, updated to firmware 1.34 on the Linkstation Mini yesterday and I seem to have this problem.

    Only other thing I've done is update to iTunes 10 but as your problem isn't related to iTunes I'm inclined to think it's the Linkstation that is the problem.

    Do let me know if you have any joy fixing this...
  • 12. Re: Finder Error -8072
    Benjamin Frain Level 2 Level 2 (255 points)
    Update - I think I've cracked it - try turning off 'Recycle Bin' support on your Linkstation and then delete the file again. It's worked for me!
  • 13. Re: Finder Error -8072
    BAPEsta Level 1 Level 1 (0 points)
    I have the problem with the 1407 error, I can't delete a bunch of big .avi files because of a problem with the Error code 1407, can't even move them to the trashcan.
  • 14. Re: Finder Error -8072
    BAPEsta Level 1 Level 1 (0 points)
    I have the problem with the 1407 error, I cant delete a bunch of big .avi files because of a problem with the Error code 1407, can't even move them to the trashcan.
1 2 Previous Next