1 2 Previous Next 20 Replies Latest reply: Apr 26, 2012 2:17 PM by sarki
wcarcass Level 1 Level 1 (0 points)
Hello,

My iTunes all of a sudden started to gave me this error when I tried to update my iPhone Apps:

*iTunes couldn't download your purchase*

*You don't have write access for your iTunes Media folder or a folder within it. Change permissions (in the Finder) and then choose Store > Check Available Downloads.*

This is most weird since I haven't done anything to the system nor the iPhone.
I tried to repair permissions, tried CHMOD and then booting from the installation disk and reset password, thrash preferences and the message is always there. Even weirder is the fact that when I connect my iPhone, iTunes ask me about "authorization", if I say AUTHORIZE, it gives me another error saying that it cannot be authorize because of an error, but it does not say what error!

If I deauthorize, I'll loose more than 200 Apps, but if I authorize, even with the correct password, it simply gives me that bloody error.

I do not know what else to do, any ideas?

And yeah... I tried going to the iTunes list, get info and authorize myself, despite being already authorized... by the way I do not have the "apply to the contents within...or something like that, you know what I'm talking about option". My system is 10.5.8. PPC, and I do not see the relevance but the iTunes list is hosted in an external HD.

I'll be more than thankful for any help.

G5, Mac OS X (10.5.8)
1 2 Previous Next