Skip navigation
This discussion is archived

iPhone "unable to join network" in Wifi

44610 Views 72 Replies Latest reply: Sep 24, 2010 11:57 PM by Michaelw352 RSS
1 2 3 ... 5 Previous Next
Kentucky Charlie Calculating status...
Currently Being Moderated
Sep 1, 2010 5:53 PM
I get this message when trying to join my own network (or any other free network). Bluetooth works fine. I have tried resetting Network settings.
iPhone, iPhone OS 3.0, iTunes 9.2.1
  • James Mol Level 3 Level 3 (675 points)
    Currently Being Moderated
    Sep 2, 2010 7:38 AM (in response to Kentucky Charlie)
    Was your network working in the past? Did it happen after you upgraded say to OS 4.0.2?
    Power Mac Dual 1.4GHz G4; iMac Core 2 Duo, Mac OS X (10.5.8), 2GB Ram, SATA RAID external drives; 1GB Ram; FCP6
  • wjosten Level 10 Level 10 (91,230 points)
    Currently Being Moderated
    Sep 3, 2010 10:04 AM (in response to Kentucky Charlie)
    Try this: Power off your router & all devices(that includes your phone!) that connect to your network. Wait at least 30 seconds, then turn your router on, once fully powered up, turn on each device, one at a time, wait until each one connects to your network, then power on the next device.
    MacBook Pro
  • NormHaisi Calculating status...
    Currently Being Moderated
    Sep 3, 2010 9:31 PM (in response to Kentucky Charlie)
    Some food for thought. I am having network problems too.

    The wireless router I use is not connected to the internet via its WAN port, instead it is connected to the internet via my main router connected to one of its LAN ports.

    All my wireless devices talk to the internet ok except my iPod Touch.

    It appears that the iPod only sees the Wireless router WAN port and of course indicates the internet is not available.

    I have turned off DHCP on the wireless router and using my main router as the DHCP.

    Interestingly I can actually ping google from my iPod ok.
    iOS 4
  • Andy Thomas Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 5, 2010 7:37 AM (in response to Kentucky Charlie)
    I'm getting the same problem for the last few days on my 3GS. It was fine last week now suddenly it won't connect. It can see the wifi networks, just can't connect

    Have powered off all the router stuff, reset all settign on the iphone and still no joy.

    I can't the think of anything else to try, my iPad, MacBook pro and Mac pro are all fine. We have 3 MBPs, 1 iMac, a Mac pro, an iPad and an iPhone 3GS... All old expect the iPhone. I installed the latest release a while a go and it was fine until now.

    I'm holding out the iOS 4.1 may fix it next week (but I doubt it)
    iPhone 3GS, iOS 4, MacPro, Macbook Pro
  • Andy Thomas Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 5, 2010 1:16 PM (in response to Andy Thomas)
    whohoo!!

    Got my 3GS working finally.

    Not sure if this is a genuine fix or not, but I went into my Airport Utility on my MBP and turned on the option "Use Interface Robustness" Setting. waited for the router to restart and then my iPhone hooked up.

    I'd noticed that I'm seeing a number of new local wifi networks from neighbours so thought this was worth a try

    Might be worth a try if you're having similar problems
    iPhone 3GS, iOS 4, MacPro, Macbook Pro
  • James Mol Level 3 Level 3 (675 points)
    Currently Being Moderated
    Sep 5, 2010 8:47 PM (in response to Andy Thomas)
    I had similar results after updating a change in my Airport base station, only I changed the name of my network. So might I infer that for Airport Base Station owners the solution may lie In the update/restart after changing a setting. The restart seems to take care of the problem.
    Power Mac Dual 1.4GHz G4; iMac Core 2 Duo, Mac OS X (10.5.8), 2GB Ram, SATA RAID external drives; 1GB Ram; FCP6
  • Andy Thomas Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 6, 2010 12:25 AM (in response to James Mol)
    I suspect it was the slight modification and the restart that did it. I did numerous restarts with no luck, it was only when I did the change and hit update that is worked
    iPhone 3GS, iOS 4, MacPro, Macbook Pro
  • Andy Thomas Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 6, 2010 1:50 AM (in response to Andy Thomas)
    Rats!! It stopped working again

    Not sure what the next step is, my only conclusion is that it's a clashing ip address? However i even tried giving it a static ip address and that failed as well.

    Fingers crossed iOS4.1 works and fixes it.
    iPhone 3GS, iOS 4, MacPro, Macbook Pro
  • James Mol Level 3 Level 3 (675 points)
    Currently Being Moderated
    Sep 6, 2010 4:25 AM (in response to Kentucky Charlie)
    For those of you under warranty, make an appointment at the Apple Store and take it in. Better yet, make an appointment for the genius bar online at http://www.apple.com/retail/geniusbar/

    Of course, if as some reported, it is a security issue, and Apple stores don't have secured networks, they nothing will show up.

    For the rest of us, there are two ways to let Apple know there is a problem. The simple way is at:

    http://www.apple.com/feedback/iphone.html

    Select Feedback Type: Bug Report

    Fill out the form. Just takes a minute

    If you are a developer, registered to be a developer, or at least understand the lingo, you can report the bug at

    https://bugreport.apple.com/

    If it is happening to enough people and we start telling Apple, they may look into it. Or it may be a non issue by the end of this week with the release of 4.1.
    Power Mac Dual 1.4GHz G4; iMac Core 2 Duo, Mac OS X (10.5.8), 2GB Ram, SATA RAID external drives; 1GB Ram; FCP6
  • James Mol Level 3 Level 3 (675 points)
    Currently Being Moderated
    Sep 6, 2010 4:39 AM (in response to Andy Thomas)
    Andy, have you tried changing your security???

    I have not as of yet since mine is still working at the office, at least at the main Base station but it is something you might try. Let us know.

    We have two Airport base stations on our building. Now I don't remember all terminology, but the main is connected to a modem set on through mode. The ABS does all the communicating with my internet service provider. Somehow it is set to extend the network via ethernet.

    The second is hard wired to the first via ethernet and extends the network. This one I still cannot connect to. I am thinking I will need to leave my iPhone next to it and reset it from my office.

    At home I have two, with the first one as above, but it is set, in wireless mode to "Extend a wireless network".
    Power Mac Dual 1.4GHz G4; iMac Core 2 Duo, Mac OS X (10.5.8), 2GB Ram, SATA RAID external drives; 1GB Ram; FCP6
  • Andy Thomas Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 6, 2010 6:04 AM (in response to James Mol)
    James,

    Just to confirm on mine. i seem able to use it on public wifi (I'm on one now) it's just my airport it's struggling with.

    I think it's more likely to be an ip clash that the iPhone doesn't report because it worked last night and then stopped working this morning and I changed nothigh on the router.

    I have quite a few apple devices in the house (7 to be precise) + a windows 7 netbook . Which is why I tried a static ip address at the higher end of the numbers e.g. 10.0.1.20 and still no joy.

    It could be some funky security setting but it doesn't explain the intermittent nature of it. What setting do you reckon I should have ?

    To be honest we have a few days to go to get to 4.1 so I'll wait until then, I have 6 devices working fine and I don't want to mess around with the router too much and i have a pretty strong 3G signal anyway and unlimited data do it's not preventing me doing anything.

    As you say if I take it to a genius bar they'll just hook it up to their network, see it working and hand it back to me saying "no fault".

    Completely clutching at straws here, but it stopped working the day after Mr Jobs's event last Wednesday, have there been any quite airport updates since then that could have messed this up?

    If it persists after 4.1 I'll take it in as it's still under warranty.
    iPhone 3GS, iOS 4, MacPro, Macbook Pro
1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.