Previous 1 2 3 4 5 Next 72 Replies Latest reply: Sep 24, 2010 11:57 PM by Michaelw352 Go to original post
  • icirutrut Level 1 Level 1 (0 points)
    Hey all. I'm in the same boat....kind of. I have an old iPhone 3G that's running firmware 3.0 and my girlfriend just got her mom's old iPhone 3G. I activated the new phone with AT&T and updated to firmware 4.0.2 then couldn't connect to my home WiFi (Netgear WNDR3700). I'm thinking it must be related to the firmware because my iPhone 3G with 3.0 works just fine. But, the girlfriend's 3G with 4.0.2 won't connect; I just get the "unable to join network" message. I've gone through and reset everything and tried again, but to no avail. I'm also connecting to my router with 2 PCs (hardwired), and a late-2008 Aluminum MacBook (wireless) as well as my iPhone with no problems. I just can't get hers to work with the 4.0.2. I have a call scheduled with Apple Support, so maybe they'll have some answers. I'll keep checking back and will update if I get anything good for everyone. Good luck!

    P.S. I'm an IT student and eager to get into the field. Some of you have mentioned that your in IT. What do you guys do and how did you get your start? I don't want to get this thread off track, just curious. Thanks again!
  • matija0610 Level 1 Level 1 (0 points)
    hy

    and I have same problem !
    after update os from 3.1.2 to 4.0.1 problem begin!

    "unable to join the network"
    my warranty lapsed 2 day before update !

    pls.help! i love my iphone so much.. but i love "wifi on my iphone"

    sorry on bad eng.. i am from Croatia
  • Kentucky Charlie Level 1 Level 1 (0 points)
    Back from a trip to the Genius Bar. After a "restore" and some checking of the settings behind the Apple network - still nothing. Eventually he determined that it was the dreaded "hardware" problem.

    But here's the good news! Even though it was out of warranty - Apple will replace the phone.

    Still a great company.
  • James Mol Level 3 Level 3 (685 points)
    I do hope yours is the rule rather than the exception. I best make an appointment soon.
  • icirutrut Level 1 Level 1 (0 points)
    Well, it seems that you are not the rule, but, indeed, the exception. Went to the Genius Bar tonight. The did a "more comprehensive" restore, and still no Wi-Fi. He told me it was a "hardware problem" and I either had to buy a replacement for $199 or buy the iPhone 4. No thanks. So, it seems that someone somewhere just figured they would brick all our old iPhones with bad software so we would have to upgrade. That's my .02, anyway. So, I'm gonna try to downgrade to 3.0 and see what happens. Sorry. Wish I had better news.
  • James Mol Level 3 Level 3 (685 points)
    It may have to do with how long you are out of Warrenty.

    The genius said that the software update was not the cause, which is what I would expect them to say. He could see how the install process might cause something to go haywire, but not the software itself.

    He did mention that there had been some where the antenna connection had broken. Could be. He also mentioned that the chip can go bad and you would know it by a greyed out wifi setting. Since the wifi and Bluetooth share the same chip, if the wifi goes out vio the chip, the bluetooth will probably go out. I guess the only real way to know is to take it apart and test the componts.

    After examining my phone, he said it would have to be replaced if I wanted wifi. Since the phone was a week out of Warrenty and i had just been in just prior to my warrenty expiring, he replaced it free of charge with another 3G.

    I am curious how out of Warrenty Kentucky Charlie was. By deciding not to get a replacement, if it turns out to be a software or install issue, then you might get the problem fixed with an update. Just report your problem using the links above. If you were running leopard and registered as a developer, you might be able to send in a file that would help them trouble shoot.
  • Kentucky Charlie Level 1 Level 1 (0 points)
    My warranty expired in July, so I'm not that far out. Since they don't sell the old model any more, they had to order one. I'm wondering if the new phone will be under warranty. I assume it will be.
  • suresure555 Level 1 Level 1 (0 points)
    God I hate not having the net, someone may as well cut off my water supply!

    I had the password problem first, I had the full strength wifi signal, I even had the whizzy round thing but still no net, just the eventual nag message. So, for those that have an iPod Touch and/or iPhone 3gs (that still connects to your home wifi ok) as well as an iPhone 4 try this. I’m not promising tho peeps but it worked a treat for me:-

    First (and if your bothered) do a quick comparison between the network settings across devices (IP Address, Subnet Mask, Router & DNS). I found that none of them matched between my iPod Touch (which connected fine) & my iPhone 4 - how this happened I have no idea; Second, disconnect (ie. select ‘Forget this network’) ALL your Apple devices from wifi then, if you want, reboot the lot afterwards to be sure; Third, re-connect the devices but starting with the iPhone 4 FIRST. Try it, if ok connect the rest.

    I found afterwards that the network settings aligned except for the IP address (by a single digit) and now my connection is lightning fast as before on all my devices!

    Good luck!
  • James Mol Level 3 Level 3 (685 points)
    suresure has a good idea. I didn't think to check these, but in his case it worked.

    I'd be interested in what others who still have problems found out when they checked their network settings across devices.
  • Andy Thomas Level 1 Level 1 (5 points)
    Holy *^%# could it really have been that simple, based on the above I just turned did a forget network on my iPad, turned off the wifi, then turned on the wifi on my 3GS and bingo it hooked up., then turned on my iPad and hooked up to my wifi, and bingo they both work now ( for the last hour)

    So basically it could be that the iPad was preventing my iPhone from connecting.

    The iPhone now has the lower ip address.

    Will let you know if it stays solid
  • James Mol Level 3 Level 3 (685 points)
    Do you recall how your network settings compared before you did this?
  • Andy Thomas Level 1 Level 1 (5 points)
    Sadly it didn't last long. I still think my theory of it being a clashing IP address is where it's at. Something in the the way the router si handing them out.

    I'm not sure how much more effort I can be bothered to put into trying to fix it, such a shame. I even turned off wifi on my Mac pro and iPad to see if theta was it, rest my network settings on the iPhone, but no joy, so I think my experience this morning was a fluke, and only lasted an hour
  • Dubdove Level 1 Level 1 (0 points)
    Hi Andy,

    there seems to be a growing number of people who have no problem connecting one iphone/ipad device to their home network but get a problem when they add a second one.

    Everything works fine for a short while and then one of the devices no longer connects. But it takes a long time to realize it's some conflict between the devices that is causing the problem.

    I'm seeing this same problem since getting a new ipad - either it or my older iphone will refuse to remain connected to my wifi network. Hours of fruitless searching for a solution (including trying various settings, updating router firmware, changing passwords, updating iOSs, restarting everything in different sequences, disconnecting possible interfering devices, etc.) just left me frustrated but no nearer a solution.

    So now I simply disable my home wifi connection to my iphone and curse apple's poor wifi implementation.

    Hoping apple will one day recognise this issue and who knows, maybe even fix it...

    Dubdove
  • James Mol Level 3 Level 3 (685 points)
    Hi Andy,

    Thanks for the insight. This is a slightly different issue in terms of the cause of the problem and you may have hit on the solution. If you would be willing (since it was not the problem I had, I can't start it), would you please start one.

    If at a loss for the title, maybe "iOS unable to connect two devices at once" or "Cannot connect two iOS devices at the same time". You well may be able to come up with a better one.

    That way others could join in and could be referred to the Apple Feedback sight to report a bug at http://www.apple.com/feedback/iphone.html to choose Select Feedback Type: Bug Report then fill out the form. With a number of people reading the topic and posting, then submitting feedback, Apple might see a problem, then fix it if they can duplicate it.
  • SliceofKimbo Level 1 Level 1 (0 points)
    I have an iphone 3g and am having this same wifi issue connecting. Always the same message "Unable to join network", even though other computers and an iphone 3g are connecting.

    I upgraded to 4.0 and this is when my wifi not connecting started. I tried 4.1 and even tried downgrading to 3.1. Both didn't work.

    I took the phone into a genius bar and they restored it but it still didn't work. They did offer to fix the phone and send it back to me though. I haven't taken them up on it as I need the phone for work and can't wait the week it would take to fix. They did offer a replacement phone for 30 bucks.

    Is it possible that somehow upgrading to 4.0 burned the chip?