Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPod touch 4G on Mac OS X 10.4?

Hi all

I have a 6yr old iMac running Mac OS X 10.4.3 ... I was all set to order a new 4G iPod touch but read in the Tech Specs that the System Requirements include needing to be running OS X 10.5.?

If the iPod only "talks to" iTunes when it's connected to the Mac, and the new iTunes 10 will run on OS X 10.4 (I've checked this), why does the new Touch need 10.5?

Any input gratefully received. Apologies if I'm asking a dumb question!

Cheers y'all

iMac G4 1.25Ghz 17 with SuperDrive, Mac OS X (10.4.3)

Posted on

Reply

Page content loaded

Sep 2, 2010 12:33 PM in response to Goldenboy74 In response to Goldenboy74

Don't worry folks ... it seems Apple have changed the System Requirements for iTunes 10 to "needs OS X 10.5" ... that kinda answers my question for me.

So I need a new Mac before a new iPod touch!

Sep 2, 2010 12:33 PM

Reply Helpful
User profile for user: Goldenboy74

Question: iPod touch 4G on Mac OS X 10.4?