1 2 3 Previous Next 198 Replies Latest reply: Dec 23, 2010 11:08 AM by joopydog
Thorsten AB Level 1 Level 1 (0 points)
Hello,

I have a MacBook Pro and an iMac with Mac OS X 10.6.4 on both computers. In addition, I updated both computers to iTunes version 10 this morning.

The issue I am facing is that every time I try to import CDs (original ones) into iTunes, both computers start to behave really strange. But let me describe this in more depth:

- I insert the CD
- Snow Leopard recognizes the CD and shows it in the Finder
- iTunes opens
- Behavior 1: iTunes starts going crazy. It shows the CD for a few seconds and then starts to jump between the CD and the Music section, constantly (like, at least, 5 times a second or so). In addition, iTunes won't react to any input, anymore. This goes on for 20 seconds or so and suddenly the CD is gone in iTunes. The Finder won't show the CD, too, although it is still in the DVD drive.
- Behavior 2: The behavior is more or less the same despite the fact that iTunes and the Finder won't unmount the CD. Instead iTunes keeps jumping between the CD and the music section. Furthermore, the Finder shows not only one but three CDs from which two are greyed out, and the CD icon is jumping all over the background image of the Finder. In this case, it only helps to reboot the computer (a restart of the Finder does not help) to get the two CDs unmounted.

Unfortunately, both behaviors do appear on both computers. Might that be a software bug or am I doing anything wrong? It is certain that both computers were able to import CD before version 10 of iTunes, and it is also certain that both CDs can be imported to iTunes (I did that years ago). But I need the songs in a different format, and so I have to do it again. Sadly, it does not work anymore. Does anyone know an answer to this or can help in any way?

Thanks!

Thorsten

MacBook Pro, Mac OS X (10.6.4)
  • 1. Re: iTunes 10 won't import from CD
    Lukev Level 1 Level 1 (0 points)
    I have exactly the same issue and so do two of my colleagues

    Hope they release a fix soon
  • 2. Re: iTunes 10 won't import from CD
    disconnekt Level 2 Level 2 (490 points)
    I'm having an importing issue on my iMac too. The disc is recognized fine and can be played, but when I try to import it I get an error saying the disc cannot be found. I tried several CDs and it was always the same. I was in the middle of importing all my CDs when I updated to iTunes 10, and now I'm stuck. A pretty serious bug, indeed.
  • 3. Re: iTunes 10 won't import from CD
    ornleifs Level 1 Level 1 (0 points)
    The same here, I was trying to import a new CD and nothing happened there was no sign of the CD anywhere and I had to turn of itunes to get the CD out of the computer. It´s obvious that Apple released this way to soon and Ping is full of problems and bugs too.
  • 4. Re: iTunes 10 won't import from CD
    cmitch51 Level 1 Level 1 (0 points)
    My problem is slightly different. When attempting to import a CD, I get a notice saying that iTunes "cannot locate" the disk, which is of course in the drive and has already been read by Gracenote.
  • 5. Re: iTunes 10 won't import from CD
    RamaSod Level 1 Level 1 (0 points)
    While I was unsuccessful in importing a CD, I opened the preferences menu to confirm my import settings (Apple Lossless, Automatic) and noticed that the import continued correctly while I was in in the preferences menu.
    While this is a "messed up" fix, it may help until the software coders at Apple solve this fluke of code.
  • 6. Re: iTunes 10 won't import from CD
    mattheiszen Level 1 Level 1 (0 points)
    I have the exact the same problem as the original poster. Really nice, now I can't listen to my CD's anymore. Worked fine before updating to iTunes 10.
  • 7. Re: iTunes 10 won't import from CD
    Tex Arcane Level 1 Level 1 (0 points)
    I'm having the exact same problem as the original poster. I'd go back to 9.2.1 if I could but the Library can't be used by it since it has been upgraded to 10.
  • 8. Re: iTunes 10 won't import from CD
    atomicpdx Level 1 Level 1 (5 points)
    I'm having the same problem. I think the problem is with the "Automatically CD retrive names from internet" function. I went to system preferences and turned off the option to automatically open iTunes. I re-inserted the CD and found it in the finder. I clicked on a track to play, which opened iTunes. iTunes played the track, but when I asked it to retrieve CD track names, the CD disappeared, stopped playing, and couldn't be found in the system Finder.
  • 9. Re: iTunes 10 won't import from CD
    stevemca Level 1 Level 1 (0 points)
    Same here, insert disc, Itunes 10 goes crazy and disc dissapears from finder.

    I have disabled Import CD Track Names and all is good.
  • 10. Re: iTunes 10 won't import from CD
    Tex Arcane Level 1 Level 1 (0 points)
    Turning off "Automatically retrieve CD track names from Internet" keeps the blinking wackiness from happening. The only draw back is you have to type all the information in yourself.
  • 11. Re: iTunes 10 won't import from CD
    Thorsten AB Level 1 Level 1 (0 points)
    @RamaSod: I wanted to try your solution, but I was more and more stuck with the disappearing CDs in iTunes. So I couldn't try this one.

    @atomicpdx: Great solution. I just tried it with 5 CDs from which I knew that all of them could neither be played in iTunes 10 nor be imported to iTunes 10. But once I unchecked the "automatically retrieve CD track names from Internet" option, it worked. I can play and import CDs again.

    Although this is not a real solution (Apple should fix it), it still gives me my iTunes back, and typing the names and all of that, isn't a big deal either (at least for the moment).
    Many thanks!!!

    Thorsten
  • 12. Re: iTunes 10 won't import from CD
    Will Boyd Level 1 Level 1 (0 points)
    Hey!
    I am having the exact same problem with my iMac! I had a CD burned for me yesterday, and when I tried to import it, the "Audio CD" icon flashed up on the sidebar briefly and went away. The only way I could get the CD onto my Library was through Home Sharing with a MacBook that had iTunes 9. A store bought CD, however, loaded just fine onto my iMac.
    If anyone finds a solution, please reply! It would be greatly appreciated!

    Will Boyd
  • 13. Re: iTunes 10 won't import from CD
    Nick Bramhall Level 1 Level 1 (0 points)
    I'm having the exact same issue (with shop bought CDs here) as the original poster. The solution offered above (disabling getting album from the internet) is a good temporary fix and has allowed me to import a few discs I bought yesterday. Hopefully Apple will get a fix out for this soon as manually typing in the album information is hardly the most fun way to spend my time.
  • 14. Re: iTunes 10 won't import from CD
    tcole2775 Level 1 Level 1 (0 points)
    Exact same thing just happened to me!!!!!!!

    This *****!!! I wish I had not updated!!!!!!!!!!!!!!!!!
1 2 3 Previous Next