Previous 1 2 3 4 5 Next 126 Replies Latest reply: Feb 8, 2016 6:29 AM by turingtest2 Go to original post Branched to a new discussion.
  • Joseph Kannry Level 1 (5 points)

    I misunderstood. Thought turning off group by album artist would fix album splitting problem. Misunderstood. Compilation is answer. Will check compilation multiple tracks tomorrow.

  • bsteed Level 1 (5 points)

    Hi. If people are still having trouble with this, I have an efficient solution.


    All you need to do is select the whole album, go to the Get Info section, *delete* the album title and click enter so all of the tracks in that album have no album title (but the artwork will remain), then select all the tracks again and go back to the Get Info section and re-input the album title and it should all be grouped.


    I just did it a few seconds ago for my Polysics discography.


    Hope this helps.

  • turingtest2 Level 9 (68,886 points)

    Ria777's particular problem was addressed over 18 months ago.


    What you need to do to fix any particular grouping issue in iTunes depends on what the root causes are for the issue at hand. There is no magic bullet of one way to fix things because there are different causes, albeit some more common than others. If you find a fix for your problem that works for you that's great, but it is worth appreciating that for others there may be other underlying triggers of their split albums, and that a fix that seems to work OK in iTunes may not actually improve matters when the album is transferred to an iPod.


    The article on Grouping tracks into albums deals not just with the all the potential causes of multiple covers, but other related issues such as merging multi-disc albums into one, ensuring correct track order, keeping Greatest Hits albums separated etc.



  • RoentgenRay Level 1 (0 points)

    Many thanks for this really informative article, I can now group compilation CD as one album! If only I had found it last week, I would have saved so much time.

  • feigo512 Level 1 (0 points)

    can read this


    The easiest thing so far is to select all the songs from the same album and edit the field called "album artist"

    After that all the songs will be grouped into a single album. And you can still see multiple artists for an individual song.

  • turingtest2 Level 9 (68,886 points)

    Ria777's particular problem was addressed over 18 21 months ago.


    I recommend you read Grouping tracks into albums for when setting a common album artist isn't enough to get things sorted.



  • Hardik Gala Level 1 (0 points)


    All solutions are found here.

    1) select all files in itunes u want in same album

    2)right click and select get info.

    3) then under multiple item information select options tab.

    4) check part of compilation and yes.

    5) save changes

    6) be happy and like my reply if it was useful.



  • turingtest2 Level 9 (68,886 points)



    If you'd care to read my post immediately before yours you would note that the original poster of this thread is probably no longer interested. If you'd followed the link to my article you might appreciate that Apple's support document isn't the solution to every user's issues, even if it has proved enough for you.


    Also, please note that you should not request people "like" your replies, or mark them as helpful or solved.



  • Ricky Barnaby Level 1 (25 points)

    I am the original poster of this discusion and the reason it is still open is because there came in so many answers and then came in further questions and even more answers that it started to become a interesting and helpfull post for many people.

    I would like to say this is solved for me. And since the original post i refered to this post again and again for help.

    There are so many answers here and the post is so active i have chosen not to mark it solved even though YES IT IS SOLVED for so many in so many different ways.

    I am apreciative of everyone who has come with answers here and hope that it can continue to be of help for others.

    Thank you everyone. Thank you.

  • SkyHook17 Level 1 (95 points)



    No typo's on this track and all the group info cloned except for comments, track name, and track number.  I just gave my single roque track a fictional album name and saved it, then changed it back to its correct name, actually cut and paste from the original album name inside the track, and now it has joined the album. 


    Obviously iTunes doesn't update data if the form thinks there is no change;  one bad bit and nothng happens until you overwrite it. 


    Thanks for the idea;  I was pulling my hair out. 

  • dubiousraves Level 1 (0 points)

    I have used the "get info" solution to fix this problem in tTunes. The problem, as others have mentioned, is that a guest artist on the track causes the track to be split into a separate album with the same title. So, that fixed. However, when I transfer the album onto my ipod, the album ends up split in 2 on the ipod. Anyone have a fix for this?



  • dubiousraves Level 1 (0 points)

    Hi. 2 problems with your solution: 1. The tracks, while assembled into 1 album, are out of order. 2. They don't transfer as 1 album to an iPod. They are split up into multiple albums on the iPod.



  • turingtest2 Level 9 (68,886 points)

    I'll say it again: Read Grouping tracks into albums. The answer will be there.


    For an iPod classic all artist fields on an album should be identical. Move guest artist information into the track name or comments field, or treat as a compilation.



  • brightonjohn Level 1 (0 points)

    The solution that I found for my iPhone is to use the 'get info' technique for making albums back into albums and then renaming them in the 'get info' tool so that with a number as well as the new name I can drop them into dedicated playlists. This applies in particular to double albums such as "War of the Worlds" which, with a very little initial effort now plays right through and in the right order.  Don't forget though that now you need also to sync the specific playlists as well. I've had to do this for Les Mis as well.

  • Klahane Level 1 (0 points)

    I've been struggling with this issue in iTunes 11. I tried a number of solutions, but the one that seems to work for me is:

    You can usually fix this by selecting every song in an album, select Get Info and place a checkbox next to every box except the Title of and Track number of the song.



    Of course, there may be various causes, but manually matching each field that was filled in didn't work for me, but checking all the fields that should be the same (even if they are blank or appear to be the same) grouped songs into a single album as they should be.

    This makes sense to me.

Previous 1 2 3 4 5 Next