Skip navigation

iTunes 10 add to library not working

270704 Views 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew RSS
1 2 3 ... 12 Previous Next
Boudjtastic Calculating status...
Currently Being Moderated
Sep 2, 2010 6:05 PM
I was trying to add some MP3's to my iTunes collection tonight and am seeing that iTunes 10 add to library function is not working at all.

Really irritating.
MacBook Pro, Mac OS X (10.6.4)
  • Jim MacCormaic Level 4 Level 4 (2,635 points)
    Currently Being Moderated
    Sep 2, 2010 7:06 PM (in response to Boudjtastic)
    I'm afraid this probably won't be of much help to you, but my experience differs.

    Not only can I add music to my library, but I find the process to be much quicker in iTunes 10. Previously, iTunes indicated that it was 'processing' the files before it went on to copy them. The processing step now doesn't happen.

    Do your MP3s play in Quicklook? Is there anything different about them compared with files you've successfully added to your library with previous version of iTunes?
    2.66 GHz Core 2 Duo 24" iMac; 800 MHz 17" iMac G4; 2.1 GHz 13" MacBook (white), Mac OS X (10.6), AirPort base station and Express; LaCie (160GB) and WD (1TB) external HDs
  • SegWayne Calculating status...
    Currently Being Moderated
    Sep 2, 2010 7:41 PM (in response to Boudjtastic)
    Sorry to add a "me too" but I have an identical setup (10.6.4, iTunes 10.0) on my iMac and can't import or "Add to Library" either. Either the menu option or drag/drop just acts like it's doing something, then does nothing at all. The movies are never imported or added in any part of the library that I can see.

    I'm trying to add mp4 movies (.m4v file names) instead of mp3's though.

    Sounds like a major bug to me.

    Wayne
    iMac 20" 2.16 ghz core 2 duo, Mac OS X (10.6.4)
  • mauijiminar Level 4 Level 4 (1,605 points)
    Currently Being Moderated
    Sep 2, 2010 7:48 PM (in response to Jim MacCormaic)
    I downloaded a song from I tunes 10 today and it was WAY faster.
    2.66 Ghz Intel Core 2 Duo, Mac OS X (10.6.3), I Phone 3Gs, iPad wi fi 64 gb, Apple TV Airport Express, Time Capsule
  • SegWayne Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2010 7:59 PM (in response to Boudjtastic)
    FOUND IT!!!!

    (At least for me)

    Went in and checked the Preferences. Under "Advanced" the choice for "iTunes Media Folder Location" was completely and totally blank. Pointed it to the correct folder again and all is -- at least for now -- right with the universe.

    Hopefully it won't do like 9.x and automagically revert to the default location each time you restart.

    Wayne

    Message was edited by: SegWayne
    iMac 27" 3.06 ghz core 2 duo, Mac OS X (10.6.4)
  • -SHAWN- Calculating status...
    Currently Being Moderated
    Sep 3, 2010 11:02 AM (in response to SegWayne)
    didnt work for me.. still wont import. i dragged a whole folder (all files play with preview) mp3 files wont import. out of 17 files 2 worked... tried multiple times
    macbook pro, Mac OS X (10.6.4)
  • akajezebel Calculating status...
    Currently Being Moderated
    Sep 4, 2010 4:16 AM (in response to Boudjtastic)
    I have the same problem. I downloaded an mp3 from a site I usually download from without any problems whatsoever. I updated to iTunes 10.0 (67) this morning and downloaded said mp3 from said site and it will not import into iTunes. It plays in Quick Time Player, but not iTunes. I've checked all my preference settings in iTunes and they are just as before the update. I can't think what the problem could be. I've tried to drag the file into the window, I've tried using the "Add to library" function, I've tried simply clicking the file to open (set to automatically open in iTunes) but nothing works.
    MacBook Pro, Mac OS X (10.5.8)
  • joecarlsonstudio Calculating status...
    Currently Being Moderated
    Sep 4, 2010 10:03 AM (in response to Boudjtastic)
    Same problem -iTunes 10 import. In my case it is mp4 movie created with handbrake. I have tried all importing options including copying to the iTunes Media...Movies folder. The file is 1.75gb. I have never imported a full length film into iTunes before - anyone know if there is a maximum file size for iTunes?
    PowerMac MacMini MacBook Pro, Mac OS X (10.6.4)
  • joecarlsonstudio Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 4, 2010 10:15 AM (in response to joecarlsonstudio)
    FYI... Re: iTunes10 import problem. I changed the tag on the movie file from .mp4v to .m4v and the import worked fine??
    PowerMac MacMini McBook Pro, Mac OS X (10.5.4)
  • Graflin Booth Calculating status...
    Currently Being Moderated
    Sep 4, 2010 5:29 PM (in response to Boudjtastic)
    Same problem. Running iTunes 10 on OSX 10.5.8. Cannot add songs to iTunes using "Add to Library" or by dragging and dropping onto iTunes window.
    Mac OS X (10.5.8)
  • dennishay Calculating status...
    Currently Being Moderated
    Sep 5, 2010 12:26 PM (in response to Boudjtastic)
    Upgrading for me made iTunes forget where the music library was (I use an external HD)... putting back the directory fixed it for me.... goto advanced settings, iTunes Media folder location, change... select media folder "iTunes Library". If you don't know where your songs are exactly then right-click on a song and "show in finder", that will give you an idea.

    I was able to add mp3's etc to itunes after that...
    macbook pro, Mac OS X (10.6.4), iTunes 10.0
  • dennishay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 5, 2010 12:33 PM (in response to dennishay)
    PS... I didn't see any menu option on iTunes to "report a bug" so I'm hoping this note makes it to the dev team... also maybe add a "report a but" menu option under help or something... just saying
    macbook pro, Mac OS X (10.6.4), iTunes 10.0
  • Graflin Booth Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 6, 2010 12:04 AM (in response to Boudjtastic)
    I also use an external HD to store my iTunes library. It is set correctly in the Preferences file. Still will not import tracks.
  • Stumblebuny56 Calculating status...
    Currently Being Moderated
    Sep 6, 2010 12:12 PM (in response to Boudjtastic)
    Same issue here and thanks for posting that the location of the iTunes content went back to the default after upgrading to 10....I'm sure I would have been scratching my head over that one for awhile. I've got all my content on Netgear Stora MS2110 home server and after adding a few new MP3s using my Macbook I decided to update my iTunes library on my PC, but using the "File/Add File to Libary" didn't work. Once I updated the path to my content I was able to add at least one of the MP3s on my server to my PC iTunes library using the File drop down menu or drag and drop, but not all of them - strange. Definitely a bug that needs fixing.
    PC, Windows XP, MACbook OS X
  • Stumblebuny56 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2010 12:22 PM (in response to dennishay)
    I just used the "Provide iTunes Feedback" under the Help menu.
    PC, Windows XP, MACbook OS X
1 2 3 ... 12 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.