Previous 1 7 8 9 10 11 12 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew Go to original post
  • ken.atwell Level 1 (0 points)

    +1 to wares's post.  I got into a situation were movies (local files, not iCloud content) would appear in "Recently Added" but not in the library itself.  Nevertheless, turning Music Match off restored them, and re-enabling Music Match did *not* remove them

  • gujuvoodoo Level 1 (0 points)

    +2 to wares's post, I just did the same thing, looks like there must be a bug on how iTunes renders the library to the user vs what the actual library is when Match is turned on, maybe its waiting for some kind of synchronization, who knows but very strange indeed...

  • jh1 Level 1 (0 points)

    To fix the problem - follow these steps:



    > SELECT STORE (from top menu)



    And you will be able to see your video and music content you have manually added via "dragging" or "add content".



  • williamsdn Level 1 (0 points)

    I have tried everything listed:  sign out/in; drag to "add to itunes" folder; clicking on "add to library"- nothing in working.  I need this mp3 into itunes to burn a disk. 

  • Vulturem Level 1 (0 points)

    Installing Quicktime solved the problem for me.

  • RonceMonce Level 1 (0 points)

    I think I found a way, I had this problem too.

    I don't know for Mac 'cause i never owned one, this is for windows.

    Might be a little late post.


    1) In the folder album highlight and right-click all the songs and click on Properties.


    2) Go in the Details tab


    3) Fill in the Media section.


    Hope it helps! (It works for me on Windows).

  • wjtaggart Level 1 (5 points)

    Thanks!  Just noticed this issue and found this post immediately -- good fix.  Funny it took me so long to notice.

  • rbizza Level 1 (0 points)

    I had the same problem where I couldn't see a movie after adding the folder to my library.  I found this forum.  I tried a few things and nothing worked.  Anyway, in a last ditch effort, I saw that my file name had a few dashes - - - in it, and after I took them out, voila, they showed up.  So check the filenames everyone.  It may be as simple as that.  Later. 

  • Nillie Welson Level 1 (0 points)

    I don't recall seeing what worked for me listed in this thread...


    I wasn't able to see albums imported via 'add to library' listed by artist, and I wasn't having any luck with this thread as I don't have Match turned on.


    I compared 'get info' information for an album that was appearing appropriately in my iPod with one of the recently imported albums and found one delta: 'part of compilation'.


    Taking a leap of faith, I changed this setting to 'NO' and resynched my iPod at which time I was able to see the recently imported album. I updated every CD imported this way via the 'recently added' playlist and then resynched again, and all was well. Hope this helps.

  • hobbes8calvin Level 1 (0 points)

    Based on a previous poster's (slakjaw) suggestion, I was able to fixed the problem by:


    1. Deleting the last purchased song from itunes, but not from icloud
    2. Then I re-downloaded the same song from itunes match
    3. All of the items that I had tried to add in the last two days magically appeared in itunes (recently added smart playlist).
  • hobbes8calvin Level 1 (0 points)

    Thanks slakjaw, your idea fixed my problem.



  • gregsta82 Level 1 (0 points)

    I am running iTunes 10.7 on a 13" MBP (mid-2009) with OSX 10.8.2. I have been having the same problem. What I noticed was the the file was being imported into my iTunes media folder and placed into a sub folder with the same name as the file.


    I had two of the factors that some of the responses above mentioned. First iTunes match was on, secondly the files I was trying to add had a "-" in the title. Switching iTunes match seemed to address the issue as when I restarted iTunes the movies I had previously tried to add appeared in my library. I tried adding another file with a "-" in the title and it worked fine. I switched iTunes match back on and restarted iTunes and the file continued to appear in my library and seemed to play fine.


    With iTunes match still on I attempted to add a file without a "-" in the title and it seemed to import OK and the file played fine. I then attempted to add another file with a "-" and it also appeared to work OK but as iTunes match was still "matching" my library I am going to try this again soon to confirm that turning iTunes match on then off again seems to resolve the issue.

  • wolfgang ubi Level 1 (0 points)

    I was just going nuts trying to figure out why iTunes 10 wouldn't load my .m4v movies. Then I took out all punctuation marks, including parenthesis, and viola!!

    So give that a shot before you take any more drastic measures....

  • wade0955 Level 1 (0 points)

    Have to agree with you! We're an Apple household through and through with over $35.000.00 of Apple gear in our home yet our friends at Apple don't seem to care about that. In the past 5 years I've purchased several thousand dollars worth of media off the iTunes store but, lately, all I seem to have is problems with them. Items that play on AppleTV but not on the computer I dowmloaded them on (?!), and they won't play on any of our iPads either! Called them, stayed on hold for almost an hour just so they could tell me that it's a hardware issue (which it wasn't!). I love Apple products but I fear that they're suffering from their success. I went away from PC's because of this kind of stuff! My work PC hasn't quit once in the last 4 years, perhaps it's time to go back where I'm wanted?

  • Feisal Mansoor Level 1 (0 points)

    Same problem here: Added songs, well albums really, from playlist i.e. .m3u; songs and album turn up in play list but not in main Music library.

    Solution: Select playlist, highlight songs, grab and paste on Library. When copying like this, the Library Music/Movies/Book/Radio all get highlighted but the actual files are not copied again. Voila, the Albums and tracks all turn up in the Music Library.

    I don't know why it works, but it does.