Previous 1 8 9 10 11 12 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew Go to original post
  • adams_apple Level 1 Level 1

    Hi all - jh1's solution treats the problem. To reiterate, here's the behavior that's observed:


    1. User is in iTunes logged into iTunes Match
    2. User tries to add local conent (e.g., by ripping CD using iTunes) to library.
    3. Files are added to filesystem, which is under iTunes management.
    4. Track data does not show up in Music.


    As jh1 says,


    1. Go to Store > Turn Off iTunes Match
    2. Observe that the recently imported music shows up in Music.
    3. Go to Store > Turn On iTunes Match


    This will get you up and running. I had a telephone discussion with Apple support, and a bug report has been filed, so hopefully the workaround will be unnecessary in the future. But this does the trick for now. Nice work, jh1!

  • javierjose Level 1 Level 1

    Thanks you @adams_apple. I had the same issue until I try what you just describe. It seem that this happen because my iTunes Match just got renewed. So I think most of the people here got this issue because of that.

  • pandask Level 1 Level 1

    Many people are not using iTunes Match and for those of us, the problem still remains :-(

    This is very frustrating.

  • javierjose Level 1 Level 1

    I'm sorry pandask. I know it's frustrating. Have you try to log out from your iTunes Store account and logging back?

  • l-town Level 1 Level 1

    Same. Last album I added (downloaded MP3s) - plays/shows up as fine in "Recently Added," but is nowhere to be found in general "Music." I can't search for it or find it. What happens when it gets bumped off of my Recently Added list? Does it disapper from iTunes?

  • l-town Level 1 Level 1

    I'll be damned - that worked!

  • dcortello Level 1 Level 1

    I went to the Apple store and the geniuses had no clue about this problem.


    Reacting to a prompt in ITunes, I just signed out of the ITunes store and then signed back in and everything I had ripped showed up in my ITunes library.

  • reii_peeps Level 1 Level 1

    I also had the same problem.  I'm using windows 7.  Some of the folders can't be added to my itunes library.  I simply changed the name of the folder of the music album then, problem fixed.  Hope this works for some of you guys

  • primalman Level 1 Level 1

    This worked for me.

  • LadyBD Level 1 Level 1

    It did NOT work for me.  I don't have iTunes Match, in fact, I've never downloaded a single piece of music from the iTunes store.  EVER.  I just downloaded a piece of music and it attempts to launch.  When I do a "search" I can see the new songs in the search list.  My options are to "Play Next", "Add to Up Next" (what on earth does this even mean?), or "Go To iTunes Store". 


    None of these options work, the music does not play.  I get the little graphic "pop" when I double click on the song on my desktop, as though it's trying to launch, but iTunes just sits there.


    Any suggestions?


    Using:  Mountain Lion

    Mackbook Pro

    iTunes 11.0

  • LadyBD Level 1 Level 1

    Addendem: Ok... after turning my computer on and off, I can add the new music if I drag them into an existing playlist.  Bu it doesn't appear in my music folder, and when added manually iTunes can't find it / won't play it.  This is ridiculous.  Sorry - I know, preaching to the choir. 

  • jacypoo808 Level 1 Level 1



    My problem:

    import CD.

    appears to be imported - green checks by each song when import done

    look at library - nothing

    try to import again - iTunes say I am duplicating and music is already in library

    can't find it

    rinse / repeat.


    went into all the forums related to my problem - nothing worked.

    didn't want to attempt uninstall / install - not all my stuff is in cloud yet


    finally tried the fix from yacoboy


    WORKED! thank you!

  • jayjayuu Level 1 Level 1

    Just had this problem as well.  Had iTunes import a CD but it couldn't be found.  As someone else suggested, turning off iTunes Match was the answer.  After doing that, the album appeared.  A bug presumbly.  Could be that because the music is an Arabic Sufi album, iTunes Match couldn't make a match....

  • Mj662 Level 1 Level 1

    I am also having the same issue,


    I added videos by dragging and droping but they don't show up. The itunes window hilights as if it is accepting the videos bit they are not theere after dropping them. I then try using QuickTime to send to iTunes for apple TV and they still do not show up, the strange thing is that when i use my apple TV to look at the content in itunes it is there and the video plays fine.

  • tom6040 Level 1 Level 1

    i had the same problem . fixed it by going to preference,import settings and then check mark box for use correctionwhen useing audio cd's