Previous 1 2 3 4 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew Go to original post
  • Joel D. Reid Level 3 Level 3 (815 points)
    Same for me. 10.0 on 10.6.4.

    Don't forget to +give Apple feedback+ so they know the details of the situation... what files cause it, which OS X versions it happens with, how widespread this issue is, etc.

    Sometimes the little progress window flashes as if it's going to copy the tracks into my iTunes Music folder (particularly if I launch iTunes by opening the tracks), but that window always vanishes instantly. No messages in console... no errors in logs or on stdout.

    If I 'drag' the tracks to the song section or the Library in the sidebar, it does outline the section and put a plus on the cursor, but nothing ever happens when I 'drop'. They play fine in QT Player, etc.

    I grasped at the straw of the earlier reports that the Library location would have been lost, but my Library has always been in the default location. My location was still showing correctly when I checked it, but I changed it to my Desktop (scary!) and changed it back. Everything already in iTunes still works but the switch and switch back didn't help.

    Ah, the pangs of being an early adopter.
  • Graflin Booth Level 1 Level 1 (15 points)
    Joel,

    The behavior you describe in your second and third paragraphs is exactly what I am seeing. Thanks for the accurate description.
  • mineo71 Level 1 Level 1 (0 points)
    Curiouser and curiouser....

    I was trying to add some MP3s as well. You're right - the add to library function isn't working.

    When I finally managed to put the files into iTunes, though, they turned up on the 'Recently Added' playlist - however the songs are +not in the main library+.

    So it's created another problem: how can I move something from 'Recently Added' to the main library?
  • Agent Mckay Level 2 Level 2 (230 points)
    I had a similar problem and here is what solved it. In itunes I had previously deleted several tv shows selecting the option move files to trash then I found I was unable to empty these files from the trash. And at the same time importing to itunes stopped working. None of the usual options for deleting stubborn files from trash worked, I finally went into each file and set permissions to read and write for all users AND I had to eject my external drive where the files were orignally stored in my itunes library. After all this I was finally able to delete these files. I then found I was now able to import files into itunes again. I also went through the folder path to my itunes library setting all premissions to read and write not sure if that was part of the final fix or not. Anyway it appears removing the stuck files and setting permssions fixed my importing issue.
  • iDav82 Level 1 Level 1 (0 points)
    I'm having exactly the same problem. If I try to add from within iTunes, nothing happens. If I put the files into the "Automatically add to iTunes" folder, then end up dumped in the "Not Added" folder.

    This is happening for EVERY mp3 I try.
  • janedoessis Level 1 Level 1 (0 points)
    I have the exact same problem. I can see the new files under recently added but that's the only place I can see them. OSX 10.6.4 iTunes 10 with no updates available. This is very frustrating!
  • ArtyFarty Level 1 Level 1 (70 points)
    If you haven't already found the answer to this it seems to be a permissions issue with all or part of the iTunes Media folder location.

    . Note the location from iTunes > Preferences > Advanced > iTunes Media folder location.
    . Using Finder locate the folder noted above and select Get Info.
    . On the Info page displayed click the padlock at the far bottom right.
    . Enter your Admin password.
    . Confirm that your user name has the Privilege Read & Write.
    . Click on the Cog Icon and select Apply to enclosed items,
    . A warning message stating that you can't undo this will be display, click the ok and wait for it to finish.
    . Attempt the Add to Library again.

    If this doesn't work you may need to repeat the steps above for the Everyone group.

    Hope this helps.

    Cheers ArtyFarty.

    Message was edited by: ArtyFarty
  • Joel D. Reid Level 3 Level 3 (815 points)
    Sadly, this didn't help me. Thanks for the idea though. I don't trust Finder's handling of permissions and tried the same thing in Terminal,
    sudo chown -R joel:staff ~/Music/iTunes ; sudo chmod -R u+rw ~/Music/iTunes ;
    even followed up with a ugo+rwx
    but yeah, no help.
  • ArtyFarty Level 1 Level 1 (70 points)
    Oh well worth a try.

    Just found another draw back to the permissions change/re-apply your Time Machine back up will see your whole iTunes library as having changed and back it up.

    Hey ho it worked for me but took a large chuck of my backup storage with it.

    Cheers
  • etstanger Level 1 Level 1 (0 points)
    This is not working for me either. I have done everything in the forum to no avail. This is a huge bug and I can't believe I can't import music into iTunes.
  • Xeonight Level 1 Level 1 (0 points)
    I hope this helps a few people:

    I had the same problem after i updated to iTunes 10, iTunes wouldn't add this one album i ripped a long time ago to my library, it wouldn't play it either, but it played just fine in Quicktime, even in Windows Media Player.

    I tried everything listed here, even looked through all the file info on these particular MP3's. what i decided to do was in effect, lower the bitrate of them and maybe iTunes would 'like them' again, so i pulled out my old audio converting program, dbPowerAmp, and re-encoded this one album to MP3 again (not from disc, just used the same problematic files), at only 192kbps bitrate (really don't think it matters) and iTunes finally added it to the library and played the file just fine.

    So i'm GUESSING that iTunes 10 is more 'strict' about it's MP3 files (might also apply to certian video files that use mp3 also, e.g. AVI files).
  • jbar Level 1 Level 1 (0 points)
    In the iTunes menu directly following "Preferences" is "Provide iTunes Feedback." I've been there a number of times to lodge my own displeasure with iTunes 10's new layout and "Burn" button omission.
  • nRic0 Level 1 Level 1 (0 points)
    I am having very similar problems -- I cant add files or folders to my library. When I try iTunes completely hangs.

    Also I just found out I can sync to my iPod Touch anymore either.

    iTunes 10.0.068 with iPod TOuch 32Gb
  • Igor_G5 Level 2 Level 2 (300 points)
    Try to just drag the files from the Finder into the itunes music window and see if that works.
  • Joel D. Reid Level 3 Level 3 (815 points)
    Thanks for the thought, but none of the methods of adding song files to iTunes are working for me...
    -Add to Library.
    -Set iTunes as default handler, then open the files.
    -Applescript
    -Dragging to the song list in the main part of the window.
    -Dragging to the Library area in the left column (though the plus cursor shows and section is highlighted!)

    Sometimes a window shows for a split-second \[copy progress perhaps?\]. I even went so far as to reencode them to aiff, successfully add the aiffs to iTunes, delete the aiffs, and when iTunes complains about missing files, point it to the compressed-audio files. It doesn't play them (just sits there; skips them if put in a playlist) and if I try to "Create AAC Version" from the "Advanced" menu, iTunes crashes.

    I do not want to rebuild my library. The data in it is valuable to me. You'd think that with all the library integrity checking iTunes does now that it would, um, have some integrity. Unfortunate bug.
Previous 1 2 3 4 Next