Previous 1 8 9 10 11 12 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew Go to original post
  • atrin1 Level 1 Level 1 (0 points)

    signing out of itunes and signing in worked for me. this was driving me nuts!

  • GLAinc Level 1 Level 1 (0 points)

    Same problem here.

    Basically nothing happened no matter how I tried.
    I attempted every method suggested here to no avail.  Spent most of the day.


    I changed the AAC files to MP3.  Still no good.


    I then converted to APple LOssless.

    That worked.


    Don't know why I cannot add AAC or MP3 to the library, but there it is.  Only m4a.


    The tracks started off as FLAC rips, then converted to these other formats using Max.

    maybe there's some problem with that.

  • papalapapp Level 1 Level 1 (80 points)

    What worked for me is to un-check the "copy to library" option in the settings (the gear menu to the right).

  • Luckywales Level 1 Level 1 (0 points)

    I was having the exact same problem - whether I selected the individual files, or the folder, or tried to drag to itunes - nothing was working.  Then, I signed out of the store, and signed back in again and everything started working properly.


    I can't believe that actually worked....

  • The_Drew Level 1 Level 1 (10 points)

    It's a P.I.T.A. but I found restarting the Mac solves the problem.

  • BillyBigBolls Level 1 Level 1 (0 points)

    I don't care a jot any more. All my music is now in MP3 format and the library of films and tv I have on Apple is easily replaceable. I have not posted regarding this before, but following last years new security measures, when I stopped purchasing anything from Apple (who are not the devil, but the ultimate in style over substance with a desire for self destruction that is quite breath taking), and now with this dreadful new controlled experience which I am happy for the rest of you to enjoy, I now consider my Ipod to be a legacy player, and will be replacing it with a one of the many simpler systems available. If you would like to join me, you will soon find that Apple start to give their customers what they want, but ****, why not just rot.


    I would like to say it's been a pleasure, and indeed, in the past it has been, but now it is just too much.




    PS perhaps they are the devil, because now the word spelt H. E. L. L. needs sensoring!!

  • gregsta82 Level 1 Level 1 (0 points)

    I found the issue was related to completed torrents still seeding (my problem was always with files downloaded from torrent). Once I finished seeding or killed utorrent I could add no problem. Match didn't seem to be the issue at all.

  • felixanton Level 1 Level 1 (0 points)

    I was having the same problem with some files I had copied from an old computer to my new computer. I finally discovered the files were read only, so I unchecked this in properties, and applied the changes. The files could then be added to itunes.


    Not sure if that will help in your situation, or if it is just a coincidence, and something else was really causing the problem.

  • sjosephineee Level 1 Level 1 (0 points)

    So, I had the same problem, and I was reading through this discussion. What I did actually kinda shocked me. I had tried dragging my mp3s to my music folder, THEN dragging it to my iTunes, but that didn't work. SO! I closed iTunes and reopened it. When it opens, typically you see a pop up that asks if you want to make iTunes your default program for certain things. (If it wasn't your default already) I decided to try it, and after I clicked "continue," a pop up came up and asked what I wanted it to be a default for. I checked the mp3 and mp4 boxes and clicked ok. After that, I could drag my mp3s over to iTunes. : D
    I'm not sure if this will help you guys, but I hope it does.
    I also use a PC, so I don't know if it's exactly the same, but it helped me!
    I hope it helps you. (:

  • veradee Level 1 Level 1 (0 points)

    This solution worked, changed the file name by removing dashes, worked a treat, thanks!

  • iphonemon Level 1 Level 1 (0 points)

    DROVE ME NUTS , SPENT LOTS OF TIME FIGURIN IT OUT, what worked for me was:



    I had it unchecked, and then i added music to library by going to FILE> ADD FILE TO LIBRARY< select manually




    FREAKING JESUSCHRISTO, itunes gets more and more annoying.

  • The_Drew Level 1 Level 1 (10 points)

    I relented and installed iTunes 11. The problem was solved temporarily but soon came back. My workaround was just to reboot the mac everytime the fault occurred, that allowed me to always import my content, but was just a quick fix.


    However I've since been running 11.1.3 and that has been rock solid stable and no re-occurrences of the issue at all.


    iTunes 11 is particularly horrid, it removes many good things about iTunes (including my favourite feature, iTunes DJ), and replaces them with vastly inferior and increasingly more annoying (read "broken") workarounds, but the hassle of regular forced reboots was just too much to ignore.

    Well played Apple, your willingness to eat your digital children has forced me to accept a future devoid of happiness.

  • The_Drew Level 1 Level 1 (10 points)

    Irony of ironies, the very day I publicly compliment iCrud 11 for it's stabilty, it flakes out and my importing files problem returns.


    Screw it, I'm switching to Spotify and Netflix. By Apple, you used to be good.

Previous 1 8 9 10 11 12 Next