Previous 1 2 3 4 5 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew Go to original post
  • Igor_G5 Level 2 (305 points)
    It's working fine for a lot of people so it isn't a bug in iTunes. It's something in your setup. I haven't had any problem adding songs to my library.
  • Joel D. Reid Level 3 (815 points)
    @Igor_G5, \sigh You're not new to the forums--please be as polite as possible and try to contribute if you're going to post. Your first post was an obvious suggestion, one that was already verified as not-working higher up in the thread. We know how to use iTunes. Your comment about it not being a bug... somehow it's my fault? Well, as evidenced in this page alone, many people are having this problem (Boudjtastic, SegWayne, -SHAWN-, akajezebel, joecarlsonstudio, Grafin Booth, Stumblebuny56, Joel D. Reid, mineo71, Agent Mckay, iDav82, Jackiass, ArtyFarty, etsanger, Xeonight, and nRic0 ...16 and counting). Projecting this forum's tiny sampling out onto the iTunes user base at large means that, conservatively; hundreds? thousands? of iTunes users are having this problem.

    I cannot speak for the others, but there is nothing strange about my setup. Additionally, iTunes 9 performed the same actions just fine. It is, most certainly, a bug in iTunes. iTunes natively plays mp3, m4a, and mp4 files but it cannot add them to our Libraries. It finishes a standard Open dialog, but then it flashes a small empty window with no message in it, does not report any error, and none of the expected behaviour occurs. Additionally, if I poke at it in any sort of tricky way, it crashes. Applications, especially top-tier apps of iTunes caliber, should never fail to do something normal without showing an error, and should never crash.

    You didn't experience the bug, awesome for you, but that's bad, anecdotal evidence that "it isn't a bug in iTunes" at best. How many technicians does it take to change a light bulb? None, "We have that same exact light bulb down here in the IT office and it works fine." I hate online arguments, and have nothing against you personally--I'd simply ask you not blame us for this problem and make sure every post is a contribution.
    @Xeonight, yeah... I had good luck getting it to import the files once I re-encoded them to AAC in a third-party encoder and Quicktime Player Pro 7. I'm glad it works, but I can't stomach the idea of doing a lossy transcoding for all my already-compressed files that it is refusing to import.
    10.0.1 is out. This issue is not listed among the "important bug fixes" but I'll post back if it helps.

    Cheers, Joel
  • Joel D. Reid Level 3 (815 points)
    Nope, 10.0.1 (22) doesn't help.
  • Himself3 Level 1 (0 points)
    After upgrading to iTunes 10 I am now getting the error that the song files cannot be converted due to not having the proper permissions to the Itunes folder (or a sub folder). I checked the library folders and set the permissions (anyone able to offer an idea why they were lost?) to now have access but I am still getting the same error. Any Ideas or suggestions?
  • MrApollo Level 1 (0 points)
    Same here! Trying to add mp3s and import a CD into iTunes (10.0.1). In all cases, nothing shows up in the main library but are appearing in the Recently Added playlist. This is driving me nuts!
  • TMcL Level 1 (0 points)
    I had this issue, too. Here is what seems to be helping me (import of 6K songs not yet finished)...
    I just happened to read something that a great, knowledgeable responder I've followed a few times before said in these forums ... JJ is his name.. He told someone in the MAC environment to hold down the option button when they dragged adn dropped... So I dragged my top level folder holding down the ctl key... At least SOMETHING is adding now... It might not be my one sub folder of all my ripped CD's that I PAID to have ripped and that added just fine to earlier Itunes... not there yet. I'll let you know how it turns out...
    Still not an answer for why the add folder does not work.
  • Jakobomb Level 1 (0 points)
    I had a similar issue. Just spent a long time trying EVERYTHING on here (repair permissions, log out of user account, check location of itunes library, re-install itunes etc.)

    Then I discovered that it was actually just a specific subset of MP3s that I could not import. I re-encoded them and succesfully imported them.

    Weird, but just thought I'd throw that out there and maybe save some folks some aggravation.
  • Joel D. Reid Level 3 (815 points)
    As reported, 10.0.1 hadn't fixed it for anybody, but 10.1 came out today and fixed it for me! Yea! Just bumping in case anybody is still subscribed. Good luck.
  • Rich74 Level 3 (945 points)
    I just had this. I've been encoding ripped (mine, bought) DVDs with RipIt and Handbrake - no problems dropping them into iTunes until this one file just would not add, iTunes just seemed to ignore it. I looked in the Movies folder in my iTunes Music directory and the file had copied over, it just wasn't displayed in the iTunes window. I dragged it to the Trash, tried dragging the original in again. iTunes ignored it like before. This time I checked the Movies folder - nothing. I tried right-clicking the original .m4v file and choosing 'Open with iTunes' - the movie began playing in iTunes and appeared in the Library. Right-clicked and 'Show In Finder' - it was the one in the Trash. So, I deleted it from the Library again (no warning or confirmation message though?), dragged it from the trash to the iTunes Music/Movies folder and did iTunes Files/Add to Library... on it. Imported fine. The one thing I don't ever recall seeing through all this is the copying progress bar in iTunes.

    iTunes 10 by the way

    Message was edited by: Rich74
  • Chris in NY Level 1 (120 points)
    I've read through the extensive posts to this thread. Needless to say I am yet another affected user. Bu I have noticed a strange wrinkle not yet mentioned:

    1) When I download new song from iTunes it goes into the library with no problem.

    I am merging two previously separate iTunes libraries (both are mine in diff accounts on the same MacBook).

    2) I have the same experience but with music: I drag the songs into iTunes to add, it flashes but doesn't complete the processing (as others have mentioned above)...and no, it does not show up in iTunes.

    But, the songs do show up in the iTunes music folder. So the files are properly stored in the correct folder structure (and some folders of existing artists. But iTunes does not seem them; I've done searches in iTunes for songs that are in the folders...and nothing. Tried 2-3 times and same thing. Really odd.

    I hope this behavior helps diagnose the problem! Let me know if anyone has any bright ideas!

    Thanks Mac Community!
  • BRWright Level 1 (0 points)
    I am having the same problem. I have tried EVERYTHING mentioned in this long thread (except encoding, which I don't understand), and NOTHING works, not even holding down the Option or Control keys while I drag.

    I get no progress bar, no window. I get no plus sign. The iTunes window does not highlight.

    When I use => Add to Library..., nothing happens. No response at all.

    Files do NOT appear in the Recently Added folder. Files do not appear in ANY libraries or other folders.

    Files DO appear in the downloads folder, but I can't do ANYTHING with them.

    Many existing tracks now show "file not found" and are no longer playable.

    Also, when I purchase and try to download new items, the download manager just goes and goes continuously, and never stops, until I close down my computer for the night. It will literally re-download over and over all day, and never stop. For example, this evening, a 79-cent, 9.2 MB track downloaded over and over for 7 hours until I finished for the day and finally "canceled" download. However, bizarrely, only ONE copy of the file appears in the downloads folder when it's all said and done. (And I can't do anything with it.)

    I have paid good money for these tracks, so I expect to be able to use and play them. I am a professional musician, and make it a point never to download illegally. Consequently, these tracks are the only ones I will use. With so many individuals complaining of an identical problem, this is obviously a HUGE problem with iTunes. Since I am operating in good faith, I expect Apple to reciprocate and fix the problem immediately. Otherwise, I shall consider organising a class-action suit to end this nonsense once and for all. Playing downloaded tracks is the whole point of the program! This is outrageous.

    Let me know when the problem is well and truly fixed.

  • yacoboy Level 1 (0 points)
    Hi, i had the exact same problem as everyone else on here.

    I have managed to fix it!
    I was trying to import an album folder (.mp3 format) but itunes just didn't respond when i tried to add them to the library.

    anyway i managed to fix it by going to file --> preferences --> general --> import settings

    then i changed my import encoder to MP3 (i then selected higher quality but this doesn't make a difference)

    itunes then cooperated with me and imported the files!

    finally, i spent hours on this problem and i found out it was just some simple settings.

    well i hope it works for everyone else.

  • barnert Level 1 (0 points)
    I've had a problem that may or may not be identical to what others are having. I also have some workarounds, and some additional info that might help Apple debug the problem.

    Ever since I upgraded to iTunes 10.0, it occasionally gets into a state where new songs that I add don't appear. Here are the exact details:

    * The track is not visible in the main list view.
    * The track can't be found by any smart playlists that I create.
    * The file does get successfully moved or copied to the right place in my filesystem ("/Volumes/Titled/iTunes/iTunes Media/Music/$artist/$album/$track $title.ext").
    * Using Applescript to search for the track in "first library playlist" works.
    * Using Applescript to search for the track in "first playlist whose special kind is Music" turns up nothing.
    * Refreshing the track via Applescript has no effect.
    * Adding the same file again via Applescript returns the same ID every time (so iTunes already knows it has the file, and isn't adding duplicate tracks or anything).

    In other words, the problem is that the files aren't being added to the Music playlist. A bit of snooping with Applescript and by grepping the XML library file verifies this.

    Generally, once this starts happening, it happens for every file that I add. It doesn't matter whether I add them through drag&drop, the menu, the "Automatically Add to iTunes" directory, or Applescript. It doesn't matter whether they're within my media folder or outside of it. It doesn't matter whether I add a file at a time or a whole directory. It doesn't matter whether I add music or videos (which likewise fail to appear in the Movies playlist). Quitting and relaunching iTunes has no effect. Neither does rebooting. Neither does adding additional files.

    Removing files from the library sometimes fixes it. So does opening files instead of adding them (e.g., by double-clicking an MP3 in the Finder, which causes it to be added and then played). So does converting existing library files into a new format. None of these are reliable, but if you do any of them over and over it seems like eventually the problem goes away. I have no idea why any of these should work when adding more files doesn't, of course.

    Once the problem goes away, it seems like all missing files suddenly appear, or at least more than one does. Then, everything is fine, until it breaks again. (I have no idea what causes it go into this state.)

    So, my first workaround is an Applescript that removes the last-added file from the library and then adds it back. I switch to the List view sorted by Date Added and run this script over and over until a new file suddenly appears.

    Then I found out how to make the Library playlist visible. I did this by "defaults write show-library-playlist -bool TRUE; defaults write hide-library-playlist -bool FALSE", but most users would probably prefer the GUI at for this. Then you can forget about the fact that your Music playlist is broken, because Library works fine. Except that some things (like smart playlists, iPod sync, etc.) will still be broken.

    I tried all of the other ideas in this thread, to no avail. Needless to say, the "iTunes Media Folder Location" setting in Prefs has been correct all along, and the permissions in that directory are fine; otherwise, iTunes wouldn't have been able to move/copy files there, etc.

    I sent feedback with all of these details to Apple, including the specific Applescripts I ran to test the problem. Maybe if we're lucky, they'll be able to repro it, and fix it for iTunes 10.2.
  • Prefers Linux Level 1 (0 points)
    This is not working for me as well. Apple is really dropping the ball on this one... a major bug running for 4 months with no satisfactory fix? Ridiculous.
  • slakjaw Level 1 (0 points)
    This was happening to me for a couple days as well. I noticed that the last file that was added to my library was a song I bought from the iTunes store. After that, nothing I added to the library would show up, although it did show in the "Recently Added" playlist. I went on a hunch after searching for an answer. I just deleted the song I bought from the library and the next thing you know, all the missing files suddenly showed up.
    Definitely a bug in iTunes.

    Message was edited by: slakjaw
Previous 1 2 3 4 5 Next