Previous 1 2 3 4 5 6 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew Go to original post
  • g1mpster Level 1 Level 1 (0 points)
    I came across this thread and many like it while trying to figure this out as well. I have a large collection of video files, all encoded in M4V format using Handbrake. They play fine in Finder, in QT and everywhere else. I've had them in my iTunes library before, however I just moved them all to a Synology NAS and trying to add them to the library for my new Mac Mini to use as my main movie player on my TV I hit this issue.

    I could add some videos to my library while others that were encoded exactly the same way at the same time could not be added. I fixed my disk permissions, copied the file locally and validated the iTunes library setting was correctly set. So after being fairly certain that it wasn't an encoding or permissions issue, I checked another spot that has bit me before with my Mac (last time I had to recover some files from a Time Machine backup): extended attributes.

    Sure enough, the file had an extended attribute for ResourceFork. As a test, I removed it from one file that had repeatedly failed to be added to my library. As soon as the extended attribute was gone, the file went right into the library with no problems. I don't know how it got there or what information it's trying to store, but everything I care about still seems to be there (all the metadata tags, cover art, etc.). To fix this stuff, you'll need to be familiar with Terminal. Here's the info on this case and at the end I'll provide instructions for how to do this recursively on all files in a directory.

    code:
    ~/Desktop$ ls -la@
    -rwxrwxrwx@ 1 ryan staff 89673097 Mar 5 10:57 S01E01 - Pilot.m4v
    com.apple.ResourceFork 3355

    ~/Desktop$ xattr -d com.apple.ResourceFork ./S01E01\ -\ Pilot.m4v

    ~/Desktop$ ls -la@
    -rwxrwxrwx 1 ryan staff 89673097 Mar 18 20:46 S01E01 - Pilot.m4v


    Additionally, for removing the extended attributes, I had considerable trouble with the solution given on the #1 Google hit for this (http://zzamboni.org/brt/2008/05/07/removing-all-extended-attributes-from-a-direc tory-tree/index.html). It turns out that Snow Leopard seems to need some additional arguments to make this work correctly. Here is what I found to work for me:

    code:
    for i in $(ls -Rl@ | grep '^ ' | awk '{print $1}' | sort -u); do echo Removing $i ... >&2; find . -print0 | xargs -0t xattr -d $i; done


    A couple of notes on this.

    1. The grep command is actually a tab, not spaces, so do as the article says and type "grep '^" then press CTRL+V, then press the TAB key, then finish typing out the command. This is the only way to get the tab character into the Terminal window.

    2. Additionally, according to the comments this needs to be run from a sudo command prompt. It's not enough to simply prepend the whole command with "sudo" because this will only apply to the first command and the one that needs it is the "xattr" command.

    Aside from that it worked great to remove all the extended attributes from the files.
  • mcblee Level 1 Level 1 (0 points)
    i seem to be having the same problem as alot of other folk. running vista and itunes 10.2.1.1
    when i click add to library, the box pops up as normal, i pick the one i want and click "add file" the box disappears normally but the file never adds to the library. i should mention that this file im trying to add is a large mp3. (40meg). this has never been a problem in the past and i added similar files just last week on the older itunes version.
    when i go to add a smaller file, a normal size song of 4 meg it adds fine, exactly the same format and is added with no problem.
    i tried some of the fixes mentioned above, not all of them apply to windows users but none of them worked. its as if itunes isnt even trying to add the larger files.
  • Andrew273 Level 1 Level 1 (0 points)

    Please try -

     

    There is a folder Automatically Add to iTunes

     

    - C:\Users\USERNAME\Music\iTunes\iTunes Media\Automatically Add to iTunes

     

    move one of the music files (that's not showing in the Library) from its current folder into this "Automatically Add to iTunes" folder. Mine auto refreshed the entire library and I could see all the 'missing' music files.

  • christopherfromcastleton Level 1 Level 1 (0 points)

    Vista (PC) Solution:

    Apparently Itunes 10 doesn't like "hidden files".

     

    1.Right click the folder you wish to import

    2.Select "properties"

    3.Make sure the "hidden" check box is not marked. Delselct it if it is.

    4.Click "Apply".

    5.Select the option to make this change for all subfolders and files.

     

    This worked for me.

     

    Good luck.

  • fromBerlinGermany Level 1 Level 1 (0 points)

    Very strange. When I add files from the finder to a playlist (the common way for me) the files will shown in the playlist but not in the whole library???
    If I add the files again in the whole library nothing happens. Usually they will be shown doubled in the whole library.

    If I add other new files only to the whole library no one of them will be shown.

    But purchased will added to the library. Any explanation for this?

     

    iTunes 10.4 in the latest version after installing Lion

  • mastagangstakillah Level 1 Level 1 (0 points)

    I had the same problem with my iTunes but finally got to fix it!! After launching iTunes I was trying to add some ripped (mine) CDs, "processing" window popped up, then disappeared and nothing. The files were in the Recently Added playlist, but not in the music library. After reading a few posts in this thread, I had a hunch and deleted the last two albums I added a few days ago and magically all the new CDs I've tried to add appeared. So if you have the same problem, go from the last song you've added and delete one by one until the problem is fixed. I checked if the problem with songs corrupting the adding process was going to reappear, but I had thankfully no.

     

    Keep on rollin'

  • Brooklyn Go Hard Level 1 Level 1 (0 points)

    Ok people, idk if this help but i been having the same problem yall been having and i believe im good now. ok first off scroll down to your playlist and go to recently added......and BOOM! im back in action, hopefully yall will be to

  • Dezzz Level 1 Level 1 (0 points)

    I had the same problem, I solved it by checking the folder path in iTunes, mine was pointing to iTunes/iTunes Media rather than iTunes/iTunes Music (Where you should see all the music stored). Pointed it to the latter and it now works.

  • royroy Level 1 Level 1 (0 points)

    I had the same problem and after some research, i found another disccusion that had a fix to it.  Worked for me, hope this will help the rest of you!

     

    http://triq.net/mac/mp3-validator-mac-os-x

  • nexis99 Level 1 Level 1 (0 points)

    I have a slightly different problem.

    My iTunes will add music to my library.  However, it makes an individual playlist for each and every album/artist... that is not what I want.  I only want it to add music to the library, but it won't do that.  Anyone have a similar problem?

  • Jimena00 Level 1 Level 1 (0 points)

    My problem is similar except that when I try to add music to my library, iTunes creates an empty playlist with the name of the file, so I can't add music to my library.

    I deleted iTunes and installed it again but I still have the same problem. HELP

  • Stephen Pocock Level 1 Level 1 (15 points)

    I had the same problem. Somehow I've created a huge hierarchy of folders under music. I had selected an "Automatically Add to iTunes" folder that was at the bottom. I found another one in the top media folder. Transferrred my files there and it worked fine.

  • iG.STUDi0 Level 2 Level 2 (330 points)

    I had the same problem with iTunes 10.5, but on an XP box. The correct media folder location was listed in the perferences, but I had to reselect it. After restart (never hurts) the import works fine.

  • nobuski Level 1 Level 1 (0 points)

    Guys, go to the iTunes folder in your C drive, and make sure you see a folder labeled "iTunes Library" is in there. If not, just create a new folder and label it "iTunes Library". That's all.

  • iTunes_is_Crap Level 1 Level 1 (0 points)

    Having same problem (win7, iTunes 10.x the latest anyway)

    I'm unable to import any movies no longer. My experience with Apple products is short - and without a proper solution it will be.

     

    Couldn't imagine when buying iPad that Apple can create such a crap.

     

    My libraries dont include anything "too important to be saved", so uninstalling iTunes and re-installing it have popped in my mind...

Previous 1 2 3 4 5 6 Next