Previous 1 4 5 6 7 8 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew Go to original post
  • Captinsmooth Level 1 Level 1

    I resolved this issue by signing out of my itunes account then siginging back in. All the music the was not showing after importation now appears. Hope this helps others!

  • fallsalot Level 1 Level 1



    Many good ideas within this thread which led me to this solution:


    1) If you wish to "Add Folder to Library" an album of songs in "album order,"  first check that the album's songs under the folder/directory of "album name" have a two-digit number + space (e.g.  '01 song name.{mp3,m4a} ). Dig to find the order, or just rename as you wish...


    2) If you've bought your tunes through iTunes, then likely the track file names have a '.m4a' extension.


    3) If you've downloaded the tunes from, say the label/publisher, then likely these tracks have a '.mp3' extension.


    4) OK, so you (may, and likely so) have a MIXTURE of '.mp3' and '.m4a' type files, and you're wanting to "Add Folder to Library:"  Ensure your files are on LOCAL MEDIA, not CD's or other removables... like USB sticks/drives.

        A) Use your 'puter search to find each set of files, MP3 and M4A, and "organize" them either in separate directories/folders, or the same, BY ARTIST-named directories... your choice, but it's a "housekeeping issue:" you may later pull from MP3 or iTunes sources--oh, and your CD rip choice informs this source type as well--and keeping the source types separate will reduce complications later... moving on...

       B) Visit iTunes preferences and adjust the "CD Import Settings"... select either MP3 or AAC, to start.

       C) Visit "Add Folder to Library" and select the directory/folder with files of type MP3 or AAC as chosen in step "B."  Import/Add runs, importing(sic) files of said type.

      B, again)  Select the other file type, then...

      C, again)  ...this pass either selecting the same or differentiated-by-file-type directory/folder... remember/note your earlier choice. (?)


    5) Exit, and restart iTunes.  Verify all as you expect it to be, that your music has been integrated with your library.


    This procedure resolved my conundrum cleaning up a friend's set-up, to which I reminded him, "computers aren't smart, people are."  And I thank the many like-minded smarts of the people of this forum!  Your clues helped me identify that Apple has merged the iTunes "Import CD" and "Add Folder" functions to the same library routines in the iTunes 10.+ versions... both will import/add based on the selection of file type under the "Import CD" settings.


    And yes, I uninstalled, then re-installed iTunes to verify.  I did not fuss with file attributes, nor permissions; and verified this procedure with both Winders and the Mac'd OS (Leopard+).


    /falls (and gets back up, again, and again)

  • Tridg2011 Level 1 Level 1

    Im having the same problem, I can see it on my Apple TV but not in itunes.

  • xih228 Level 1 Level 1

    This is rediculous, all due to the new update.  Apple really need to patch this update.  Its rediculous that an update actually decreases the functionality of this program.  Getting really frustrated with Apple right now.

  • Barb Smith Level 1 Level 1

    Captinsmooth wrote:


    I resolved this issue by signing out of my itunes account then siginging back in. All the music the was not showing after importation now appears. Hope this helps others!

    This fixed my problem, too.  Thank you for posting!  BJS

  • senemsalar Level 1 Level 1

    I have spent all my evening to find a solution to the same problem, tried everything that all you guys have recommended. Could not end with a solution. Apple is such a pain. I wish i did not buy ipad.

    Can anybody recommend anything different?

  • Ferriciean Level 1 Level 1

    Signing out and back in of my iTunes Store account worked for me...

  • bevansciw Level 1 Level 1

    I've been using Apple products forever, including iTunes. Have imported countless CDs I've purchased over the years. iTunes not adding my imported CDs all of a sudden is not user error. I too have tried all options posted within this thread, but still sit without a fix. What gives Apple?


    In fact, just last week I imported a purchased CD without an issue. Now I get nothing. Looked inside the physical location were iTunes stores imported music and everything is there, as it should be. However the CD is not showing up in my iTunes Library. Have a strong feeling that my iTunes Match (iCloud) is screwing things up.


    When I open iTunes, there is a cloud next to "Music" that appears to be chewing on something. Unfortunately that's been going on for hours without resolve. Resorted to trying all the ideas folks are throwing out, but still nothing. Any other bright ideas floating around? Would prefer Apple deliver the correct answer instead of relying on its loyal users/followers having to resolve the issues.

  • Josh.Gr Level 1 Level 1

    I think I found the problem and the very simple solution (at least on OS X (mine is Lion 10.7.3)). I had a "lockfile" present. Open the Terminal and run the following:


    ls ~/Library/Preferences/*


    On my machine, I saw multiple entries and one with a "lockfile" at the end. Even if you don't, just try removing all of them (probably a good idea to quit iTunes first):


    mv ~/Library/Preferences/* ~/.Trash/


    Then restart iTunes. It seems to behave as if you've never run it before (you get all the tutorials again). But after that, I'm able to add things as usual. As far as I can tell, you seem to lose some settings in Preferences (but not all of them), so you may want to double check that. But none of your data is stored anywhere near this directory, so there's no serious danger here.


    Hope this helps.

  • gbcrofton Level 1 Level 1

    I tried the above, and am ABLE to add mp3s, but not AAC files.   I was able to convert some AACs to MP3s and import them that way, but it seems many of my music files may be corrupt.   Anyone know a way to determine whether AAC files have somehow been corrupted?    I have 100 gigs of them, and can't imagine just erasing all of it.... 


    Thanks in advance for any thoughts.

  • slopes0213 Level 1 Level 1

    I had added two cds into my library via the "File>add to library" route. they showed up in the recently added smart playlist and were physically in the right place on my drive but not in my music library display. I found a similar thread on this problem and it suggested downloading a free music file from iTunes and it fixed the problem. I was skeptical but I  had tried every other suggestion on these forums that at this point I'll try anything.. I googled "free iTunes song of the week" found a link that opened the free song in iTunes. I downloaded it and low and behold when I typed the artists that I had added in the search box they would finally display the new CDs I added from those artists under "music". I couldn't believe it worked! This may work for you folks, give it a shot.. Seems like there are ways that work for some of us and not for others. Good luck!

  • ronsen Level 1 Level 1

    It all started with: no credit card > no account > no signing in > no free app > ? no iTunes ? > no Apple?!


    @Apple: FIX IT g** **mn

  • lnikitin Level 1 Level 1

    Same here. PC Windows 7, last version of iTunes.

  • cm97 Level 1 Level 1

    Have tried everything. iTunes 10 no letting me add mpeg to my library.


    Any further suggestions?

  • hypa3000 Level 1 Level 1

    not sure if this has been mentioned before

    i was pulling my hair out trying lots of different things as I couldn't add tunes to itunes playlists with latest itunes installed on Win 7 64bit OS


    but in the end solution which worked for me was very simples


    Not sure which of these two did it  as I unchecked both of the following:



    right click the iTunes shortcut on the desktop


    Properties > Compatibility > UNchecked 'run this program as an administrator'


    (I had checked this above when trying out things in the past).



    I also did this


    Again right click the iTunes shortcut on the desktop


    Properties > General > Advanced > unchecked 'File is ready for archiving'


    hope this helps



Previous 1 4 5 6 7 8 Next