Previous 1 2 3 Next 177 Replies Latest reply: Feb 26, 2014 11:42 AM by The_Drew
Boudjtastic Level 1 Level 1 (5 points)
I was trying to add some MP3's to my iTunes collection tonight and am seeing that iTunes 10 add to library function is not working at all.

Really irritating.

MacBook Pro, Mac OS X (10.6.4)
  • Jim MacCormaic Level 4 Level 4 (2,635 points)
    I'm afraid this probably won't be of much help to you, but my experience differs.

    Not only can I add music to my library, but I find the process to be much quicker in iTunes 10. Previously, iTunes indicated that it was 'processing' the files before it went on to copy them. The processing step now doesn't happen.

    Do your MP3s play in Quicklook? Is there anything different about them compared with files you've successfully added to your library with previous version of iTunes?
  • SegWayne Level 1 Level 1 (0 points)
    Sorry to add a "me too" but I have an identical setup (10.6.4, iTunes 10.0) on my iMac and can't import or "Add to Library" either. Either the menu option or drag/drop just acts like it's doing something, then does nothing at all. The movies are never imported or added in any part of the library that I can see.

    I'm trying to add mp4 movies (.m4v file names) instead of mp3's though.

    Sounds like a major bug to me.

  • mauijiminar Level 4 Level 4 (1,660 points)
    I downloaded a song from I tunes 10 today and it was WAY faster.
  • SegWayne Level 1 Level 1 (0 points)
    FOUND IT!!!!

    (At least for me)

    Went in and checked the Preferences. Under "Advanced" the choice for "iTunes Media Folder Location" was completely and totally blank. Pointed it to the correct folder again and all is -- at least for now -- right with the universe.

    Hopefully it won't do like 9.x and automagically revert to the default location each time you restart.


    Message was edited by: SegWayne
  • -SHAWN- Level 1 Level 1 (0 points)
    didnt work for me.. still wont import. i dragged a whole folder (all files play with preview) mp3 files wont import. out of 17 files 2 worked... tried multiple times
  • akajezebel Level 1 Level 1 (0 points)
    I have the same problem. I downloaded an mp3 from a site I usually download from without any problems whatsoever. I updated to iTunes 10.0 (67) this morning and downloaded said mp3 from said site and it will not import into iTunes. It plays in Quick Time Player, but not iTunes. I've checked all my preference settings in iTunes and they are just as before the update. I can't think what the problem could be. I've tried to drag the file into the window, I've tried using the "Add to library" function, I've tried simply clicking the file to open (set to automatically open in iTunes) but nothing works.
  • joecarlsonstudio Level 1 Level 1 (0 points)
    Same problem -iTunes 10 import. In my case it is mp4 movie created with handbrake. I have tried all importing options including copying to the iTunes Media...Movies folder. The file is 1.75gb. I have never imported a full length film into iTunes before - anyone know if there is a maximum file size for iTunes?
  • joecarlsonstudio Level 1 Level 1 (0 points)
    FYI... Re: iTunes10 import problem. I changed the tag on the movie file from .mp4v to .m4v and the import worked fine??
  • Graflin Booth Level 1 Level 1 (15 points)
    Same problem. Running iTunes 10 on OSX 10.5.8. Cannot add songs to iTunes using "Add to Library" or by dragging and dropping onto iTunes window.
  • dennishay Level 1 Level 1 (0 points)
    Upgrading for me made iTunes forget where the music library was (I use an external HD)... putting back the directory fixed it for me.... goto advanced settings, iTunes Media folder location, change... select media folder "iTunes Library". If you don't know where your songs are exactly then right-click on a song and "show in finder", that will give you an idea.

    I was able to add mp3's etc to itunes after that...
  • dennishay Level 1 Level 1 (0 points)
    PS... I didn't see any menu option on iTunes to "report a bug" so I'm hoping this note makes it to the dev team... also maybe add a "report a but" menu option under help or something... just saying
  • Graflin Booth Level 1 Level 1 (15 points)
    I also use an external HD to store my iTunes library. It is set correctly in the Preferences file. Still will not import tracks.
  • Stumblebuny56 Level 1 Level 1 (0 points)
    Same issue here and thanks for posting that the location of the iTunes content went back to the default after upgrading to 10....I'm sure I would have been scratching my head over that one for awhile. I've got all my content on Netgear Stora MS2110 home server and after adding a few new MP3s using my Macbook I decided to update my iTunes library on my PC, but using the "File/Add File to Libary" didn't work. Once I updated the path to my content I was able to add at least one of the MP3s on my server to my PC iTunes library using the File drop down menu or drag and drop, but not all of them - strange. Definitely a bug that needs fixing.
  • Stumblebuny56 Level 1 Level 1 (0 points)
    I just used the "Provide iTunes Feedback" under the Help menu.
Previous 1 2 3 Next