4 Replies Latest reply: Sep 6, 2010 6:35 AM by nickthequick
nickthequick Level 1 Level 1 (0 points)
It happened to me now already the third time. Trying to open an internet page, the Safari wheel keeps turning for ages. Becoming impatient, I try another page, the same thing happens. I close Safari and try to open it again, but Safari doesn't open. I have to restart the Mac to get Safari working again.

Anybody else had the same experience?

intel iMac, Mac OS X (10.6.4), dsl, alcatel modem
  • Klaus1 Level 8 Level 8 (46,770 points)
    Adding Open DNS codes to your Network Preferences, should give good results in terms of speed-up as well as added security:

    If you are using a single computer: Open System Preferences/Network. Double click on your connection type, or select it in the drop-down menu, and in the box marked 'DNS Servers' add the following two numbers:

    208.67.222.222
    208.67.220.220

    (You can also enter them if you click on Advanced and then DNS)

    Sometimes reversing the order of the DNS numbers can be beneficial in cases where there is a long delay before web pages start to load, and then suddenly load at normal speed:

    http://support.apple.com/kb/TS2296

    If your computer is part of a network: please refer to this page: http://www.opendns.com/start/bestpractices/#yournetwork and follow the advice given.

    You could also try these codes as well: 4.2.2.1 & 4.2.2.2

    If you use a Router, make sure it has the latest firmware installed.
  • Carolyn Samit Level 10 Level 10 (98,630 points)
    HI,

    Try emptying the Safari cache more often. Click Safari in the menu bar then click *Empty Cache*. Relaunch Safari. If it Safari still freezes try troubleshooting the Safari .plist file.

    Open a Finder window. Select your Home Folder in the Sidebar on the left. It has a small house icon. Then open the Library folder then the Preferences folder.

    Move the com.apple.Safari.plist file from the Preferences folder to the Desktop. Now launch Safari. If Safari doesn't freeze, move the .plist file to the Trash.

    Web pages include a small icon or 'favicon' which is visible in the address bar and next to bookmarks. These icons take up disk space and slow Safari down. It is possible to erase the icons from your computer and start fresh. *To delete Safari's icon using the Finder, open your user folder, navigate to ~/Library/Safari/ and move this file "webpageIcons.db to the Trash.*

    In Safari / Preferences - Security. Disable plugins. Relaunch Safari. If Safari doesn't freeze, then you may Safari third party outdated plug-ins. Go here for help with that. Safari: Add-ons may cause Safari to unexpectedly quit or have performance issues

    Right or control click the Safari app icon in the Applications folder then click *Get Info*. In the Get Info window under General make sure that the: Open in 32-bit mode or Open using Rosetta boxes are not checked.






    Carolyn
  • ~Bee Level 7 Level 7 (31,160 points)
    nick --

    This had happened three times, right?
    What did you change like 4-5 days ago?

    When did you update Safari or your OS?
    Did you add any internet apps or plugins 4-5 days ago?

    Do you empty the Safari cache and history lists?

    When you open Safari, are you opening it from the Dock?
    What happens if you open it from the Applications folder where the Safari app needs to be placed?
  • nickthequick Level 1 Level 1 (0 points)
    Hi Carolyn and thanks for your help. Emptying the cache seems to help, the problem hasn't occurred again.

    Helmut

    P.S. I'm sure you have more sunshine than us in Austria!