12 Replies Latest reply: Feb 11, 2013 6:48 PM by KidFit
Jay Kappmeier Level 2 Level 2 (205 points)
I just discovered that iTunes 10 will not import audio CDs. Once you insert the CD and iTunes launches, the CD disappears from the desktop. It is not there in the finder window nor in the iTunes window. This occured on all three Macs I tried it on and occurred with about four different audio CDs.

Apple Technical Support people duplicated the problem on their Macs and have referred this to engineering. If you plan on importing audio CDs in the near future I suggest not installing iTunes 10 now.

Jay

MacPro 4Core 3GHZ, 5GB RAM, Mac OS X (10.6.4), iTunes 10
  • efeigenb Level 1 Level 1 (20 points)
    confirmed. same problem. ugh. hope this gets fixed soon.
  • mpu Level 1 Level 1 (0 points)
    I had the same issue. I download the iTunes 10 from Apple's website and installed it again. Then, rebooted the system and the issue was resolved.

    I hope it helps.
  • Jay Kappmeier Level 2 Level 2 (205 points)
    Unfortunately this did not work for me. I did a complete uninstall, downloaded iTunes again just in case I had a corrupted file the first time and reinstalled it. I restarted the computer and the same problem occurred. Apple is still checking on the issue.
  • John Turner Level 1 Level 1 (135 points)
    There is another thread.

    Someone resolved it by deleting: <user>/Library/Preferences/CD info.cidb

    This did not work for me.
    My resolution was to turn off "Automatically retrieve CD names from Internet", and set "When you insert CD" to "Show CD". I can manually retrieve names using Advanced->Get Track Names, then click Import CD.

    The problem appears to be a problem between iTunes and Gracenote.
  • Jay Kappmeier Level 2 Level 2 (205 points)
    Well since reloading the program worked for someone I decided to try it again. This time I immediately restarted the computer. This time it worked on two Macs and I haven't worked on the third Mac yet. I also do not have the program go out to the internet. I have it play the CD when it is inserted and also get the track names manually through Graceland.

    Jay
  • Will 616 Level 1 Level 1 (0 points)
    Don't bother with the reload or the file deletion - the users identifying Gracenote as the problem have got it right. My problems manifested exactly as per the description but I noticed that audio CDs that had previously been imported (and tagged by gracenote) still worked fine. Putting this together with John Turner's excellent suggestion in the post above - I turned off auto 'get names' and now audio CDs work fine. I guess the patch will be on the way.

    Message was edited by: Will 616
  • Eric Myers2 Level 1 Level 1 (5 points)
    It does appear to be an issue with Gracenote. Turning off the Auto retrieve option from preferences allowed iTunes to recognize the CD, but then trying to get the names manually still did not work (tried with 4 different commercial CDs).

    I've gone back to 9.2.1 (Thank you Time Machine) - works (and looks) much better. I'll stick with this version until Apple gets the new version of iTunes back up to par. Right now it feels like a half-baked v1 Microsoft product.
  • Matthew Goeckner Level 1 Level 1 (15 points)
    The other option here is to eject the cd and then reinsert it. That works for me. Of course, EVERY stinking CD needs to be reinserted so it is somewhat of a pain in the behind.
  • daniel Azuelos Level 2 Level 2 (335 points)
    Jay Kappmeier wrote:
    I just discovered that iTunes 10 will not import audio CDs. Once you insert the CD and iTunes launches, the CD disappears from the desktop.


    Could you please check if your problem disappear when configuring your
    iTunes so as to avoid automatic search of track names on the web:<pre> Preferences…
    Automatically retrieve CD track names from Internet</pre>
    <pre>--------
    don't look for my Macs models in my signature, this would be uggly... and irrelevant
    --
    dan</pre>
  • sariaru Level 1 Level 1 (0 points)

    I'm having the same problem, and it does not go away when I tell iTunes to avoid automatic track name searches.

  • AdrienneW Level 1 Level 1 (0 points)

    This worked. Thanks to John Turner!

  • KidFit Level 1 Level 1 (0 points)

    Will this procedure mess up my playlist???