Previous 1 2 3 4 5 6 Next 89 Replies Latest reply: May 3, 2015 7:16 PM by Dave Robertson2 Go to original post
  • Periphrast Level 1 Level 1 (5 points)

    First of all, does anyone still have a Users and Groups category in the System Preferences Menu?  Second of all, killing startup items was the first thing I did when trying to snuff iTunes.  Unfortunately, iTunes Helper doesn't appear among selectable items under the System > Accounts > Login Items menu.  I've killed it manually in the Activity Monitor, but iTunes still resurrects every time my headset reconnects after I've walked just out of range.

  • Imp68 Level 4 Level 4 (2,445 points)

    "First of all, does anyone still have a Users and Groups category in the System Preferences Menu?"

     

    Yes.  Anyone running Lion or Mountain Lion.  If you see accounts, you're running an older version of the OS.

     

    If my suggestion doesn't work for you, oh well.  I'm glad it helped someone else.

  • Wolf Harper Level 1 Level 1 (40 points)

    steveburchett wrote:

     

    If it runs at all, that is unacceptable.

     

    Easier would be to just manually quit iTunes.


    I agree it's unacceptable, but I haven't found anything else to do about it. 

     

    Ever try to "just" manually quit itunes in this situation? It goes like this.

    #1.  iTunes starts minimized, and the foreground application gets laggy. 

    #2.  iTunes starts playing music, often in an explosive and embarrassing audio outburst.

    #3.  You frantically switch to iTunes and bang command-Q.

    #4.  Absolutely nothing happens.

    #5.  Because, it popped up a dialog saying "oh hey, having trouble syncing some of your videos."  Command-Q doesn't close that box.

    #6.  You hit command-Q again, but that gets intercepted by another dialog asking for your password to log into the iTunes store to get downloads.

    #7.  You hit command-Q AGAIN, and it says "Hey, I'm downloading podcasts. You really wanna quit?"

    #8.  You bang "Yes, I bleeping do."

    #9.  More swap while your system recovers.

     

    I'm serious.  it usually happens when you're trying to use another fat application that calls for a headset, and if you're like me, you also have a browser with 8 windows, Word, Adobe etc. etc. open. 

     

    That's why it's so useful to kill it <2 seconds into step 1 before it can start holding court.

  • the.firestarters Level 1 Level 1 (0 points)

    In the CDs and DVDs preference pane disable iTunes to launch inserted for Audio CDs

    Source

  • steve.burchett Level 1 Level 1 (0 points)

    I had great hopes, but no cigar.

     

    Thanks for the suggestion, though!

     

    Steve

  • Adonsa Level 1 Level 1 (0 points)

    iTunes misbehavior persists when the Phaton PS BTNC is plugged in.

    Remedies proposed over the last 3 page are appreciated, but do not work.

    iTunes opens about every 15 minutes while bluetooth is on, no matter what.

     

    Any Apple Employee:

     

    Why didn't the beta testers notice this? 

     

    Apple Employee, in light of Mac users' heroic, but unsuccessful, attempts to mitigate this misbehavior/annoyance, what is your plan to take this problem to the senior leadership?

     

    What is your plan to bring a solution to this web page?

     

    Annoyances are for PC users, Mac users shouldn't have to put up with this nonsense.

  • steve.burchett Level 1 Level 1 (0 points)

    I, too, feel like Apple has dropped the ball.

     

    Or is it just the need to continually put iTunes in front of us even though we are not using it? After all, advertising is all about impressions!

     

    Let's just hope that's not true.

  • colleenP29 Level 1 Level 1 (0 points)

    Best description of the problem, ever.

  • msheaver Level 1 Level 1 (0 points)

    Hey everyone, this is the solution! To reiterate, go to Systee preferences >> Users and groups, click the Login items tab, select the itunehelper entry, and click the little minus sign <-> to delete it. Reboot your system and voila! No more iTunes when turning on your bluetooth headset.

     

    I did this in OS X 10.8 (Mountain Lion).

  • steve.burchett Level 1 Level 1 (0 points)

    I did this quite some time ago (perhaps at your first iteration) and it still does it. Mac OS X 10.8.5.

     

    Thank you for trying, though!

  • TenderWarrior Level 1 Level 1 (0 points)

    Au contraire, madam... in fact, this is officially STILL a problem in 10.9 Mavericks. I am using an LG HBS-730 headset, and the iTunesHelper fix most certainly did not make a difference. Before I invest some phone time, have any of you fine folks tried calling Apple Support to speak with a tech? If so, what was the result?

  • PiotrBox Level 1 Level 1 (0 points)

    OK, in mavericks i cannot change f*ckn itunes name in finder. any way to change it?????

     

    i really need to have itunes fake app

  • PiotrBox Level 1 Level 1 (0 points)

    OK,

    I managed to rename the app in terminal by:

     

    cd ~/Applications/

    sudo mv iTunes.app iTuneF.app

    password...

     

    now when i connect my TDK the renamed iTuneF.app starts anyway, but doesn't play music. GREAT.

     

    .... not really. When i connect second time (with iTuneF.app ON) the stupid starts to play again.

     

    I even created fake iTunes.app with automator. the only think it has to do is to quit the iTuneF.app  and it does when clicked in dock. but on bluetooth connect nothink.

     

    So this fix only works it you keep renamed itunes app OFF.

     

    AND i have no idea what will happen now when there will be itunes update of some sort. will the system panic and go under bad?

    will see

     

    still i really dont like what is happening with apple. wee lose all controll of our own machines.

     

    PS. sorry ofr posting reply. i tried to edit, but it crached after one and now i have no edit button in my post.

  • MeDumb Level 1 Level 1 (0 points)

    Fuzzy, does your UE 9000 Headphones still work?  I just got a pair and get no sound at all from them in OSX 10.9.

  • FUZZY DUNL0P Level 1 Level 1 (0 points)

    Yep, they work and I didn't had any sound problems so far. Call Logitech, they have a good support, maybe they can help you.

     

    BUT be careful with the plastic head band. Mine broke 2 months ago as I took the headphones off my head with the normal way of pulling the speakers a bit apart off my ears. Theres some kind of predetermined breaking point. I got them replaced by Logitech.