Previous 1 2 3 Next 43 Replies Latest reply: May 23, 2015 9:42 AM by Cubic Apple
evebill8 Level 1 (0 points)
Hi folks,

I tried to put the 2x G.Skill 4GB DDR3 PC3-1066 RAMs to my 2010 MacMini. It only kept beeping after reboot. Anybody has the same problem? Would anyone please tell me what brand of RAM. Thank you!

MacMini, Mac OS X (10.6.4)
  • macbig Level 4 (1,680 points)
  • Benjamin Brossard Level 1 (130 points)
    Take the new ram out.

    Put old ram back in.

    If the computer boots now, it would point to bad ram.

    To troubleshoot, you could install the new ram one stick at a time. If it works with one in and not the other, just one stick is bad.

    If neither work, it would probably mean your mac doesn't like that ram.
  • Calsifer Level 1 (0 points)
    Having this exact same error with my 2010 Mac Mini Server.

    Updated the firmware, and checked for any software updates before starting this process.

    Tried to replace the 2 x 2GB memory modules with 2 x 4GB memory sticks.
    Upon restart the Mini just beeps at me.

    So. . .

    Removed the NEW memory and reseated. Once again upon restart it still just beeps at me. I then removed the new memory all together and replaced the original memory that put me back at 4GB using both slot 0 and slot 1. The Mini works as before.

    SO. . .

    Removed all memory, insert 1 stick of the 4GB memory. Mini restarts and sees the 4GB stick in slot 0, and says memory is OK.

    Removed the memory stick in slot 0 and replaced with the other 4GB stick. Mini restarts and sees the 4GB stick in slot 0, and says memory is OK.

    Now. . .

    Placed the first 4GM memory stick in Slot 1 and kept the second 4GB memory stick in Slot 0. Upon restart the Mini just beeps at me.

    NERD RAGE ENSUES!!!!!1!1!

    Any help would be greatly appreciated!
  • trint Level 1 (0 points)
    Have you tried a single stick in Slot 1...?

    With my non-working 8GB Kingston memory configuration in the Mac mini 2010, both 4GB sticks failed to work in Slot 0 (individually) and so I contacted Kingston but they were uncertain as to why it was failing.

    The 1GB working factory sticks and the 4GB Kingston sticks both use Hynix chips but the component codes are different (factory - H5TQ1G83TFR, Kingston - H5TQ2G83BFR).
  • Calsifer Level 1 (0 points)

    Oddly enough the 4GB sticks do not work in slot 1.

    I am now using 1 4GB in slot 0 and 1 2GB in slot 1 for 6GB.

    sigh failure on my grand memory upgrade.
  • trint Level 1 (0 points)

    When I first spoke with Kingston they were under the impression the Hynix chips were the same (exact H5TQ.... codes) but having realised they are different they are now raising the issue with their technical team in the US.

    You might want to check your memory stick codes and if they are similar to the ones I've mentioned in my previous post you might want to get in touch with your memory brand's technical support and suggest Kingston are making further investigations.

    Hynix have a code interpreter for ram modules on their website and it would seem the difference in codes means that a different Die Generation and chip configuration was used to the new modules from those that worked from factory.

    Hope some of this helps you out.
  • Iron Monkey Level 1 (35 points)
    I put 2x 2GB 1333MHz Kingston RAM in my aluminum Mini and it recognizes all 4GB no problem.

    The model no. of the RAM is KVR1333D3N9/2G-SP (Kingston). Total cost of the upgrade was about $85 USD.
  • MacValley Level 1 (0 points)
    Ran into serious troubles when trying to upgrade my Late 2009 Mac Mini (3.1) 2.66 GHz from the original 4GB to 8GB with Kingston memory KTA-MB1066K2/8G. No boot, just beeps. Then, after consulting Kingston tech support I reset the PRAM and NVRAM, see After that I inserted the new 2*4GB RAM and now it works like a charm! (Thank you Kingston). I see that other users say that one should stay away from Kingston memories, but the reset maybe is all that it takes?
  • Freddie747 Level 1 (0 points)
    Just want to say thanks, you saved my day with your post.
    I had bought the exakt same memories and got the beeps. After reseting the PRAM and NVRAM it works perfect.
    Thanks again!
  • Mr Kirk Level 1 (20 points)
    Hi MacValley,
    I was about to purchase the same memory upgrade from Kingston KTA-MB1066K2/8G, when I noticed it is (according to Kingston) the same memory as the Macbook Pro, so I've found this discussion. Anyway, can you confirm the you reset the PRAM/NVRAM BEFORE you inserted the new ram? And then it worked and shows the full 8GB?
  • rogerhyam Level 1 (0 points)
    I went for broke with an 8Gig upgrade fom Crucial. Put them in and just go the beeps. Took one 4Gig out and replaced it original 1Gig and it worked. Did the VROM thing mentioned further down the thread where you boot whilst pressing option-command-p-r and wait for two start up noises. Then put the other 4Gig in and I'm "cooking with gas" on 8Gig.

    I reckon you can only do so much per step with the PROM VROM thingy.
  • PAULSG63 Level 1 (0 points)
    I also get beeps when I put two sticks of 4Gb mem.. one works fine by itself.
    I tired the resseting PRAM NVRAM... but it never resets >:|
    I have a PC keyboard not an apple keyboard. I use the <windows>-<alt>-P-R But it doesn't reset.
    Anyone else have this issue? Do I need to buy an MAC keyboard?

    Paul G
  • houckjp Level 1 (0 points)
    I used a Microsoft wireless kb & mouse. I did have to switch to a different USB port before it worked for some reason. But I was able to do it.
  • Shawn.Hank Level 1 (0 points)
    Thanks for providing info in this thread. I too bought the Kingston KTA-MB1066K2/8G. I tried to install it in my MM (2010 Unibody) and had the same results as you fine folks. Having the 4GB Dimm in slot 0 resulted in a singular beep indicating no ram detected.

    I tried calling Kingston Tech Support and they told me that they had no record in their DB of issues with this RAM and the MM Unibody. I was going to call AppleCare, but decided to take the Cruical 8GB (2x4GB) RAM from my MBP 13" and swap it out.

    Lo and behold, the Crucial RAM works in the MM and the Kingston RAM works in the MBP.

    Although I did the research prior to purchase, I neglected to check the forums here. I learned a good lesson.

    Happy New Year!

Previous 1 2 3 Next