1 2 3 Previous Next 40 Replies Latest reply: Jan 14, 2014 7:18 PM by nyc863 Go to original post
  • 30. Re: Memory Upgarde for 2010 MacMini
    Carl V. Level 1 Level 1 (5 points)

    This is still fairly fresh in my mind, so thought I'd add a little more info.  The memory I was using was this:

     

    Kingston Technology 8GB Kit (2x4 GB Modules) 1066MHz DDR3 SODIMM Notebook Memory for Select Apple iMac's and Macbooks KTA-MB1066K2/8G

     

    Also, I was running Lion, whichever release was current at the time.

     

    As I mentioned, I tried a few things that weren't successful but when I tried the following, my install went very easy.  Put one module in the lower slot, booted up and it was recognized.  Shut down and added the other module in the upper slot.  Booted up and both were recognized.

     

    I had done the PRAM/NVRAM reset prior but can't say whether that was necessary or not as I didn't test before and after.

     

    It may be a memory speed issue you have if your memory is 1333MHz, as vinesnob alludes to in his/her last paragraph in the thread just above.  Both he and you mention your 4GB module will only work in tandem with a 1GB module.

  • 31. Re: Memory Upgarde for 2010 MacMini
    Blunderbuss Level 1 Level 1 (0 points)

    All of the memory sticks are 1066MHz. I do however agree that this may be time-based, and that there is a slight possiblity that the time to "start up" a memory stick or the synchronization between the memory sticks could be an issue. However, I am still baffled at the fact that memory sticks I named A and B (Samsung) are so similar, yet, one of them consistently succeeds paired with any other memory stick while the other one won't even work alone.

     

    I have just attempted your approach, and it did not, this time, accept, the 4GB stick alone, for some reason. I will attempt again, just because I find this kind of defeat unacceptable, and because it sometimes does succeed (apparently not related to either praying and cursing, both of which I have tried plenty today). The inconsistency of results seems to indeed point to a timing issue, but I would still, oh so wish to have that one confirmed so that I can take action (or give up) accordingly.

     

    Thank you very much for sharing. Made this day a bit lighter.

     

    EDIT: while writing this post, my Mac Mini accepted the first of the two 4GB sticks at the lower slot. I don't know why it did, but it did. I'll try to feed it 4GB more on Monday.

  • 32. Re: Memory Upgarde for 2010 MacMini
    Blunderbuss Level 1 Level 1 (0 points)

    To follow up on my attempts:

     

    No, it did not work out. For some reason, only memory stick A (described in my first post here) in lower slot gives a stable configuration. Any of the memory sticks B, C, or D can then be put in upper slot, giving me either 2GB or 5GB. All other configurations, with either B, C or D in the lower slot will work after a while, but end up in an empty blue screen in the end (of death?). This is extremely weird, since A and B are essentially the same model. Also, one would expect C or D in the upper slot to cause instability, but that is not the case. Again, all of the memory sticks are 1066MHz, and A and B are also apparently the same model, which apparently came pre-installed.

     

    This is all the time I can put into this issue. Still, it would be nice to get more info from Apple, about the causes to this oddity so that the 5 (or more) people in the world, who prefer to upgrade their Mac Mini to buying a new oneand who happen to have bad luck (with their motherboard? with their PSU? with an overly eager EFI, with what, really?) could avoid the apparent pitfalls.

  • 33. Re: Memory Upgarde for 2010 MacMini
    Mechanicalmonkey Level 1 Level 1 (0 points)

    Just some input to the whole discussion. I bought the 8 gig kingston kit KTA-MB1066K2/8G to upgrade my Mac MIni mid 2010. Same problem as everyone here with the beeps and all. Slot 1 was the one working with the new sticks (check your system information > hardware > memory if you want to be sure which slot is working for you). Resetting the NVRAM did NOT do the trick for me but resetting the SMC did (http://support.apple.com/kb/HT3964). Now got 8 gigs (2 gigs/spent hour) !

  • 34. Re: Memory Upgarde for 2010 MacMini
    Gigdan Level 1 Level 1 (0 points)

    I’m having the same problem:  Kingston Technology 8GB Kit (2x4 GB Modules) fails to upgrade.  One stick works alone in the bottom slot, the other works alone in the top slot, and they’ll work with one of my 1gig sticks to give me 5 gigs of RAM.  But the two 4gig sticks won’t work together?

     

    I see that some of you reset your NVRAM / PRAM / SMC.  I’m a bit squeamish about doing that.  Can someone please suggest what to do? 

     

  • 35. Re: Memory Upgarde for 2010 MacMini
    Gigdan Level 1 Level 1 (0 points)

    Update to problem:

    After reading instructions on  Resetting the SMC for Mac Pro, Intel-based iMac, Intel-based Mac mini, or Intel-based Xserve

    1. Shut down the computer.
    2. Unplug the computer's power cord.
    3. Wait fifteen seconds.
    4. Attach the computer's power cord.
    5. Wait five seconds, then press the power button to turn on the computer.

    I had realized that my computer was left unplugged overnight with the two 4-gig sticks installed.   So, I went and  plugged it in, started it up and was thrilled to see that it started without beeping!  I checked the “About This Mac” and sure enough, it had 8 gigs of RAM!  I went on to check More Info/Hardware/Memory and both banks showed 4-gigs each with OK status!!

    My suggestion to anyone having this problem is: have patience!  I was getting frustrated and desperate, trying all kinds of remedies, and all it took was to unplug the darn computer for a little while!

  • 36. Re: Memory Upgarde for 2010 MacMini
    Fernando E Level 1 Level 1 (0 points)

    My two cents. I'm"spamming" all the threads that I had bookmarked in trying to fix this on my late 2009 mac mini:

     

    What worked with me with 2 x 4GB ram from OWC:

     

    1) Remove stock/old RAM from both slots.

    2) Inserted new stick of 4GB ram on top slot (in my case, this slot had no problem recognizing the new sticks).

    3) Leave the "buggy" RAM slot open.

    4) Start the mac mini up, performing the NV/PRAM reset (holding down Option + Command + P + R)

    5) When OS X boots up, shut down the mac mini.

    6) Insert the other stick of 4GB in the buggy ram slot.

    7) Restart the mac mini normally, not holding down any keys (normal boot).

    8) Profit

     

    Absolutely sailing on 8GB of OWC ram now. Sure, I've pulled hair out, RMA'd probably perfectly fine RAM with Newegg, and still clench when I restart the machine, but hey. This thing wasn't really meant to be opened, right?

     

    ;-)

  • 37. Re: Memory Upgarde for 2010 MacMini
    Blunderbuss Level 1 Level 1 (0 points)

    I'm truly glad it worked out for you, and also that you can take all that trouble as lightly. That said, I beg to differ on one of your accounts:

     

    If it really wasn't meant to be opened, Apple should be marketing their hardware (or certain serial number spans) as non-upgradeable, as opposed to providing a how-to sheet detailing how to open the casing to change the memory. As a software developer on Apples products, and knowing many others, I can note that hair-pulling is more of a rule than an exception with Apple, so I am out of excuses for them.

     

    This exact "Apple experience" has been systematic to all my work on Apple products, so in the end, I find the degree of customer contempt coming from this company, in disguise of incoherent, incomplete, obscurely implied, and plain incorrect information, unacceptable. If they had improved the ratio of people actually working on products (and documentation is a technical fact-based product!), to that of people lollygagging in their legal, sales, and marketing, I am sure the quality and coherence of all their products would improve enough to make me more positive to Apple as well.

     

    As it stands, I only wish that I, my customers, and my employer, and our mothers, could send Apple a bill on every hour wasted due to incorrect marketing (as opposed to documenting!) of their products, features, and API:s. All we want to know is the price tags, up-front. No excuses. Just correct price tags.


  • 38. Re: Memory Upgarde for 2010 MacMini
    S.J. from New Mexico Level 1 Level 1 (0 points)

    I have a Late 2009 Mac Mini 3,1 and have been experiencing the exact same issues in this thread when trying to upgrade to 8GB ram from 4GB. I bought 2x Kingston 4GB chips from amazon and only the top slot seems to work. Installing the old 2GB chip in the bottom slot with the new 4GB in the top worked too, leaving me with 6GB total. I've tried just about everything here on this thread, resetting PRAM and SMC, swapping chips in various configs, without any luck of getting either the entire 8GB or just the 4GB in the bottom slot working.

     

    BUT! As a last ditch resort, I tried Gigdan's solution. I installed the 8GB chips into the Mac Mini and left it unplugged overnight. In the morning, voila! It worked! I have no idea why it worked and can verify it didn't the night before. But as a guess, there was probably some latent energy in the computer keeping whatever initialized the memory still active. Give it some time to completely power down and dissipate seemed to work for me. Hope this helps someone.

  • 39. Re: Memory Upgarde for 2010 MacMini
    irob_swe Level 1 Level 1 (5 points)

    Count me in. I was supposed to upgrade three MM4.1 with 2x4G yesterday and was sent a batch of the latest KTA-MB1066/4G. I have spent 20+ years as an Apple techie and can tell this is probably the strangest RAM problem in history.

     

    Kingston has always been great the few times there has ever been a problem and I do recall they shipped a batch of this type of modules and they were also 4G where some might stop working. That was an early batch and something we got replacements for and replaced cost free the coming weeks back then. The stores was replaced withing days and the modules has not been seen since. The problematic modules was marked 222 but the replacements read something else, like 442. Just too bad I never got a mail about it. Anyway, it's a strange coincidense that the very same part number is still plagued with other problems and like some say - it's different modules in different computers and from different manufacturers. Wonder if it's a frequency problem where radio noise inside the computer interfere.

     

    I had a white MM3.1 exposed to capitalise on the 2x2GB ”fishing tackles” so during the crazy installation (before coming here) I did use it to verify that every single 4G-module was fine. They are not affected in the MM3.1 but only the MM4.1.

     

    The first computer would only start with a 2G-module in the lower slot (closest to motherboard). After some 50 trials I had to leave it with 6G as I was scared the slot might be worn out in my attempts. Nothing helped to get 4G booting in the lower slot.

     

    The next mini had problem with the upper slot (away from logic board). After some resets and shuffled reseats the mini started fine with 2G in the lower slot and a 4G in the upper, but only when I kept pressing the start button for 2 seconds. If I did like with the 2x2G and just touched the start button nothing would happen. The next time I touched the button it would start at the same moment but always to the RAM fault sound. This was a change in how you had to deal with the button. I replaced the lower and it booted just fine with 2x4G but had to tell the user to always push until the light would come on or else they would crash in the next attemt if she lost it. It didn't make any differance if I hold the button pressed in the first mini.

     

    The third mini was fine right away. 2x4G like it should!

     

    I guess the start button might help someone else but I will later try to install 2x4G and have it rest unplugged over night.

    I've repared a few firewire ports on the B&W G3's this way so I know the miracle might help. That was told to be fried components back then and Apple later (perhaps it was in the G4's they) put an extra wire on the female port to protect the circuits.

  • 40. Re: Memory Upgarde for 2010 MacMini
    nyc863 Level 1 Level 1 (0 points)

    Count me in.

     

    I bought Kingston MB1066K2/8G from Amazon it has "equiv Apple P/N MC016G/A" printed on it which is listed by Apple as being specifically for the Mid 2010 Mac Mini: http://www.parts-quick.com/mc016g-a.html

     

    either stick worked in the outer slot, neither stick worked in the inner slot. Tried SMC reset. Tried NVRAM reset. Tried leaving it powered off for a long time. Gave up. Observed that 4g+1g (original) worked giving 5gb.

     

    Then I switched this Kingston 4+4 to a late 2009 imac and they worked, replacing older 2gb+2gb modules, which I moved to the Mac Mini, and those worked there as well.

     

    Very frustrating, and a long waste of time.

     

    I doubt the memory is faulty so something about the specifications causes them to be rejected by Mac Mini 2010 but accepted by iMac late 2009, and clearly this Kingston part is NOT equivalent to Apple P/N MC016G/A -- or apple P/N MC016G/A may not work with Mac Mini.

     

    Or.. the Mac Mini is correct and I got a bad pair, but the iMac doesn't yet notice, and I can't run the hardware memory (AHT) test on either mac to check, because OSX 10.9 upgrade removed it.

1 2 3 Previous Next