5 Replies Latest reply: Sep 26, 2010 7:25 AM by kobran
P.D.G.Butler Level 1 Level 1 (0 points)
Hello,

Today I received a new iPod touch 8GB 2nd Generation from Apple, after my old one's audio jack failed. When I got home I decided to try and update to iOS 4 from 3.1.3. Download went fine, started to install. Everything went fine until my iPod got stuck with the Apple logo and the loading bar beneath. On my MacBook the loading bar is stuck on roughly 5%.

I was like sure, this has happened before to my 1st 8GB iTouch, we ended up getting that one replaced, then got the replaced one replaced again. So now I am on my second replacement, and it has failed me again.

I held down the home and lock button until it has reset. Original image comes up from when you first purchase the iPod, so yes I plug it into my laptop.

"iTunes has detected an iPod in recovery mode. You must restore this iPod before it can be used with iTunes"

Ok sure, so I decided to follow the instructions. Extracts all the data fine, then yet again gets stuck on roughly 5%, with the same image shown on the iPod.

Any one have any idea? Or will I have to return it to Apple.

Thanks.

iPhone OS 3.1.3
  • P.D.G.Butler Level 1 Level 1 (0 points)
    No one?
  • r.ellis Level 1 Level 1 (0 points)
    My device does the exactly same thing (iPod Touch 2G 32GB). However, my progress bar reaches 95%-98% completion before it hangs forever. I did my upgrade overnight so it stayed that way until I went back to my desktop to see if it finished. I thought about deleting the downloaded .ispw from the apple servers and re-download the latest firmware again, might help.

    I'll update as I see progress.

    Message was edited by: r.ellis
  • lola5951 Level 1 Level 1 (0 points)
    Sorry I can't help. But I just tried to update yesterday and it is doing the exact same thing. So I'll be checking to see if someone can offersome help on this.
  • ncbigman Level 1 Level 1 (0 points)
    I also initially had problems updating my iPod Touch 32GB 2G. I also got stuck with the Apple logo and the loading bar. iTunes gave me the message it could not connect with the iPod. I reset the device and tried again. This time I just had the Apple logo and no indication on iTunes that a device was connected. I disconnected the iPod and reset it again.

    At this point I thought about the fact that my battery was low and that I was also using a USB hub. I then used an external charger to charge up the battery on the iPod. After that I connected it directly to a USB port on my computer and this time it updated the software with no problem. I don't know if charging the iPod and connecting it directly to the computer made the difference or not. Perhaps as they say, the third time is the charm. So you might just need to try a couple more times. Good luck.

    I will also say that the upgrade seems to be a good one. After upgrading my iPod to OS4.0 I was getting several crashes a day and some apps just would not work. I haven't had a lot of time with OS4.1 but I haven't had any crashes since updating and programs that were not working are now working.
  • kobran Level 1 Level 1 (0 points)
    In my case iPod was already updated to the latest iOS. Suddenly, without charging or using iPod for 8 hours the iTunes/cable logo showed up on iPod. I assumed it wants me to connect to iTunes on the computer. I connected it and got message "itunes has detected an ipod in recovery mode".
    I didn't try to recover as I think it is some kind of a bug. Not sure what to do..