Previous 1 2 3 Next 33 Replies Latest reply: Apr 16, 2014 9:13 PM by TopSteve
Morris Taub Level 2 Level 2 (160 points)
How can I get it back on track please?...

I can still multiply, divide, and conquer

but I can't convert, currency, weights, distance, etc...

I'm lost, please help me...thanks...


MacBook Pro - 'Matte Screen' no glossy crap..., Mac OS X (10.5.8), ipod nano - NEC 2690 'matte screen'
  • biovizier Level 5 Level 5 (7,925 points)
    I haven't looked recently, but "" used to get its exchange rate information by contacting a web page at Apple that in turn got its information by scraping an IMF web page. In the past, if the layout of the original IMF page changed, the Apple page would parse it incorrectly, and "" would retrieve junk, causing currency conversions to fail.

    The current version of "" appears to fail to perform any conversions whatsoever (not just limited to currency) if it fails to read the "~/Library/Application Support/Calculator/FinancialRates.xml" file, something it will try to do if there is a currency conversion is in the "Recent Conversions" list.

    So until Apple fixes things from their end, if you need to perform currency conversions using "", it will likely be necessary to retrieve a valid "FinancialRates.xml" file from a backup, update it with current information by hand-editing it, then locking it to prevent "" from making further changes. I.e. it would probably be easier to use something else.

    If you need to perform conversions other than currency, try deleting the recent conversions list (the property name is 'RecentConversionsDefaultsKey_1' from the "~/Library/Preferences/" file, then refrain from selecting "Currency…" from the "Convert" menu.

    As long as there isn't a currency conversion in the "Recent Conversions" list, it should be possible to perform other conversions...

    Edit: It appears Apple is getting its info from Yahoo these days, not from the IMF page.
  • Morris Taub Level 2 Level 2 (160 points)
    oh my, this is confusing biovizier...I'm thinking I may look for some free calculator/converter and install and be happy (though not sure if one exists)...I don't want to be jumping through hoops for conversions...

    thanks for the detailed explanation...i will give clearing the plist a try and hunt for another apple compatible app for currency conversions...
  • Morris Taub Level 2 Level 2 (160 points)
    currency converter in Dashboard...helps me right away with some calcs...
  • Pierre Terrien Level 1 Level 1 (75 points)
    Thanks for the tip. I have the same problem with my calculator, which used to work just fine. Anybody know what's going on?
  • blindmull Level 1 Level 1 (0 points)
    Confirmed. Same problem here. After selecting on of the conversions in the menu not even the panel to select currencies will appear. Just 'nothing' happens.
  • Morris Taub Level 2 Level 2 (160 points)
    I think biovizier kind of outlined the problem...this is an apple related problem...when we hit 'convert' here, the software connects up someplace at apple who gets info from the internet...someplace that line of info is broken...this happened a few years ago and it took a while for apple to least i think it was that...

    so long as i have something to work with, the currency converter via Dashboard, i don't care if apple's calculator works or not, though it's slightly more convenient to keep open all the in europe, I need a daily tool to convert currency and often miles/inches to centimeters lost without it...
  • panta rhei Level 1 Level 1 (0 points)
    Thanks, biovizier!

    It seems to me that an almost-empty XML-file (without data) allows other conversions until Currency is tried. After that, the XML-file has zero size, but adding just a carriage return ot it brings other conversions back to life. For the time being, that is.

    I thought I had done something really, really stupid, but obviously there are Higher Powers at work here. Invoking the Currency conversion yesterday obviously cleared all data from the XML-file, so I'm not sure if a back-up is of any use.
  • firefoxx Level 1 Level 1 (0 points)
    My Calculator app still functions; it converts.
    The only thing that it is not doing is retrieving the current currency rates. That function is lost.
    The "Update" button is active, but the data is not updated.
    Perhaps the recent Safari update has something to do with this.
  • FunkyRico Level 1 Level 1 (5 points)
    Hi, Thank you,

    Same problem here, since... well? dont' know, but I guess not for so long.

    I tried to restore the "FinancialRates.xml" from an old backup but it does not help.

    You are right about removing the "" file, I finally can use the convert function again (except exchange rate).

  • epow Level 1 Level 1 (0 points)
    I have the exact same symptoms as Blindmull. Nothing at all happens when I select conversions. Pity. I really found this calendar function useful. (Calendar Version 4.0.6)
  • 200cm Level 1 Level 1 (0 points)
    Same thing here, I tried to use the currency converter with no success. Rates just don't get updated. No other conversion being executed, also.
  • elishasessions Level 1 Level 1 (0 points)
    Same here.

    Selecting any conversion from the menubar results in.... nothing.
  • weileongtan Level 1 Level 1 (0 points)
    just have to add that I'm running into this problem too. Had been relying on for rough currency conversions and now it's frustrating that nothing happens (AND no error messages - lucky for me google found a thread that led to this).
  • bc22 Level 1 Level 1 (0 points)
    Deleted the file and the calculator worked...for one conversion. Then nothing. There's a problem somewhere that needs fixin'
Previous 1 2 3 Next