7 Replies Latest reply: Mar 8, 2012 8:58 PM by boardingboy
Lommis Level 1 Level 1
I just went through my library and found a bunch of duplicates that I want to remove completely. I've usually done this by selecting the items I want to delete and hit cmd + backspace. Then it removes the item from any playlist, the Music library itself and from the iTunes Music folder.

When I try cmd+backspace, backspace, edit -> delete or right-click-delete on my selected items it removes them from the library and any playlist that also contains them, but not from the iTunes Music folder.

The weird thing about the whole thing is that it worked just fine yesterday when I deleted (cmd+backspace) a couple of songs, and also when I were running previous versions of iTunes. So, have I made any changes/installs since yesterday you may ask? No, nothing. Maybe I accidentally hit a key combination that does some stupid stuff, impossible to tell.

What I've tried:
- Every delete combination mentioned above
- Repair file permissions in Disk Utility (you never know)
- Reset all dialog warnings (in iTunes)

Other settings:
- Keep iTunes Media folder organized

So, any ideas on this issue? It's a real bugger when I have to locate the folder and delete it manually, and then remove the references in my library.

MBP, Mac OS X (10.5.8)
  • Lommis Level 1 Level 1
    A little update on this one.

    Just out of curiosity I tried to delete a couple of newly added songs, since the ones I tried to delete earlier were added a long time ago. The dialog box came up with options to trash the item, just like it's supposed to. Hooray!

    My bad for not trying/informing this before, didn't really think it would matter.

    So, now my wage theory is that there might be some permission issues, or maybe there's something itchy stuff going on with the database?

    I'll try to look deeper into it on my part.
    Any comments/tips on this issue would be greatly appreciated!
  • Lommis Level 1 Level 1
    Yet another update.

    Since iTunes now wants to import all songs added after the iTunes 10 update to "/Music/iTunes/iTunes Media/Music" instead of the old location: "/Music/iTunes/iTunes Music" it seems like iTunes can't delete files in the iTunes Music folder. Only in iTunes Media.

    What?! How can this be? I'm running out of ideas, and getting more and more frustrated.. Might the solution be uninstalling iTunes 10 and installing the oh so good version number 9? So stupid.

    Luckily for me there only ~150 songs added after the iTunes 10 update. I could just re-add them to the location used by the previous versions and see if that helps. But, since I look at my music library as holy ground I don't want to touch it without knowing what's going to happen.

    Anyway, anyone tried moving their old library to the new "iTunes Media/Music" folder? If so, what happened with ratings, play count, date added and so on? My guess is that iTunes will have problems location the new location of the songs in the Music library and playlists.

    Gasp, what to do.
  • Lommis Level 1 Level 1
    I solved it.
    Tried moving a couple of albums from the old library path to the new one (iTunes Media/Music), worked like a charm.

    Tagging this as answered.
  • Lommis Level 1 Level 1
    Solution is already posted in the thread.
  • fjsdofnsjgv Level 1 Level 1
    A cleaner solution is to hit option + backspace. Then you will be asked if you want to move the file to the trash.
  • malcolmfromqueanbeyan Level 1 Level 1

    Just the help Ineeded, thank you.


    The itunes help file under


    manage your itunes library > manage your files > Delete items


    just says  select the item and press the Delete key.


    On my Mac (with itunes 10) this has absolutely no effect; there is no response at all to the key press.

    Your solution to use option-delete works fine, but I can find no mention of it itunes help.


    Reading through this thread, the fact that I do not keep my music files in the itunes preferred folder may be relevant.


    Anyway, thanks for your posting.

  • boardingboy Level 1 Level 1

    I am having the same issue and I've tried the option+delete and nothing happened.

    Any ideas? This is driving me crazy! I have like 70 of the same empty playlists that magically appeared over night. UGH!