9 Replies Latest reply: Apr 12, 2011 8:42 AM by Town Mouse
Town Mouse Level 1 (0 points)
Hi - I've looked at the various posts on this topic but none of them seems to match the problem I'm having. I simply cannot get my Macbook to import photos from my Kodak camera. I get a few pictures to import, but the rest just appear as dotted line frames. There's nothing wrong with the camera - I can import them to my husband's Macbook no problem. So what's with mine I wonder? I'd be really grateful for some advice. Thanks.

Macbook, Mac OS X (10.6.4), Purchased February2010
  • kmike65 Level 1 (10 points)
    I'm having the same problem. One post suggested it might be because of movie files on your memory card. I had one. I deleted it. Suddenly I could import into iPhoto from my Kodak EasyShare with no problems. Only started having the problem after we "upgraded" to Snow Leopard. Hope Apple sees these posts and fixes the bug!
  • Shticky Level 1 (10 points)
    Same issue here. The problem occurred after a recent software update. I am running iPhoto 09 8.1.2 (424).

    Prior to this update I was able to import photos and videos from my Kodak Easyshare V550 camera.

    This isn't specific however to Kodak, because I can import photos and videos from a Kodak Playport HD camera fine. iPhone 3GS also works fine.

    When I searched my log, the most recent software update installed this item:
    9/8/10 9:28:53 PM /System/Library/CoreServices/Software Update.app/Contents/MacOS/Software Update[7560] Installed "Digital Camera Raw Compatibility Update" (3.3)

    Although I don't use RAW files, this may have altered the way that iPhoto sees the videos and photos on the memory card. Please help if you have any ideas. I tried creating another iPhoto library to attempt the import there, but I still see the dotted-line boxes where thumbnails should be and get the error that either there was a problem downloading or that it doesn't recognize the file type ".jpg".

  • Shticky Level 1 (10 points)
    Hmmm, after I read my own post I realized that there was something I could try. I took the memory card out of the Easyshare Kodak V550 and put it in the Kodak Playsport, then connected the playsport to my mac. When iPhoto launched it showed all the photo thumbnails on the SD card and had dotted outlines for all the videos. I chose to Import All and it worked fine.

    I then took the SD card out of the Playsport, put it in the Easyshare and formatted it on the camera. I then took one photo and one video and plugged the Easyshare into the mac.

    I saw in iPhoto the complete photo thumbnail but only dotted lines around the video. When I tried to Import All I got the error that there was a problem downloading a file. When I tried to import only the photo, I got the error that the file, "100123.JPG" was in an unrecognizable format. So something is happening in the communication between the camera and the software. The SD card is fine and can be read. The camera WAS working prior to a software update.

    Hope that helps.
  • Shticky Level 1 (10 points)
    Just another note, after I deleted the video on the card, and plugged the Easyshare back into the Mac, I was able to download the photo just fine.

    So I think we've narrowed this to Kodak Easyshare Cameras and .MOV files, Snow Leopard and iPhoto 09.
  • Town Mouse Level 1 (0 points)
    Thanks for help on this one. I've now realised - a bit late in the day - that the problem can be narrowed down to the memory card. Random photos haveimported ok, but the ones on the card seem to be the ones not loading properly. The Apple store guy suggested I try a card reader. Also re-formatting my memory card, but only once I was sure I had the photos stored elsewhere. I'm going to give that a try first and see how it goes. It's good to know I'm not the only one having problems with this.
  • umparrothead Level 3 (535 points)
    You can also try using Image Capture to import photos instead of iPhoto. It is able to send them directly into iPhoto, so the functionality would be the same, just with an outside program. This way, you could also determine if the issue lies with iPhoto or the OS.
  • April West Level 1 (0 points)
    I too am having problems. I just tried to use iphoto 11 and image capture to download images off my Cannon EOS Rebel. Image capture showed each of the photos (about 175), and said it was importing to iphoto, but the images never made it there. Now my camera shows that the images are gone, but they haven't shown up in either iphoto, photos, image capture, etc. HELP! is there a way to recover the pictures?
  • umparrothead Level 3 (535 points)
    You can try viewing the card through a card reader or another computer. In the future, confirm that the Delete photos after import is unchecked in Image Capture (bottom left corner). If the card is truly empty, its unlikely the photos can be recovered. Maybe they are on the computer somewhere.
  • Town Mouse Level 1 (0 points)
    Thanks to all who helped with this. It's so long ago now I can't quite remember how I resolved it, but resolve it I did with help from all of you.