Previous 1 3 4 5 6 7 Next 93 Replies Latest reply: Nov 1, 2012 4:07 AM by Jimmy-Stocks Go to original post
  • Tigg247 Level 1 Level 1 (0 points)
    For iPod touch (4th Generation):

    Go to settings, the go to wifi, turn it off and then turn it back on, click the little blue arrow on the network you are connected to, then change the DNS to either 8.8.8.8 or 8.8.4.4 (8.8.8.8 worked for me) then it should work.
  • ashama Level 1 Level 1 (0 points)
    I had this problem, and none of the previous answers worked for me. After testing several different approaches, I finally discovered what the problem was:

    * Your password must have at least 1 uppercase letter and 1 numeral in it. *

    The reason that new accounts work is because the process Apple set up for creating new accounts requires that you have at least 1 uppercase letter in your password. Older accounts, on the other hand, don't require having an uppercase letter.

    Try these steps:

    1. Go to: http://appleid.apple.com/
    2. Click on *Manage your account* and login.
    3. Click on *Password and Security*.
    4. Click on *Change Password*.
    5. Change your password. *Make sure your password has at least 1 uppercase letter and 1 numeral in it!*
    6. Click on the *Save Changes* button.
    7. Finally, go back to your iPhone or iPod Touch and try your new password in FaceTime, and voilà!

    Please let me know if this works for any of you. I am curious to know if this helps people out.

    Good luck!
  • Mac Chief 117 Level 1 Level 1 (0 points)
    Alright, so here's the deal. This may or may not be the answer to all of your problems, but here's what I found works.

    It might have something to do with your password settings. Facetime requires you to have a more strict password than regular apple id (Even though you use your apple id for facetime) So make sure that your username password meets the standards of facetime. (Minimum one capital, requires numbers and must be at least characters long I think?) Try this out, it worked for me.
  • Scattertron Level 1 Level 1 (0 points)
    If nothing else works, change your DNS settings. I had the same problem as everyone else, tried every fix, and it turned out to just be a DNS issue. Using 8.8.8.8,8.8.8.4 fixed everything. A warning though: although you can change back to your original DNS settings after you've activated your account and Facetime will still sign in successfully, you must still use the altered DNS if you want to be able to place/receive calls.
  • Jono2341 Level 1 Level 1 (0 points)
    What you need to do is go:
    Settings
    Wifi- click the blue arrow on your network name.
    Go to DNS and change what ever is there to:8.8.8.8,8.8.4.4(Write down the one that is there just encase you need to revert changes.


    This worked perfectly for me and if it doesn't work change the DNS back to what it was before or tap FORGET NETWORK and type in the password again.
  • morganzabean14 Level 1 Level 1 (0 points)
    I have two email adresses but the one of my apple ID I don't wish to use. I am trying to use the other one but it won't activate. I just cant seem to set up my FaceTime account.
  • Renomames Level 1 Level 1 (0 points)
    for who still cant actually changing the DNS to 8.8.4.4 worked pretty got for me yeii i think this problem may be coused by ios 4.2.1 because in 4.1 i didnt had that problem...
  • exitnine Level 1 Level 1 (0 points)
    well, actually check your firewall setting on your router, i got the same issue, but after the 8.8.8.8,8.8.4.4 still not work at all, i just change my router firewall setting and it work fine now.
  • verdejt Level 1 Level 1 (10 points)
    I figured mine out. I have DSL and on my wifi router I looked at my DSL settings and added the two DNS addresses from my router to my DNS settings in the wifi tab on my iPod touch, btw this also resolved the problem of my location not able to be found that I had earlier.
  • wired00 Level 1 Level 1 (0 points)
    Settings > network + wifi > click the blue arrow and change DNS to 8.8.8.8 (Google Public DNS) also worked for me. Was previously 10.1.1.1 my routers local IP address. No idea why this fixed things but logged in perfectly after this. Also before making this change i'd reset the device but i'm sure just changing the DNS would have done the same. Thanks to all those posting about using 8.8.8.8. Was doing my head in... apple really needs to sort this out...
  • Joseph Rizzo Level 1 Level 1 (30 points)
    I have had this issue since the very last iOS update. I can no longer log into Facetime via the iPod Touch 4G. I can log into Facetime via the Mac FaceTime application so I am certain the username & password are correct. I have checked that the username and address is verified on Apple's web site. I have tried changing the DNS settings to Googles as mentioned by a few people. I went into an Apple store and had 3 different employees try to get it working - but were unable to. I have changed the password to include a capital letter, numbers and characters as recommended by a few people. I have also tried to reset the network settings on the iPod Touch 4G.

    I definitely think there is a bug in the Facetime software on the IOS for the iPod Touch 4G. I believe somehow the old password gets stuck in there and isn't cleared out. I have been resisting doing and erase and restore because of the amount of work and time to restore and set up everything from scratch but if anyone has any other suggestions let me know. I was trying to wait for the next iOS update to see if this will fix it.
  • EZ Jim Level 7 Level 7 (21,785 points)
    Joseph Rizzo wrote:
    I have had this issue ... if anyone has any other suggestions let me know. ...


    http://www.apple.com/support/ipodtouch/contact/


    EZ Jim


    Mac Pro Quad Core (Early 2009) 2.93Ghz Mac OS X (10.6.6); MacBook Pro (13 inch, Mid 2009) 2.26GHz (10.6.6)
    LED Cinema Display; G4 PowerBook 1.67GHz (10.4.11); iBookSE 366MHz (10.3.9); External iSight; iPod4touch4.2.1
  • mike21b Level 1 Level 1 (0 points)
    That's the solution that works. I had given up on my iPod Touch, which was a Christmas gift, primarily to have video chats with family members scattered around the country. I couldn't log on.

    I changed password dozens of times. I could buy things in iTunes, log on to Apple sites, etc. - but not Facetime.

    Finally, in a last ditch attempt, I realized that when I originally created the password, it required at least 1 uppercase letter and 1 numeral in it, as ashama told us.

    It works now. I can use my everyday email identity, myname@myISP.com and the properly formatted password, and all is well.

    It would have been better if Apple made this requirement more clear to users.
  • Joseph Rizzo Level 1 Level 1 (30 points)
    Still a no go here. I have changed the password to include an upper case letter, lowercase letters and numbers. The account is 'verified' on Apple's web site. I can log in via iTunes, purchase items from the App store, can use Facetime on the Macintosh just can't get activated on the iPod Touch. (It did work previously on the iPod Touch until I believe the very last iOS update)

    I will wait until iOS 4.3 and see if that fixes it. Otherwise, I believe the only solution is to erase and set up as brand new iPod Touch.
  • verdejt Level 1 Level 1 (10 points)
    Check your router and look at your DNS Server address. Then once connected
    To your wifi make sure that those DNS server address are in your Touch
    Wireless config.
Previous 1 3 4 5 6 7 Next