14 Replies Latest reply: Oct 27, 2010 7:16 PM by maketuishome
Cminks Level 1 Level 1 (5 points)
I'm having issues launching a Microsoft Office application after using CleanMyMac. The app works fine in my guest user account, but when launching in my admin account the icon hangs out in the dock for a moment before closing down.

The console gives me the following message:
com.apple.launchd.peruser.501[552]
([oxo-ox7a07a]).com.microsoft.Outlook[1448]) Exited with exit code: 255

If anyone has any suggestions it would be greatly appreciated!

Macbook Pro, Mac OS X (10.6.4)
  • Allan Eckert Level 8 Level 8 (47,445 points)
    Sounds like CleanMyMac hosed your admin account for you.

    One of the primary reason I never use any of that type of applications. Personally I prefer to do any housecleaning myself rather then to trust an application to do it.


    ___________________

    Allan
    tiger
  • baltwo Level 9 Level 9 (61,995 points)
    I suspect it hosed the Office installation. Uninstall and reinstall it.
  • Allan Eckert Level 8 Level 8 (47,445 points)
    Why do you say that when the OP said it works in guest but not admin. That to me sounds more like a hosed user account rather then a hosed application.


    ___________________

    Allan
    tiger
  • Cminks Level 1 Level 1 (5 points)
    I've tried to reinstall the application. No dice.

    A hosed admin account doesn't sound too fun. No other application is having issues. Anything that can be done to recover?
  • Allan Eckert Level 8 Level 8 (47,445 points)
    My suggestion would be to create a new admin account and see if the new account is able to run Office.

    If it does that would give you two choices; either use the new admin account and delete the old one that doesn't work or troubleshoot the old account. Finding what is causing this problem can be a difficult task.


    ___________________

    Allan
    tiger
  • baltwo Level 9 Level 9 (61,995 points)
    I took that console listed failure to mean more than just a plist corruption. However, I've been wrong before. If the Office apps launch w/o issues in the new admin account, then any microsoft preference files shown in /new user account/Library/Preferences/ are the likely culprits. It might also be the stuff in the /old user/Documents/Microsoft User Data folder.
  • Cminks Level 1 Level 1 (5 points)
    New admin account launched the app just fine :/

    My preference would be to do the work to fix the original admin account, but I would consider both options to be difficult tasks!

    So do you think it's something specifically with the admin account or the office application itself?
  • baltwo Level 9 Level 9 (61,995 points)
    Since it works with the new account and the other one, it's definitely something amiss in the original account, most likely amongst the various preference files in that account's /Library/Preferences/. First thing to do is log into that account, move everything associated with MS and those apps into an empty folder on the Desktop, log out and back in, and see if the apps work w/o issues. if so, then you can either reset the preferences for the apps or move the moved one back in one a time, log out, and see if the issue returns. Laborious and time-consuming, but the best approach. If the issue still occurs, then something else is conflicting or corrupt.
  • Cminks Level 1 Level 1 (5 points)
    Thanks for the continued help.

    I removed all of the preference files - and I mean all - I didn't focus on just MS apps. Once all were moved, I logged out and back in to no avail.

    Is it safe to say that the problem is somewhere in the admin user folder? I can't find many other places that could be having this effect on this application!

    One other thing I didn't mention before is when I launch in my admin account, before it crashes, this window shows up and runs a few cycles (http://cl.ly/06e071e51c9aff810632). Then the app closes. In the other user accounts (where the app works), this window does not appear.
  • baltwo Level 9 Level 9 (61,995 points)
    Then, check the Microsoft User Data folder in your /Documents/ folder. Again, it's definitely something in that account. Another option is to log into another admin user account, delete the bad account, saving user data (put into a disk image inside /Users/Deleted Users/), recreate the account, using the same username and password, log into the recreated account, and see if that fixes the issue. Once you get it going correctly, mount the saved data disk image, and transfer your other stuff back.
  • dwb Level 7 Level 7 (21,725 points)
    When I run into Mac Office issues the first thing I do is delete the Microsoft preferences (plists). I've found that the MS fonts cache is often at fault. However it sounds like you've already tried that. The next thing I do is remove the Microsoft User Data folder which is in your Documents folder.

    Keep in mind that in your lIbrary folder there's a Microsoft folder as well as some com.microsoft.* files. You need to kill all of them to be sure you've done the lot.
  • Lifeform Level 1 Level 1 (0 points)
    I had the same error when Outlook started. In case this helps someone, I used my Time Machine to restore the entire Microsoft User Data folder in Documents to a few hours ago. When I re-started Outlook, I was prompted to rebuild the Main Identity by the Microsoft Database Utility.

    I did the rebuild and all is now fine, but I thought I'd mention it here in case someone wants to try just running the utility without restoring with Time Machine. You can launch it from Applications/Microsoft Office 2011/Office/Microsoft Database Utility.
  • WaterCons Level 1 Level 1 (0 points)
    I'm posting this both to thank baltwo and to confirm that the suggested methodology works in proper circumstances.

    When I upgraded to MS Office 2008 in my one user system the apps failed to start. I spent some time with MS Office support and posted to these discussions. As suggested I created a new user identity and since the problem didn't exist for that user, everyone's recommendation was that I should live with running MS Office under the new user identity and create a Shared directory accessible to both users, since solving the underlying problem might be more mucking around with the OS that I might be willing to do.

    Since MS Office 2011 is about to be released I decided to revisit the issue, came across this discussion, and tried throwing out (actually, quarantining them to a desktop folder) the Preferences files. There were three sets for the problem user: a series of "com.microsoft" files in the primary Preferences folder (eliminating these did not work), several in a "Microsoft" subfolder (ditto) and then, as might have been obvious with hindsight, a subfolder, "Office 2008". Those did the trick.
    When I restarted Word the software activated the Setup Assistant which wanted me to register the software and check for updates.

    After that, all has been well. That felt very good. Thanks again, baltwo.

    Never again shall I be intimidated by "mucking around in the OS." I used to do it at work back in Windows 3.1 and WordPerfect for Xenix days, how much worse could it be now? (Kidding about that last part. I'm sure it's more difficult).
  • maketuishome Level 1 Level 1 (0 points)
    Hello There

    I am having this very same issue, where in my console messages are returning the exited with exit code 255, this is for Outlook. The application initially launched fine, when I installed Office 2011. The application then asked you whether you want to create a custom profile, or import mail from another source, i.e Entourage, which I did do, from version 2008. The import seemed to work fine, could see all mail, then a few minutes later returned the error code, and now Outlook will not lanch

    I'm wandering if there is also a corrupt file somewhere?. I have reviewed all the notes from all the about Guru's, and nothing has worked so far?. Any ideas?.

    I've created a Test Account, but have not loaded the Office 2011 software against that new account yet. But thought I would post this query, to see if there were alternatives.

    Thanks in advanced

    Message was edited by: maketuishome