Previous 1 2 Next 16 Replies Latest reply: Jan 1, 2011 2:02 PM by K Shaffer
legolas-woodelf Level 1 Level 1 (0 points)
I want to upgrade from 10.3.9 to 10.5.

But before I do, I want to check the compatibility of my existing software. Is there anywhere online where you can check what programs will and won't get broken when you install a new OS?

Specifically I need to know if these versions of iLife will work with 10.5:

iMovie 4.0.1
iPhoto 4.0.3
GarageBand 1.0(7)

And am I right in saying that a new OS will include things like MacMail, iCal, Address Book etc.? If not, will my old ones work (1.3.11, 1.5.5 and 3.1.2 respectively) or will I have to buy new versions of those too?

I've generally steered clear of upgrades as in the past so I'm a bit ignorant of these things. The only reason I want to upgrade is that I'm being frozen out of more and more websites due to having an old browser/flash player etc. (but they're the latest I can run on my OS). I'm not fussed about new features, I just don't want to lose old ones.

Any help or advice on compatibility most gratefully accepted.

17" iMac 1.25Ghz 512MB RAM 80Gb Hard Drive, Mac OS X (10.3.x)
  • macjack Level 9 Level 9 (50,625 points)
    If your Mac is Intel, you could upgrade to 10.6 boxed set and the latest iLife & iWork would be included. I'm not sure if your existing iLife would work either in 10.5 or 10.6, it's a bit long in the tooth. Mine is iLife '06 but running running fine in 10.6.

    Here's a list of compatibility for 10.5...
    http://www.macintouch.com/leopard/compat.html
    And for 10.6...
    http://snowleopard.wikidot.com/

    EDIT: All the standard Mac apps would be included in any upgrade. i.e. Mail, iCal, Address Book, Safari, iChat, etc.
    http://www.apple.com/support/leopard/



    -mj

    Message was edited by: macjack
  • legolas-woodelf Level 1 Level 1 (0 points)
    Thanks for the reply Jack.

    My Mac is PowerPC G4 so 10.6 not an option.
    Looking at the list it seems my iDVD won't survive the upgrade and nor will my Photoshop Elements 2.
    Looking around ebay it looks like the OS - if I can win it - will be around £80 while some places are doing the OS, iLife, iWorks box set for around £110. So the latter might be my best option overall. At least I know it will all work.

    Sadly this doesn't endear me to the software industry. The only reason I need the upgrade is because more and more websites now use Flash 10 which my OS won't support. Everything else I'm happy with as is but I'm going to have to fork out again for software that I have essentially already bought once. And all to get me back where I started.

    I've always taken a dim view of any kind of software piracy, but experiences like this do tend to make one more inclined to embrace it.


    Thanks again for your help.
  • macjack Level 9 Level 9 (50,625 points)
    Try Apple Store telephone sales for the boxed set. I know here in the US they no longer have the item on line but is only available through telephone orders.



    -mj
  • Dave Hamilton Level 5 Level 5 (6,820 points)
    Looking at the list it seems my iDVD won't survive the upgrade and nor will my Photoshop Elements 2.

    When I upgraded my G4 (specs below) to 10.5 I found that iDVD 6 was painfully slow for encoding, around 3.5x the playback time of the project. Toast 7 is more than twice as fast for that at the highest quality setting, but with a trade-off. It can import iDVD projects and keep the chapter points, but the menus are lost.
  • legolas-woodelf Level 1 Level 1 (0 points)
    Thanks Dave.
    To be honest I've always had the same experience with my iDVD 4 that came with the machine. I literally have to leave it overnight to burn a complicated DVD, although all discs after the first (if I'm doing a batch of them) will burn quicker (is it asset encoding that takes the time?).

    I've never used Toast but may have to take a look.

    The good news is I've just ordered a brand new box set with 10.5.6 and iLife 09 for vaguely sensible money from ebay. The box is in German apparently but I'm assured the discs are all multilingual so hopefully that shouldn't be an issue.

    My hard drives are all backed up and I'll keep a partition on an external drive with 10.3.9 just in case. Will let you know how I get on when the discs arrive.

    My thanks to you all for your thoughts and advice - much appreciated.
  • Dave Hamilton Level 5 Level 5 (6,820 points)
    is it asset encoding that takes the time?

    Yes.
  • Dave Hamilton Level 5 Level 5 (6,820 points)
    I think I may have understated the encoding time for iDVD 6. I haven't used it in a long time, but it was much slower than iDVD 4 on my system.
  • legolas-woodelf Level 1 Level 1 (0 points)
    I guess that's progress.




  • K Shaffer Level 6 Level 6 (11,540 points)
    You may find a deal somewhere (even second-hand) on an iLife '06 retail install disc;
    that would be fine with Leopard 10.5.8. The iPhoto version is 6.0 (mine says 6.0.6)
    and the iMovie HD version is 6.0(.3) while GarageBand is 3.0(.4) and iWeb, v. 1.1.2.

    These have updates available after the iLife '06 is installed, from Support downloads.

    Depending on the hardware, some features of later iLife apps may not be fully supported.

    And the iTunes latest version (online from iTunes download) may have limitations in your
    older vintage G4 model. I'm currently using iTunes 8.2.1 since I don't have a newer iPod,
    iPad, iPhone, etc that may need the correct interface, or new/different Store content.

    {Reverting to an older iTunes version is somewhat busywork. The 8.2.1 is available still,
    and is listed in the iTunes downloads as "iTunes for G3s" but my copy precedes that name.
    While I have the latest iTunes install .dmg, I have not installed it; and Ignore Updates.}

    Any older saved items imported into a newer version of iLife should be updated; but they
    can't be used in the older version after they get converted (usually.)

    iLife '06 has, in the opinions of several users who have expressed them online, a better
    set of software in some aspects of iMovie, iDVD, than the later iLife '08. Since I don't
    really use those, such opinions should be researched before going past iLife '06.

    You may be able to find a deal on a retail (second hand) iLife '06 boxed disc; I did and
    paid only $10. including the box. I also got a retail boxed Leopard 10.5 for $10. in box.
    I already had iLife '06 (and iLife '08) but wanted another retail copy. Also have two 10.5s.
    A deal usually means personally finding someone who has upgraded to newer hardware.

    Good luck in matters big & small!
  • legolas-woodelf Level 1 Level 1 (0 points)
    I've just been doing a bit more trawling.

    It's looking like I may have a problem with iMovie too. It seems that the iMovie 09 that will come as part of iLife 09 won't work on a G4. However I've also read that my old iMovie 4 won't work with Leopard.

    I'll reserve judgement until the software arrives and I can try it, but if this is true then it's a very, very poor show from Apple. I'll be able to work round it 'cos I'm keeping a 10.3.9 boot partition on an external drive along with all its old applications, but it's a poor and inelegant solution.

    All of which has got me thinking - this all started because I can't use newer browser versions or FlashPlayer 10 (which more and more websites seem to need). I'm having to jump through a lot of hoops and kill a lot of my system at great expense just to sort this one problem.

    So approaching the problem from the other side, is there some whizzo Firefox fudge that I can use to con my 10.3.9 system into being able to look at FlashPlayer 10 driven websites?
  • K Shaffer Level 6 Level 6 (11,540 points)
    From the little bits of reading I've done, across some user forums
    and the limited experiences I've had with iLife app versions, the
    better or most likely supported ones look to be iLife '06 & iLife '08
    in the G4s running OS X 10.4.11 and OS X 10.5.8.

    And within various hardware specifications across different models,
    some preference was given the older iLife '06 with specific apps
    being more robust than their '08 replacements.

    There is a better likelihood of iLife '06 being the better performer;
    and the market for pre-owned can be anywhere from free/cheap to
    outrageous/expensive. The higher end may even be New/Oldstock.

    My iMac G4s have iLife '06; the iBook G4 has whatever it shipped with;
    so that one may have iLife '05 or something older than iLife '06.

    {The mid-2005 iBook G4 is hibernating in the closet, almost new, I won't
    awaken it until time to a monthly checkup and update browsers, do a
    battery check, perhaps calibrate them, and general maintenance.}

    iLife '06 works, from all the online bits I've read, well with Leopard & G4s.
    That's part of the reason I have retail installers for it; for whenever I up-
    grade the G4s I have with the Leopard 10.5 retail discs. It won't be a
    crash course upgrade, I will leave one at Tiger 10.4.11 while it works.
    My next upgrade would hopefully be a much more recent Mac & OS.

    Good luck & happy computing!
  • lisa cook Level 1 Level 1 (0 points)
    My English is not too good, so please have patience.
    I use 1.67 gHZ POWER PC G4
    MAC OSX 10.5.8
    As I gather reading the posts, ILife 09 will not work
    Which version of ILife should I try to buy: O6 or 08?
    Thank you for your help
  • K Shaffer Level 6 Level 6 (11,540 points)
    In order to find which version of iLife, be it '09, '08, '06, etc
    may be best for your computer model and OS X system,
    one has to match the iLife: System Requirements with the
    computer's hardware and software specifications.

    iLife '06 is most likely to work across all the apps and their
    limitations based on hardware your computer has inside it.

    {Also, note specs for the cameras one may use with iMovie
    and other iLife apps; since you may find a newer iLife version
    could allow newer cameras; but your computer may not have
    the support for such different advancements the version gives.}

    iLife '06 would work just fine in a PowerPC G4 Mac and
    probably do very well; and the software in iLife, if the
    computer supports the iDVD, iMovie, iWeb, GarageBand,
    iPhoto versions (and the need for DVD read/write) it may
    be the best choice. However, sometimes we find that we
    may have to settle for what we can find; among older
    software sets and obsolete hardware, you can get lucky.

    Here is a Support page with different versions of iLife and
    their specific system requirements; see if there is a match
    between what you can get (affordably & practically) which
    may work in your computer within its configuration limits.

    • iLife: System Requirements (versions: '04, '05, '06, '08, '09)
    http://support.apple.com/kb/TA27615

    {Since iLife '11 will not work at all in your PowerPC-based Mac
    the link above does not address this version at all. However,
    there are other Apple Support articles which cover iLife '11.}

    Note there are processor (cpu) and other hardware limits to using
    various iLife versions, so some older computers are not supported
    as newer product reflects changes in hardware advancements
    and later OS X versions.

    The iLife '09 may work in several models of Mac computer, but
    note the computer processor speeds, RAM requirements, and
    OS X version requirements; free or unused hard disk drive
    capacity, and other limitations will be details to watch for in the
    process of finding what iLife version may work for your Mac.

    As I said, some of the iApps in iLife won't work in your computer,
    when the iLife version is too new for the older Mac's hardware .

    Some users preferred certain advanced features in the apps
    in iLife '06 better than those in iLife '08; as some of the apps
    in iLife are light versions of more advanced pro software that is
    also available for purchase; there are music apps, photo apps,
    and other products outside of iLife's iDVD, iPhoto, etc that can
    do advanced things. But some versions of iLife have fairly good
    feature sets for their level of expected use.

    If you can get iLife '06 inexpensively (I bought an install DVD for
    $10 in the retail box, previously owned) that would be a fair version.
    To find a private person who has upgraded to a newer product, and
    who has the retail install DVD in box, you may get a fair deal.

    From what I see by comparing the most likely iLife versions your
    1.67GHz computer could run (not knowing other hardware specs)
    the iLife '06 could be most likely to succeed in a favorable way.
    The iLife '08 appears to state higher computer processor speeds
    would be required for one or more of the iLife apps.

    You would also have to pair a suitable camera's specs with those
    of the computer and the iLife version. While I have iLife '06 and
    also have an external iSight FireWire camera, I don't use them.
    I've been told the iSight camera (clips on display or sits on stand)
    can work with iChat, and some other iApps adequately. Not so
    sure if that would be good with iMovie. Some USB2.0 cameras
    could be used in last model PowerPC Macs; not sure which ones.

    So, it is my opinion you would do fairly well with iLife '06 in the
    computer model you have, but some users have installed a
    newer iPhoto and ran a different iMovie, etc. I have not read of
    how well that works. As some computers can't use all of the iLife
    apps (old Macs without a SuperDrive can't write DVDs, etc) so
    although the set of iLife apps gets installed together, you may
    be able to use Pacifist utility to pick and choose install packets.

    Getting a retail iLife '06 install DVD in good shape at less than
    an auction mark-up price, may be a difficulty. I found local items
    for cash, via Craigslist; and drove to meet real people at their
    home, to buy Mac gear. Also got a great deal from a former DSLR
    owner on a new Nikon battery, agreed to meet in a parking lot.

    What did your computer originally ship with? (Do you have the
    original install/restore DVD?) Seems to me, my mid-2005 iBook
    G4 (shipped Tiger 10.4.2) has iLife '04 or '05 in the original discs.

    I've seen iLife '06 on retail DVD for about $25. from web re-sellers
    who are not doing online auctions. Once you get the DVD, there
    are several download steps to get them updated. Be sure to get
    the steps installed, run Disk Utility's 'repair disk permissions' and
    then check for the next update download bits, & repeat as needed.

    (I save update bits on CDs or DVDs so I don't have to go online;
    and put them in folders, in the order the bits have to be installed,
    so as to save myself time if/when I have to reinstall anything.)

    Hopefully all of my writing here does more than just serve to confuse.
    Good luck & happy computing!
  • K Shaffer Level 6 Level 6 (11,540 points)
    PS:

    You may be able to find easier to read Support pages in a language
    more familiar to you than English; though I have not checked into it.

    Note:
    • Apple - Support - Country Selector:
    http://www.apple.com/support/country/

    Could be, there are alternate language pages in the Support Database
    of articles you may find more understandable, via the above link(?)

    Best wishes...
    Good luck & happy computing!
Previous 1 2 Next