10 Replies Latest reply: Sep 16, 2010 11:47 PM by Waterflyer
Patrick Van Nerum2 Level 1 Level 1 (30 points)
Hi All, like many I waited to update my iPhone 3g to update from 3.1.3 to 4.0.x.
So yesterday I did perform the update. Everything went well, iOS 4.1 was in my iPhone, but when iTunes started to sync my personal data back, the connection got lost and the iPhone rebooted itself. It kept doing that during data sync. So I restored the iPhone with new firmware, but the same problem occurred during the new firmware load.

Now it only boots in recovery mode and every time I want to recover my iPhone, it reboots you see a progress bar on the iPhone, but the iTunes comes with an error 2. There is no way the iPhone can be restored now. I tried 2 versions of iTunes 9 and 10. I try setting it in dfu mode and restore, but no luck.

I never jailbreaked my iPhone!

Patrick

ACSA, Mac OS X (10.6.4)
  • nick101 Level 4 Level 4 (3,655 points)
    Try a different PC or a different USB port (one that dosn't connect via any kind of hub). The process seems to be sensitive to the quality of the USB connection
  • Patrick Van Nerum2 Level 1 Level 1 (30 points)
    I've tried 4 different Macs
  • nick101 Level 4 Level 4 (3,655 points)
    Oh. Scratch that then.

    Try the following:

    1. Redownload and reintrall iTines. There seem to have been some issues with this
    2. Redownload the update and install to the phone
  • Patrick Van Nerum2 Level 1 Level 1 (30 points)
    That didn't work, I already tried. I also tried a machine with iTunes 9, but that didn't work either.
    I started up in dfu mode, but that again, it doesn't work. From the moment you get the progress bar on the iPhone and iTunes says it's going to update, the iPhone reboots. I think the problem is with the iPhone and not iTunes.
  • nick101 Level 4 Level 4 (3,655 points)
    It looks as if it's the hardware as you suspect.

    Sorry

    Message was edited by: nick101
  • Patrick Van Nerum2 Level 1 Level 1 (30 points)
    No problem, your help is very appreciated!

    I think it's hardware too, but it's so strange that it happened after a software update.
  • rimshaker Level 3 Level 3 (515 points)
    The 4.1 update is kinda tricky in that it does all these extra steps and reboots that I never seen in all my previous updates.

    I also updated from 3.1.3 last nite and was a nervous wreck the whole time lol. The update did a complete backup/restore of everything so it took over an hour to complete the upgrade. In all previous ones it only took 15-20min max.

    My phone rebooted several times during the whole process. Couple times i also thought it locked up when the progress bar didnt seem to move. Just take a deep breath and walk away for a bit. So try plugging it back in and see what happens. Make sure your internet connection is working btw.
  • Patrick Van Nerum2 Level 1 Level 1 (30 points)
    When the iPhone reboots, iTunes generates an error 2 message. The error 2 message is very general.
  • Smilingbo Level 1 Level 1 (0 points)
    My iphone did the same and then I managed to get it going again by installing itunes 10 on my work computer. My problem seems to be because I have 10.4.11 and itunes 10 doesn't work on my mac, when 4.1 was downloaded, it crashed my iphone.

    Since I got it working on my work PC, I thought I'd try to restore it again to get my backup on to my phone, and I'm back to square one again now.
  • Waterflyer Level 1 Level 1 (0 points)
    Hi Patrick

    I have an iPhone4. I tried upgrading to os4.1. Had the exact problem like you had. I thought I bricked the phone. But I got it come back to life eventually. Here is how I did
    I used a program called tiny umbrella. I clicked start TSS server then clicked kick out of dfu mode(please check wording for similar ones. I cannot remember exact name from top oft head. But it is below the start tsp server area). Then magic happened the phone reboot and starts like normal. But all my app installed was lost. Luckily all contacts emails messages were retained. That is very lucky! Hope that helps.

    Message was edited by: Waterflyer

    Message was edited by: Waterflyer

    Message was edited by: Waterflyer