Skip navigation
This discussion is archived

Log In with Apple ID

5781 Views 13 Replies Latest reply: Dec 16, 2010 7:02 PM by Grant Harrington1 RSS
Jim Kuback Calculating status...
Currently Being Moderated
Sep 10, 2010 7:19 AM
Hi
I just wanted to print my book - therefore I have to log in with my apple id. When clicking on log in aperture is taking my apple id but wants me to create a new account.

It asks me for my password (twice) and my security question (which is already completed).

When I enter (twice) my password and my (already completed) security question answer, aperture wants me to use an email adress and states that the answer for my security question is wrong.

Whats the problem?

I have a new aperture version and 10.6.4 - everything up to date.

Thx for advise
Regards
Jim
iMac, Mac OS X (10.6.4)
  • davidcrickett Calculating status...
    Currently Being Moderated
    Sep 30, 2010 9:50 AM (in response to Jim Kuback)
    I have the same problem. Very annoying! And no answers...

    Message was edited by: davidcrickett

    Message was edited by: davidcrickett
    iMac '27 2010, Mac OS X (10.6.4)
  • JDrizzle Calculating status...
    Currently Being Moderated
    Nov 3, 2010 6:47 PM (in response to Jim Kuback)
    Same exact problem. I am running Aperture 3.1 with OS X 10.6.4. Both my wife and I each tried our account and we are both getting the same issue as you have described. I actually just created a new thread about it.

    Anyone have any suggestions? I was wanting to buy a few prints to test the quality before choosing a print vendor.

    Thanks in advance.
    24" iMac ~ Mac Mini G4 ~ iPhone 4G ~ iPod Color ~ iPod Shuffle 2G
  • ErbWVU Calculating status...
    Currently Being Moderated
    Nov 29, 2010 8:59 AM (in response to Jim Kuback)
    The apple ID has to be in the form of an email address and the answer to the security question has to be at least 6 characters long. This should get you past the create an account page and to the terms and conditions page.
  • Grant Harrington1 Level 2 Level 2 (370 points)
    Currently Being Moderated
    Dec 5, 2010 7:13 PM (in response to ErbWVU)
    I'm just trying to order my first Aperture 3.1 book too. Same issues, enter my Apple ID, in the form of an Email address, in fact the same one I'm using to login here to post question, and the same Apple ID I use to buy iTunes music.

    It asks me to create an Apple Account once I've entered my Apple ID, password, and click Sign In.

    Do I have to just re-enter my password? I already have Security Questions set, do I re-type those as well?

    My big concern is making sure that my Apple ID doesn't get 'reset' by simply ordering a book from Aperture.
    MacBook Pro 2.2 GHz Intel Core 2 Duo 4 GB 667 MHz DDR2 SDRAM, Mac OS X (10.6.4), Final Cut Studio 3, Aperture 3
  • Royceybaby Calculating status...
    Currently Being Moderated
    Dec 6, 2010 2:31 AM (in response to Jim Kuback)
    Anybody got round this yet? I can't logon with an email address and I can't continue with my apple id.
    Macbook Pro, Mac OS X (10.6.5)
  • KNPhoto Calculating status...
    Currently Being Moderated
    Dec 6, 2010 1:35 PM (in response to Jim Kuback)
    I have the same issue--two months after OP. At first, I thought a second account to handle the printed pieces was needed. That, obviously was not correct. Hopefully, an answer is forthcoming on this. *Without the ability to order successfully, no orders get placed*.
    IMac, Mac OS X (10.6.5)
  • Royceybaby Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 7, 2010 12:58 AM (in response to KNPhoto)
    I created a new account just to get these printed.
    Macbook Pro, Mac OS X (10.6.5)
  • Frank Caggiano Level 7 Level 7 (22,830 points)
    Currently Being Moderated
    Dec 8, 2010 7:56 AM (in response to Jim Kuback)
    Have you tried the suggestions at [Aperture 3: Book ordering panel turns white when submitting an order|http://support.apple.com/kb/TS3464]

    Not exactly your symptoms but it might be worth a shot. Having one click ordering turned in is, as I remember from having similar problems back with iPhoto, important.
    iMac Intel 3.06 GHz 8GB Mem; Macbook5.1 2.4ghz 4GB Mem, Mac OS X (10.6.5), Aperture 3.1
  • KNPhoto Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2010 3:00 PM (in response to Royceybaby)
    Not quite sure what happened. But, was successful after making the shipping and billing address the same in the Apple Account.
    IMac, Mac OS X (10.4.11)
  • Grant Harrington1 Level 2 Level 2 (370 points)
    Currently Being Moderated
    Dec 10, 2010 9:38 PM (in response to Frank Caggiano)
    I've been emailing Apple back and forth for several days with no resolve. What I did was just re-enter the password of my current account (where it said to create a New Account).

    BuyBook (Screen1)
    Login:
    Password:

    Screen2
    Where it asks for a New Account setup page
    Just entered my current password, and it went to the next page and I was able to place the order. It's very misleading to say the least. This wasn't advice given by Apple, they still haven't got back to me with my last reply, I just wanted to get this book ordered, so gave it a try.

    I tried AdoramaPix, ShutterFly, and SnapFish's book offerings, but none compared to the quality and layout control offered in Aperture. I was trying those while trying to this issue sorted.

    I've ordered my book and am anxiously awaiting it's delivery.
    MacBook Pro 2.2 GHz Intel Core 2 Duo 4 GB 667 MHz DDR2 SDRAM, Mac OS X (10.6.4), Final Cut Studio 3, Aperture 3
  • 100044.1717@CompuServe.com Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 10, 2010 11:46 PM (in response to Jim Kuback)
    I had exactly the same problem. Created a new password, was the directed to a new site and asked to set THREE security questions & answers. When trying I got always the message "Question not found".
    Gave up.
    12 Hours later I could log on with the new password without a problem. Very strange. Apple didn't respond to my Email up to now.
    iMac 27", 2,8 GHz, i7 Quad-Core; G4 Powerbook 17', iPod 40GB, iPod 60 GB, Mac OS X (10.6.4), G4 Powerbook 17': 1,5 GHz; 2 GB RAM
  • Seane Warzusan Calculating status...
    Currently Being Moderated
    Dec 12, 2010 1:07 PM (in response to Jim Kuback)
    Same issue. I was pulling my hair out yesterday trying to get around it. After I finally found a way around the Apple ID issue it was claiming that parts of my address were incorrect... dumb parts, like the state field, Texas lol. It wouldn't even take different variations of it.

    While doing this I also noticed that four different charges of $1.10 popped up in my account from Apple. Weird! They are still pending transactions so I'm going to wait till monday to see if they get erased or not.

    So today I decided to give it another shot and noticed there was a new update for Aperture... I downloaded it and it works like a charm.
    24" iMac, 13" Macbook pro, Mac OS X (10.6.5), www.seanewarzusan.com
  • Grant Harrington1 Level 2 Level 2 (370 points)
    Currently Being Moderated
    Dec 16, 2010 7:02 PM (in response to Grant Harrington1)
    Well, I got my books (ordered two) on 12/15/10. I got an email saying:

    You may have already received an email advising that your order has shipped, but which did not contain a tracking number. At your request, Apple has upgraded the shipping for your purchase. Order xxxxxxxx was shipped with the following tracking number:

    Now, I didn't request an upgrade on shipping, so I hope I don't get charged for an upgrade in shipping costs.

    I'm happy with the quality of the book, but it was a hassle to order. Hope it goes well for others here.
    MacBook Pro 2.2 GHz Intel Core 2 Duo 4 GB 667 MHz DDR2 SDRAM, Mac OS X (10.6.4), Final Cut Studio 3, Aperture 3

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.