Skip navigation
This discussion is archived

Macbook stuck in sleep mode

5553 Views 7 Replies Latest reply: Oct 21, 2010 5:19 PM by hananias RSS
karlw00t Calculating status...
Currently Being Moderated
Sep 13, 2010 3:47 AM
I let my computer on over night, and when I came back to it this morning it was in sleep mode. I know this because the light on the front right on the laptop was fading in and out. I tried to move the mouse, and nothing. Pressed the power button ... no change. I ended up just holding down the power button to get the computer to turn off, and then started it back up again. I have a 13 inch Macbook Pro with Snow Leopard (10.6.4). I never set my computer to go into sleep mode. I normally leave it plugged in all the time.

I opened up the sys log file (in /var/log/system.log) and it looks like Chrome did something funny. Any ideas?

<pre>
Sep 13 04:32:42 CapitalCity [0x0-0x48048].com.google.Chrome[1143]: [3799:519:103326477980838:ERROR:/b/slave/chrome-official-mac/build/src/base/pla tformthreadmac.mm(66)] pthreadsetnamenp: Operation not permitted
Sep 13 04:32:42 CapitalCity [0x0-0x48048].com.google.Chrome[1143]: [3799:11015:103326478994823:ERROR:/b/slave/chrome-official-mac/build/src/base/p latformthreadmac.mm(66)] pthreadsetnamenp: Operation not permitted
Sep 13 04:32:42 CapitalCity sandboxd[3800]: Google Chrome He(3799) deny sysctl-write
Sep 13 04:32:42: --- last message repeated 1 time ---
Sep 13 04:32:42 CapitalCity sandboxd[3800]: Google Chrome He(3801) deny sysctl-write
Sep 13 04:32:42 CapitalCity [0x0-0x48048].com.google.Chrome[1143]: [3801:519:103326573860039:ERROR:/b/slave/chrome-official-mac/build/src/base/pla tformthreadmac.mm(66)] pthreadsetnamenp: Operation not permitted
Sep 13 04:32:42 CapitalCity sandboxd[3800]: Google Chrome He(3801) deny sysctl-write
Sep 13 04:32:42 CapitalCity [0x0-0x48048].com.google.Chrome[1143]: [3801:16131:103326574404625:ERROR:/b/slave/chrome-official-mac/build/src/base/p latformthreadmac.mm(66)] pthreadsetnamenp: Operation not permitted
Sep 13 04:51:11 CapitalCity com.apple.backupd-auto[3834]: Not starting scheduled Time Machine backup - time machine destination not resolvable.
Sep 13 06:24:54 localhost com.apple.launchd[1]: * launchd[1] has started up. *
Sep 13 06:25:00 localhost DirectoryService[15]: Improper shutdown detected
</pre>

Message was edited by: karlw00t
Macbook Pro 13 inch (3rd gen), Mac OS X (10.6.4)
  • Barney-15E Level 7 Level 7 (33,420 points)
    Currently Being Moderated
    Sep 13, 2010 3:58 AM (in response to karlw00t)
    Did the battery drain to the point it went to sleep regardless of your settings?
    1.8 SP G5/iMac G4 FP/MBP 2.33/iPhone, Mac OS X (10.6.4)
  • Lee Royle Calculating status...
    Currently Being Moderated
    Sep 13, 2010 4:22 AM (in response to karlw00t)
    This happened to me once. I just kept finger on power button to force shut down. Then booted back up. Been fine since.
    Macbook Pro 15" 2.4Ghz, Mac OS X (10.5.7)
  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2010 5:24 AM (in response to Lee Royle)
    I am having a similar problem. but I didn't leave the computer overnight. I had in the past, but recently I noticed my white unibody macbook 2009 won't sleep at all. If I go down the menu bar and hit sleep, or use the hotkeys combo to sleep, or closing the lid... no matter what i do, it won't sleep! Actually, the screens turns off, and the computer stays running. The power light (regularly sleep mode, the light usually fades on and off) but when I try to put macbook to sleep, screen turns off, and the power light stays on (no fading) and the fans stay on, they wont stop either (macbook stays warm/hot). So I have no idea what to do next. I've tried checking my disk, repairing...everything is fine. Even did a big cleaning with (onyx program) and after restart, still same problem.

    After the macbook crashes, I have to force restart. Send the report to Apple (via the crash report). I don't think it does any good. I don't understand a word that reports says. So I'm pretty much stuck, with a slightly broken new macbook

    Another complain is that I can't post a new post here in apple forums... I mean, I don't see any links to "new post" or something to that nature...
    Macbook 6,1, iphone 3g 16g, Mac OS X (10.6.4), iphone 3g 4.1
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Oct 21, 2010 10:45 AM (in response to karlw00t)

    If your Mac happily goes to sleep but won't wake up--Hold down the power switch to force-reboot your machine and get it running again.

    Try resetting the PRAM. This should reset the NVRAM on most machines, which is the suggested fix.

     

    DALE

     

     

    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.4), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Oct 21, 2010 10:50 AM (in response to hananias)

    How to post a New Topic.

    Not sleeping is not similiar to not waking from sleep.

    This is for a Mac that won't sleep.
    Here is Apple doc.#303698 with their tips.

    Mine follow;
    USB devices and hubs often cause Macs to not sleep or wake quickly from sleep (notably HP printers and scanners, HP all in ones, and Cannon scanners). Disconnect all USB except for keyboard and mouse and try. If it sleeps, add one back at a time testing after each one to find the culprit.
    If you've set your Mac to receive faxes, it may not be able to sleep. It might also have a damaged preferences file.
    If you use your Mac for faxing, open System Preferences. click Print & Fax, click the Faxing tab, and uncheck the Receive Faxes On This Computer box.
    If that doesn't work or you've never faxed on your Mac, go to Finder/Hard Drive /Library/Preferences/SystemConfiguration and delete the com.apple.PowerManagement.plist and com..apple.AutoWake.plist files (if your Mac asks, type your admin. password).
    If the latter file isn't present in the folder, go to user name(probably your name)/Library/Preferences, delete the com.apple.systemuiserver.plist file, and reboot your Mac.

    Some, in these forums, have had luck fixing sleep issues downloading the Combo update from this site (yours may be corrupt), not Software Update (10.6.4 Combo, etc.), disconnect all firewire + USB devices except keyboard + mouse,Repair Permissions, re-install update, Repair Permissions again + try.

    You can install it right over what you have now.

    Many here have reported no wake from sleep or failure to sleep, running 10.6.3 on MacBooks, using Parallels and VMware. No solution yet.

    User tips……..

    In System Preferences > Energy Saver is "Wake for network access" checked?
    If so uncheck it and test.

    Also, if you have an External Western Digital (WD) hard drive and have installed
    WDDMService and WDSmartWareD on your Mac, it may not sleep. Fix is to un-install those....you don't need them to use the drive.

    "I have had this problem with my IMac G5. It is surprisingly irritating. LaCie's Silverkeeper backup software was the cause. By default it gave itself permission to wake up the computer to check if a backup was needed. Do you have this or a similar program installed which has scheduled activities including wake-up permissions as an option?"

    One provided this link, xlr8yourmac.com, to a member, which addresses failure of deep sleep with some users that updated and added new FireWire and USB cards.

    Also, here is Apple doc.#305262 about PCI cards and sleep.

    After few days of messing around I found out that I had desktop background (wallpaper) set to change every 1 minute.
    After unchecking "Change picture..." in system preferences (under Desktop/Screen saver), my powerbook went to sleep all by itself.

    One noticed this; "I have a Canon printer(shared) and my imac would not sleep. I opened up printer/fax in system prefs and noticed it said the printer was in use when it was off. Opened up the printer queue and noticed about 7 pending documents. Deleted them all and now it sleeps.
    Check the printer queue!"

     

    DALE

     

     

    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.4), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Oct 21, 2010 11:00 AM (in response to hananias)

    I gave you the wrong link on posting New Topic. Here is the correct one.
    The link is in the upper left hand corner above all the current posts.

     

    DALE

     



    Message was edited by: Dale Weisshaar

    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.4), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • hananias Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 21, 2010 5:19 PM (in response to Dale Weisshaar)
    about "new post" thanks... I for got I had to go so deep inside the forums topics, to actually see "post a new topic". Not so "apple like" (usually things are easy, and right in front of you)... oh well.

    About the sleep (or never going to sleep cause of a crash)... I tried going to sleep with out anything except the power cord connected. I also tried, doing it on batteries. Still the same problem! I don't know how to reset ram... anyways is a little late now. Yesterday I spend the day reinstalling SL. Updated everything ilife 09, iwork 09, and osx 10.6.4 and everything is working fine. Going to sleep quick! I installed most apps and brought back all my docs, music, and movies. Still everything is fine. I'm guessing you are right about ram causing the problem... if there's a next time i'll try that. Thanks your advices, you really thought a lot about this. Thank you!
    Macbook 6,1, iphone 3g 16g, Mac OS X (10.6.4), iphone OS 4.1

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.