3 Replies Latest reply: Sep 13, 2010 3:16 PM by mtclimber
Kavin Level 1 Level 1 (0 points)
Just updated to IOS4, unfortunately my iphone has frozen with link to itunes screen and my itunes is not detecting my iphone. Tried restrting the iphone by holding on to home and off. The apple logo appears but it still oes back to link to itunes screen on my iphone. any sugestions ?

IBM Laptop
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    Hi Kevin and welcome to Apple Discussions...

    Go here for help .. iPhone and iPod touch: Frozen and unresponsive

    If that didn't help.. iPhone, iPad, or iPod touch: Device not recognized in iTunes for Windows










    Carolyn
  • Dizainer Level 1 Level 1 (0 points)
    I have the same problem.
    My Iphone doesn't sync to PC. OS Windows 7
    Try evrething to you say. Not work. Iphone goes back to link to itunes screen.

    But I noticed that in Device Manager, there are two new hardware (apple mobile device recovery modes). I tried to manually install the driver. One device is installed, and the second is not. Maybe some software conflicts? Maybe Try to reinstall my OS?

    Tell me please, my Iphone can be revived, or was his death?
  • mtclimber Level 1 Level 1 (0 points)
    I had this same thing happen to my 3GS after the update. I have both a MAC G5 and a Windows XP; neither would respond. It would just show the "insert usb into Itunes" graphic on the Iphone. After going through all types of things with Apple care. They shipped me a replacement phone. The new phone would not work on the Windows PC, but got it working on the MAC. I got it all sync'd and working, but only from the MAC.

    I am still trying to get it to work on the Windows. I did all the stuff the links you showed said. The Iphone comes up as the Iphone on my computer, but Itunes does not see it. When you plug in the USB, it comes up with the Windows dialog for a camera and which photo editing software to use.

    I reinstalled Itunes, reset the Iphone, checked device manager, dumped cache, unplugged all USB devices, even went to "configsys" and turned everything off and it still didn't work.

    Anything else to try?