8 Replies Latest reply: Nov 18, 2014 10:26 AM by broadws
bbhlind Level 1 (0 points)
My iPad use to connect to my Verizon FIOS Wireless Router (Wireless G) It now will not connect and says invalid PW. I disabled the WEP security and it would still not connect. My iPhone and other computers all connect. I have reset the wireless settings to the factory and it still will not connect. I have firmware 3.2.2 (7B500)on my iPad. I also have a Wireless N router and the iPad connects to that but not the Verizon Wireless G. Has anyone have any suggestions? Thanks!

iPad, iPhone OS 3.1.3, iPad 3G 64GB
  • Armando Stettner Level 2 (205 points)
    You should ensure the Verizon router does not use MAC address security meaning the router only allows explicitly listed devices to connect to it.

    Of course (and forgive these suggestions but just covering the bases) ensure the right password (check the other computers' to ensure you are using what they use), capital letters (sometimes the auto-capitalization of the commuter or iPad might kick in) and that you are hitting the right wireless router (not your neighbors' routers).

    Which Verizon router?

    I am on a Verizon router using my iPad to type this message.
  • bbhlind Level 1 (0 points)
    Thanks for the input. My router has the MAC address disabled and definately am typing in the correct password with the correct case sensitivity as my laptops and iPhone are connecting with it too. Any other suggestions? Thx!
  • Armando Stettner Level 2 (205 points)
    What's the model of this router? And, I assume this is for Verizon's FiOS service?
  • bbhlind Level 1 (0 points)
    The model number is MI424-WR with Hardware Version D, Firmware 4.0.16.1.56.0.10.12.4.1 and it is for Verizon FIOS service. Thx!
  • JimHdk Level 7 (28,340 points)
    bbhlind wrote:
    My iPad used to connect to my Verizon FIOS Wireless Router (Wireless G) It now will not connect and says invalid PW. I disabled the WEP security and it would still not connect. My iPhone and other computers all connect. I have reset the wireless settings to the factory and it still will not connect. I have firmware 3.2.2 (7B500)on my iPad. I also have a Wireless N router and the iPad connects to that but not the Verizon Wireless G. Has anyone have any suggestions? Thanks!


    If it previously connected but no longer connects try restarting the router. You may also want to try resetting the Network settings on your iPad +(Go to Settings > General > Reset > Reset Network Settings)+
  • Level 6 (11,040 points)
    I have a similar problem. New iPad 64GB Wifi. Works with WiFi at work, but with my home computer (Dell) and DSL (Verizon Westell 7500), I get the "Incorrect password for [my network]" error. Have tried numerous times, so I'm sure I'm typing the password correctly. Have rebooted everything. Fujitsu tablet (Windows 7) works fine. Suggestions?
  • kaikealoha Level 1 (0 points)

    HI, I had the same issue, contacted Apple and Verzon, no help. Then I decided to try setting the wireless mode to Legacy 802.11bg only and it worked for Me. here's a link to the manual, you will need to log in to your fios router to change this setting.

     

    http://support.actiontec.com/doc_files/MI424WR_Rev._G_User_Manual_30.16.0_v1.pdf

     

    read page 40 of the linked pdf to see where to change this in the fios actiontec router.

  • broadws Level 1 (0 points)

    I had the same problem with any one who had an Apple phone who wanted to connect to my home FIOS network. Android phones connect without issues.

    Apple phones say password is incorrect. The fix is to go manual... enter the ssid of your router then select wpa2 security and enter the password. It will then connect without issue. Dont ask me why iphone doesnt know its wpa2 but I think that is the issue. Anyway ... it works.