Previous 1 2 3 4 Next 56 Replies Latest reply: May 22, 2013 9:42 PM by Peter Thomsen
Christian Riley Level 2 (250 points)
[I posted this in the wrong section first, although it did apply there since I tried it on a 2008 Mac Pro]

I tried a 3TB Seagate Barracuda XT drive in the July 2010 Mac Pro (and a Jan 2008 Mac Pro) on the RAID Card that came with the machines (so one is the RAID Card now shipping) and both show a maximum of 2.2 TB with a 3TB drive.

I'm curious if anyone else has tried this with different results. Any luck in getting the RAID Card to see the full 3TB in the drives?

By the way, without the RAID Card, the Mac (OS 10.6.4) sees the full 3TB, but not with it.

Anyone else seeing this?

2010 Mac Pro, Mac OS X (10.6.4)
  • Christian Riley Level 2 (250 points)
    Well, it is an internal drive attached to the RAID card and it only displays it as a 2.2 TB drive when attached to the RAID cards (on either MacPro). The same drive shows it as a 3.0 TB drive when connected without the RAID card, so I don't think it is a question of initialization although I appreciate the thought.

    I just looked some more:

    The RAID card shows 1 (or 4 for that matter) 2.2 TB drives attached vs 2.0 TB for the old drives. For example it shows "Bay 1" as Capacity 2.2 TB. Whereas when it is directly connected it shows a 3.0 TB and works perfectly.

    In Disk Utility it shows the same.
  • The hatter Level 9 (60,930 points)
    Probably most of your questions can be answered with RAID card FAQ

    And can be found from main page for us:
  • Christian Riley Level 2 (250 points)
    Alas, no, those documents don't mention 3 TB hard drives. They don't mention 4k blocks or 512 byte blocks or anything very technical. They are quite generic and since the 3 TB drives are only weeks old, I doubt this is a "frequently" asked question.
  • The hatter Level 9 (60,930 points)
    ..... because 3TB drives weren't in existence, and it is almost unheard of for Apple to update their docs on such things.

    Apple certifies use of their drives, though people have managed to use some but not all retail, and if you look at Sonnet who does test and certify drives (model, firmware etc) with their controllers / enclosures they also do not just support any drive when it comes to Seagate and others.

    Checked with Seagate?
  • Christian Riley Level 2 (250 points)
    Yes, they weren't in existence and that was why I was extremely surprised that anyone would have suggested that those documents would answer "most of your questions" when they were completely un-related and probably had not been updated!

    I haven't checked with Seagate because this is likely an Apple RAID Card issue - the drives work perfectly inside the Mac Pro to their full capacity. e.g. I can put four 3 TB drives (actually 5 if one were to go in the spare optical bay) in there and have the full usable space, just spread over multiple volumes. (I have not tried SoftRAID with it yet).

    They also work nicely up to 2.2 TB with the Apple RAID Card giving about 6TB of usable space with the RAID Card vs about 5.2TB with 2TB drives. This seems to indicate that it is a 512k block vs 4k block issue with the Apple RAID Card as has been plaguing pre-Windows 7 and impacts pre OS X 10.4.0 and pre-Intel hardware. Since there are no other 3 TB drives available yet I can't confirm it isn't a Seagate-with-Apple-RAID-Card issue, but the symptoms suggest that it is an issue with the Apple RAID Card and drives larger than 2TB since they work perfectly in the Mac Pro without the RAID Card. I also believe that the same issue is why you can not order SSD drives with the Apple RAID Card given that some (all?) SSDs support variable block sizes.

    I was merely wondering if anyone else had attempted to use them with the RAID Card with success in order to ensure that it was not some issue with the particular four 3 TB Seagate drives that I had tried.
  • ChromePlanet Level 1 (95 points)
    Yeah, Christian, very lame for someone to waste your time pointing you to generic out-of-date FAQ documents and implying the answer is there when he didn't even bother to check himself.

    Anyway, I just bought this drive. It only comes in an external case, so I assume you took it out of the case, as I did, to use in your Mac. I just sold my Mac Pro and replaced it with an iMac so I am trying to use it in a Wiebetech external drive bay enclosure via Firewire 800. The enclosure accepts 4 bare SATA drives and I don't RAID them, I just use hard drives like floppies to manage media content.

    OSX says the disc is unreadable and needs to be initialized. Fine by me, and expected, since it supposedly comes pre-formatted for NTFS. But when attempting to partition it with Disk Manager, the maximum partition size is 800 and some GB, not 3TB. Does some kind of special proprietary driver have to be loaded? Is this possibly a 32-bit only driver, since the box says this drive is not compatible with the 64-bit OSX Snow Leopard kernel? And where do I find this driver? If it was on the hard drive in NTFS format, it's gone now as I re-partitioned the drive.

    How do I access the entire 3TB in OSX 10.6? I have found no answers in the KB or other forum posts.

    If you could explain specifically what happened when you booted up with the drive in your Mac Pro and what you did I would appreciate it. Are you running 64-bit or 32-bit kernel mode in Snow Leopard?
  • ChromePlanet Level 1 (95 points)
    UPDATE: I connected the drive to a different hard drive dock via USB2 and I can now format to 2.2TB. I am beginning to suspect the limitation may be in these external drive bays and how they convert SATA to USB, eSATA, and Firewire 800.

    Unfortunately, I cannot put the drive inside my iMac as I need it as a swappable data drive and my iMac has one bootable SSD drive in it now anyway so it couldn't accommodate a 2nd drive if I wanted it to.

    So now the question becomes, what external hard drive dock product can I use to see the full 3TB?
  • Malcolm Rayfield Level 7 (28,075 points)
    Are you using GUID ("Options" button in Disk Utility's "Partition" tab)? Other partition map schemes cannot handle 3 TB. They use a 32-bit word for the number of 512 byte sectors. That limits them to a total size of 2.2 TB. The RAID card may also be using 32-bit words for sector numbering, thus limiting the card to drives smaller than 2.2 TB.
  • ChromePlanet Level 1 (95 points)
    I am using GUID.

    Just to verify, I put the drive back in its external enclosure and connected via USB2. I could format the entire 3TB. So their proprietary enclosure is doing some kind of special translating that my other enclosures aren't doing.
  • Malcolm Rayfield Level 7 (28,075 points)
    If the Wiebetech enclosure supports multiple drives with one computer interface, it has to do some processing of the commands from the computer. If the sector numbers are being processed as 32-bit words, that would make it unable to handle the full capacity of 3 TB drives. A single drive FireWire enclosure is more likely to work because SATA and FireWire command formats are similar, so the enclosure may just pass the command bytes directly to the drive without any interpreting, so would not have word size limits. USB protocols are more complicated, so enclosures that include USB may not be able to handle 3 TB drives.
  • The hatter Level 9 (60,930 points)
    Any case that isn't 100% native SATA has to have a bridge.
    The most common are Oxford, and current is 936-series.
    Safest place to find Mac compatible Oxford enclosures and large capacity

    They even have multi-drive cases.
  • ChromePlanet Level 1 (95 points)
    The Wiebetech enclosure has separate interfaces for each drive bay, but each interface offers a choice of USB, Firewire 800, or eSATA. It does use the Oxford chip for bridge-processing this translation, not sure of the version.
  • ChromePlanet Level 1 (95 points)
    Just got this email from Wiebetech technical support:

    +I'm sorry to hear about the new Seagate 3TB drive not working with your RTX400-QJ. I am guessing that this is the 3TB drive that ships inside the Seagate FreeAgent GoFlex enclosure? Unfortunately, there is a reason that they are only selling these 3TB drives inside their own enclosure and that is because it has been designed to use 4k block sizes to allow the increased capacity. None of our products are going to be compatible with this hard drive at this time and are not going to be able to offer the full use of them. It remains to be seen which route the hard drive companies are going to take when they eventually begin releasing bare 3TB drives, as compatibility with our products is going to depend on how they go about making the drives and the chipset that is located in each of our products.+
Previous 1 2 3 4 Next