Previous 1 2 3 4 Next 56 Replies Latest reply: May 22, 2013 9:42 PM by Peter Thomsen Go to original post
  • Grant Bennet-Alder Level 9 Level 9 (54,155 points)

    3TB drives, even those that are "green" or those that use 4K blocks DO format correctly under Mac OS X 10.4.6 and later.


    "A drive that does not reasonably accurately report both its make&model and its size/capacity has died."


    If that drive was sold as 3TB and is reporting 8000 MB when placed INSIDE the Mac Pro (not in an enclosure), it is not functional, and should be returned to the seller. Attempts to format it are a waste of time. It is dead.

  • The hatter Level 9 Level 9 (60,905 points)

    800GB capacity sounds vaguely familiar. That is what happened when connected to a Mac Pro with Apple RAID card for one. Or with external case and the bridge doesn't support that capacity.

  • danceswithxserves Level 1 Level 1 (0 points)

    not sure if you bought yet (seeing as your post was from April I would assume you have...) but I just got my Hitachi ultrastar 3tb drives in and they are working well in my 2009 xserve (albeit at 2.2 Tb)

  • jscajil Level 1 Level 1 (0 points)

    I have purchased two of these WD Green drives and they both show up as 802.57MB no matter what I try.  


    Ive read that these drives must be added internally and cannot be within an enclosure.   So I tried this within my PC and they were recognized and formatted properly, but once placed back into the MAC enclosure 802.57MB.  I have WD 1.5 drives that work perfectly in this same enclosure, but these 3TBs are giving me fits.


    Seeing how these drives are eSATA, is it possible to get them connected as an internal drive?

  • Grant Bennet-Alder Level 9 Level 9 (54,155 points)



    Showing up as that smaller sizes is a defct in the chips in your external enclosure, not in your Mac Pro.


    If yopu have a 2008 or older, the ODD ports (dtat-only connectors on the motherboard to support possible switch to SATA Optical Drives) can be used to provide additional "internal" drive connection.


    If you have a 2009, the Optical Drives bays are SATA cabled.

  • pgf Level 1 Level 1 (0 points)

    Has anyone tried to use the same identical hardware with a different OS?

    For example, using a live Linux distribution?

    I have a problem with a 3TB external HD on my MacBook Pro (which recognize the HD as a 2.2 TB),

    but with a live Linux distro the problem disappear:

    Re: Using a 3TB external drive?


    This make me suspect of a problem in Mac OS software/drivers/firmaware.

  • The hatter Level 9 Level 9 (60,905 points)

    The problems discussed here with Mac (workstation) Pro were with the Apple hardware RAID controller and its firmware.


    There could of course be an issue with some external drive cases.


    Some vendors sell RAID5 boxes, with 4-drives. Those get their RAID also from a controller bridge built into the case.


    You never know and can't test until there actually are 3TB drives and everything up until then was just on paper but not against actual product or prototypes.


    XP has trouble and that is why Paragon has a utility driver patch to add support.


    GPT supports larger drives and booting from large volumes.


    OS 9 could not boot from a volume larger than 195GB, but then there weren't any 200GB + drives until OS 9 was on its way out the door.

  • Stephen Epstein Level 1 Level 1 (10 points)

    Thanks to you and The hatter.


    For the less technically inclined ... I have an old MacPro (1,1) running Lion, and I wanted to add a 3TB drive, swapping out one of my older, smaller drives. I first attached the 3TB drive via USB through a Newertech Universal Drive Adapter. Disk Utility reported the drive to have 801.57GB capacity. Sound familiar?


    That's when I found this thread. The problem would seem to be my external drive adapter, not the MacPro. I inserted the new 3TB drive into the MacPro, and voila! - recognized as 3TB (the 2TB drive I removed to make room is currently hooked up to the drive adapter while I copy data off the old drives).


    Thanks for the help!

  • bill billybob Level 4 Level 4 (1,035 points)

    I have a Mac Pro 1st Generation as well. The ONLY way that I have been able to format this WD 3TB drive to get access to the 3 TB is by either having an external enclosure that uses eSata or by installing the drive internally. Note: if you use an external enclosure with an eSata connection, you will have to plug in the drive, start it up, attach the esata cable and then reboot your mac, otherwise the esata external connection will not be recognized. Once you restart (it takes a lot longer to restart BTW) the eSata external drive will show up as a regular hard drive and not as an external on your desktop. I got my esata connection by ordering the cables from OWC and then installing them to the free eSata port inside my mac. I am using 10.6.6 to do this

  • bruceknee Level 1 Level 1 (0 points)

    Hi Christian, did you ever solve the issue, I wish I'd search this thead before I bought 4x 3Ts. I am getting 2.2T also. I am using an Apple Raid card and will format raid 5. I am wondering if a new firmware might have solved it since 2010 when you guys started this thread. Tks.

  • Ricks Level 6 Level 6 (11,515 points)

    bruceknee wrote:


    Hi Christian, did you ever solve the issue, I wish I'd search this thead before I bought 4x 3Ts. I am getting 2.2T also. I am using an Apple Raid card and will format raid 5. I am wondering if a new firmware might have solved it since 2010 when you guys started this thread. Tks.




    Haven't run an Apple RAID in a long long time - but have a question for you. Does the Apple RAID Uitlity setup configuration allow setting either 64bitLBA or 4K block? If so this should get you past the 2.2TB limits you are seeing.

  • Peter Thomsen Level 1 Level 1 (15 points)

    Also had trouble with 3TB drives. Turns out the issue was with my Newer Technology Voyager S2 external dock and older sata enclosure. Both worked flawlessly with 2TB drives, but I could not format my new 3TB drive with either. After hours of research I found the older dock maxes out at 2TB. I borrowed a newer Voyager Q dock, which supports up to 4TB. Boom! Problem solved. I was able to partion my 3TB Seagate Barracuda and my Carbon Copy Cloner backup scripts are running as I type.

Previous 1 2 3 4 Next