Previous 1 2 Next 25 Replies Latest reply: Sep 27, 2010 2:20 PM by Tom Gewecke
Neil Myners Level 1 Level 1 (0 points)
I have recently changed iMacs to a new 27". Have installed iWork and set Pages preference to British English in the Inspector.

That's been fine for two weeks. But I've just downloaded an update for Pages and it no longer recognises British English. I've tried creating new templates set to British English; going into the inspector for individual documents and deselecting then reselecting British English; I've gone to system preferences and reselected British English in 'Language and Text' - but none of these have corrected the problem. I've checked old docs created on my prior Mac in templates set to "British English" and these are now highlighting words such as 'programme' and 'colour' as being wrongly spelt.

Is there anything else I should try before I opt to reinstall iWork from scratch?

27" iMac i3,Intel MacBook, G5 iMac, iPhone 4, Mac OS X (10.6.4)
  • PeterBreis0807 Level 7 Level 7 (33,560 points)
    neil

    British English is dragged to the top of your Language List?

    Don't you love the cheek of the Americans to declare their dialect "English".

    Which part of the word don't they understand? Other than all of it that is.

    Peter
  • Tom Gewecke Level 9 Level 9 (75,475 points)
    You might want to try installing another british english dictionary, like the OED one found on this site:

    http://wiki.services.openoffice.org/wiki/Dictionaries
  • fruhulda Level 6 Level 6 (15,120 points)
    Tom, why should the OP do that? The MacOs system comes with British English and Pages can use British English. Isn't it better that the system is correctly installed with British English rather than English?

    If the OP does as Peter implies, make sure that in System preferences > Language and text > Language make sure that British English is at the top in the window and then restart the computer it will work. There is no need for having English in this window if the OP doesn't want to use applications or keyboard that don't support English (that is American english)
  • Tom Gewecke Level 9 Level 9 (75,475 points)
    Tom, why should the OP do that?


    Because sometimes the other possible fixes don't seem to work.

    There is no need for having English in this window if the OP doesn't want to use applications or keyboard that don't support English (that is American english)


    I think it is best to keep English in that Window. Some apps may not recognize British English as a localization at all and will revert to some other language if English is not present.

    I don't the languages window has any connection with what keyboards can be used.
  • fruhulda Level 6 Level 6 (15,120 points)
    Tom Gewecke wrote:
    Tom, why should the OP do that?


    Because sometimes the other possible fixes don't seem to work.

    I don't think the OP has tried the correct fix yet. British people thinks English is their language and might not understand that it is referring to US English. The OPs system has to be corrected first.

    There is no need for having English in this window if the OP doesn't want to use applications or keyboard that don't support English (that is American english)


    I think it is best to keep English in that Window. Some apps may not recognize British English as a localization at all and will revert to some other language if English is not present.

    I don't the languages window has any connection with what keyboards can be used.

    Good point!
  • Neil Myners Level 1 Level 1 (0 points)
    I'm afraid none of these work.

    In System Preferences I have British English at the top of my language list, have removed the one just labelled 'English' from the list completely. Also in System Preferences I have Text Spelling set to British English, none of the other 'English' boxes are ticked. The Input Sources only has 'British' ticked and the 'Use the same one in all documents' button is pressed In Dictionary I have the British English (IPA) box ticked for pronunciation

    Have logged out with all of the above done and it still won't let me use British English.

    Have now put 'English' back in my language list but underneath British English - logged out but it still won't recognise British English.

    Would be grateful if anyone has any other suggestions - if not I'm going to re-install Pages and hope that works.

    thanks
  • Neil Myners Level 1 Level 1 (0 points)
    .... and one further thing - the British English box is selected in the Inspector in Pages under the 'More' section of 'Text'.
  • Tom Gewecke Level 9 Level 9 (75,475 points)
    Would be grateful if anyone has any other suggestions - if not I'm going to re-install Pages and hope that works.


    I gave you a suggestion about installing another dictionary -- have you tried that? Does British English work for you in TextEdit? If not, re-installing Pages is unlikely to help.
  • Level 8 Level 8 (41,790 points)
    How is it behaving if you run Pages from an other user account ?

    If it behaves correctly, reinstalling iWork would be wasted time.

    Did you apply the good old medicine : trash the Pages preferences file ?

    <startupVolume>:Users:<yourAccount>:Library:Preferences:com.apple.iWork.Pages.pl ist

    Yvan KOENIG (VALLAURIS, France) jeudi 16 septembre 2010 00:21:49
  • PeterBreis0807 Level 7 Level 7 (33,560 points)
    Neil

    It should just work. There is obviously something wrong.

    I have Australian English, which is just British (the Australian is hokum), selected and it is by default spelling check correctly.

    Do a *Complete Reinstall:*

    http://www.freeforum101.com/iworktipsntrick/viewtopic.php?t=105&mforum=iworktips ntrick

    and make sure you have all relevant iWork and (Combo) System updates.

    Peter
  • fruhulda Level 6 Level 6 (15,120 points)
    When you say " it still doesn't recognise British English" what do you mean by that? BE is selected but there is no spell checking or what?
  • Neil Myners Level 1 Level 1 (0 points)
    Correct Fruhulda, British English is selected in every possible place I can see, but when I type words with their original British English spelling - "Colour" for example - the words are underlined in red and the suggested correct spelling is the American "Color"
  • fruhulda Level 6 Level 6 (15,120 points)
    Neil, then I don't think the problem is in Pages but in the System as the dictionaries a comes with the system and not with iWork.
    Do as Yvan suggest. Create a new user account and log in to it. try PAges and spelling and see if it behaves in the new account. If it does something is wrong in your original account. If it doesn't it is a system problem.
  • Neil Myners Level 1 Level 1 (0 points)
    Unfortunately it looks as though it is a system problem. I created a Test Account and tried Pages, Text Edit and also Stickies. On all three I was getting American English despite the System Preferences set to British English and the 'more' section of 'text' in the Inspector of Pages being set to British English. Have also now tried Australian English (thanks for the tip Peter) in both System Preferences and Pages Inspector, but that isn't working either.

    I've used Macs for 15 years so know my way around them to a reasonable degree, but am not what I would call exceptionally computer literate. If anyone has any further advice (that preferably doesn't involve anything too technical or third party), I'd be grateful. Failing that I'll contact Apple or live with it.

    Thanks for everyone's advice so far.
Previous 1 2 Next