3 Replies Latest reply: Oct 25, 2010 9:15 AM by McD.ee
cricketernot Level 1 Level 1 (135 points)
Please where exactly are printer drivers located and what do the files look like? I know where my driver download file is, it's in "Downloads" and looks like this : 20040714091350156_SPL2.dmg Is that it or is there some thing important hiding somewhere? My printer is a Samsung ML-1610 (officially NOT compatible with Mac) but that driver is for ML-1710 and it works. Some smart guys somewhere had worked that out. I gather it's a good idea to AVOID Samsumg if you've got a Mac. Thanks for any info.

20" Intel iMac mid-2007, 3GB RAM, Mac OS X (10.6.4)
  • Kappy Level 10 Level 10 (260,235 points)
    They usually are in the /Library/Printers/ folder. Installed drivers may also be found in the /Home/Library/Printers/ folder. The driver folder should have a "normal" name involving "Samsung" in the name.

    Exactly why do you need to know the location? The driver installer should place it wherever it belongs.
  • cricketernot Level 1 Level 1 (135 points)
    Thanks. I see Home/Library/Printers/Samsung ML-1610.app (610 KB) I suppose that's my printer driver. In the main upper level Library folder I see what look like the drivers included in OS X (does not include mine). Why do I want to know? Oh in case I want to kill it/change it, I'm not using an official driver because there isn't one. I wish Samsung would give some tips suggesting trying other drivers, bet a lot of people have bought a new printer unnecessarily.
  • McD.ee Level 1 Level 1 (0 points)
    I've got a similar problem with an ML-1710P: I need to re-install a driver and have found Samsung to be somewhat less than enthusiastic about supporting Apple machines.

    There is a driver download facility online (http://www.samsung.com/sg/support/detail/supportPrdDetail.do?menu=SP01&prdia_cd=06010400&prd_mdl_cd=&prd_mdlname=ML-1710) and it does download a DMG file which works, but it doesn't work! It assures me it's successfully completed installation of in a folder named 'usr' somewhere on 'OSX', but the printer still doesn't show up in 'Print and Fax' under 'System Preferences', nor can I find any folder named 'usr'.

    Like you, I'd quite happily use a different driver, as long as it works. Perhaps it might be the most simple solution if you could let me know how to get that ML-1710 driver you're using?