Previous 1 2 3 4 Next 56 Replies Latest reply: Jan 13, 2016 10:43 AM by jrosene Go to original post
  • iBuyiPhones Level 1 (0 points)

    This seems to be working so far. But when I deleted and added my account as "other", my custom mailboxes did not show up. So I went ahead and added as yahoo and things seem just fine. Maybe it's an iOS5 thing where the account needed to be restarted after the upgrade. Who knows.

  • callumfromlivingston Level 1 (0 points)

    well its definetly worked on mine i had to trun on the outgoing mail slider in the acount but that was all i use hotmail btw incase that also helps

  • iBuyiPhones Level 1 (0 points)

    Well....it happened again. I'm lost again.

  • abelsuk Level 1 (0 points)

    That is alarming iBuyiPhones, might have to get a genius appointment.

     

    I've been using my mail now without the native mail app on the iPhone (access using safari browser) for almost a month moving mails at random and keeping notes of what's moved when and where - yes I know a tedious - without losing emails...

     

    Building a case for Apple to show its not the email providers!!

  • stephanierenay Level 1 (0 points)

    This worked for me:

    Go to Settings

    Go to Mail, Contacts, Calendars

    Click on your account.

    Look down for Mail Days to Sync--set as "No Limit"

    ALL of my emails instantly came back onto my 4S after I did this. Hopefully it works for others, too.

  • Will in Yorkshire Level 1 (0 points)

    My e-mail is doing the same thing - from my Iphone, from Mail on my Macbook & Mini.

     

    E-mail appears in the Inbox then disappears in seconds.

     

    My e-mail is hosted on Lion Server - it is affecting only my mailbox on the server - everyone else's are working fine.

     

    As the IT Manager - it's frustrating that I can't fix my own e-mail while all around me are working fine!

     

    I've tried removing & re-creating the account on both Mail and iPhone to no avail.

     

    I have tried the solutions suggested above but can't find the settings that the others 2 people have used - I'm using IoS 5 on my iPhone 4 and Lion client on my Macbook.

     

    I've had this e-mail address for 10 years so can't start from scratch - HELP!

  • Will in Yorkshire Level 1 (0 points)

    This even happens when I use Webmail on the Lion Server too.....

  • bigrand123 Level 1 (0 points)

    Excellent this worked for me all my emails are now back

  • iBuyiPhones Level 1 (0 points)

    Imstill having the problem. And that "mail days to sync" menu doesn't seem to be available on iPhone 4. I see you have 4S.

  • bigrand123 Level 1 (0 points)

    Yes I got the 4s and this worked fine and also on the ipad2

  • jonogib Level 1 (0 points)

    I'm having a similar problem, although after reading these posts it may be a bit different.

     

    When I read my att.net mail from my iPhone 4 Mail application, it deletes them from my server so I can't read them on my laptop (PC) when I get home. My "Deleted Messages--Remove" button is set to never.

     

    I was told by someone that I need to change from POP to IMAP.  I'm not sure what this is or how to do it, or where to do it, on my iPhone? On my laptop?

     

    Any advice is appreciated as Apple, ATT, and Microsoft are blaming each other.

  • Cornilios Level 1 (0 points)

    Ok Guys,

     

    I was having the same issue where my emails were getting deleted off the server and off my IPhone and it just happened that i went in to my outlook settings on my computer and in the settings i found the issue and i tested it and it worked. The problem is on the computer and not the IPhone itself.  I hope it works for everyone as i know how much frustrating it was after losing the emails off the servers. so to resolve the issue:

     

    On your computer open outlook - go in to your Account Settings ---> E-mail ---> select your email in the box ---> click Change ---> on the bottom you will see More Setting... click on it ---> go to Advanced tab ---> on the bottom you will see Delivery ---> Click the box that says "Leave a copy of message on the server" and the rest of the boxes leave it blank ---> click OK and then Cancel. Send yourself a test email or send email to your email address and open the email in your IPhone, after recieving the email close the mail in IPhone and open up you outlook on your computer, after recieving the email close outlook and open the email on your IPhone and it should not delete the emails anymore. ENJOY hope it works for all, give me your feedback.  Cheers

  • harlim Level 1 (0 points)

    Did you try to check if the "mail days to sync" option appears on your email account that was under 'Exchange' type of mailbox instead of any others? Because even in iPhone 4S, that option only appears to my Exchange accounts but not the others. Luckily enough my gmail was set up on Exchange (I can't remember why) and I could see that option, which means you can set up any email accounts as an Exchange account instead of their respective types (ie. Yahoo!, Gmail, etc.)

  • sissypoo Level 1 (0 points)

    I just tried what Cornilios recommended and it worked like a charm so far!

    Thanks a bunch!

  • MouseChing Level 1 (0 points)

    Go to setting > mail,contacts,calendar > choose your account eg.Hotmail > mail days to sync > no limit