Previous 1 2 3 Next 38 Replies Latest reply: May 18, 2013 3:47 PM by Imgran Go to original post
  • RideMikersRide Level 1 Level 1 (0 points)
    I've just started having the same issue. I finally figured out that it is due to pressure on the MacBook case in the center-front and left sides of the trackpad. If I rest my hand heavily on that side while typing it messes with the trackpad's various swipes and gestures, selects random things, switches pages or scrolls, etc. Or if my angle is from below e.g. a table that is higher than my wrists.

    I am able to recreate/confirm this by pushing lightly on the case at those points and getting the same undesirable cursor behavior. There's just enough flex in the case. Never had this problem before on previous laptops.

    Any ideas other than finding the perfect position every time I am using the machine? Heading into a Genius Bar ASAP.
  • markandsusanw Level 1 Level 1 (0 points)
    I'm having this problem too and I also think it's due to pressure on the case around the trackpad. Pressure it's almost impossible not to apply when typing on my laptop.

    My cursor is jumping, text is selecting, deleting, etc., all without hitting anything. It's very annoying, to say the least.

    This just started with the most recent software update on a MacBook Pro 17" I've been using for 2-1/2 years now without issue. I have no external mice, keyboards or monitors hooked up to this machine.
  • markandsusanw Level 1 Level 1 (0 points)
    I tried all the suggested resets (see Bob Kujda's post on page 1) to no avail.
  • JMDG68 Level 1 Level 1 (0 points)
    My MacBookPro5,4 have this problem too. I try changes but problem persist. Solution please.
  • RideMikersRide Level 1 Level 1 (0 points)
    I showed the issue to an Apple-certified Tech. His first thought is to replace the top case of the laptop. My MacBook Pro 17" is the last model prior to the uni-bodies. I gave him the serial number and he placed the order.

    The issue seems to be evolving as now there is a slight bulge to the right of the trackpad where the top case meets the plastic edging. This is sensitive to pressure and is causing cursor jump and random selection, etc. as well. Very annoying and even detrimental. My hand position has to be contorted and elevated in order to avoid these issues at this time.

    I'm also having a battery issue that developed at the same time as the case flex. I'm not saying it's related at this point but it is suspicious. The battery monitor is inaccurate and can change readings--I've seen it jump from 22% to 41%. And instead of putting the machine to sleep when the battery runs out, it just shuts down with no warning. It's frustrating because I have worked hard to keep it calibrated per Apple's recommendations.

    The Apple Tech will be looking at this issue as well.
  • RideMikersRide Level 1 Level 1 (0 points)
    An answer of sorts. The battery started bulging as it degraded. This bulge pushed on the keyboard and trackpad elements, pushing them into the top case and creating the sensitivity.

    For me, taking out my battery relieved the issue. A new battery is on the way. Check yours and take it out if similar issue exists until you can secure a replacement.

    Thank you First Tech Mpls! And good luck to the rest of you.
  • anorton Level 1 Level 1 (10 points)
    i have this problem too. my 15" macbook pro is less than six months old, and has nothing hooked into it except its wireless connection (and the power cord). i have tried all the fixes suggested here, but nothing helps.
  • anorton Level 1 Level 1 (10 points)
    may have fixed the issue. reinstalled osX from the disc, then updated it to 10.6.5 off the net.

    (side note: the video card driver wouldn't work without osX 10.6.5. if you are having trouble playing video after a reinstall, you might need to finish updating osX. i found a discussion thread that led me to check the video card maker's website, which stated the need for osX 10.6.5 in order for the video card driver to function.)

    it's been two days so far, and no jumping cursor. (as opposed to before, where it would start to jump and jive about five minutes after a reboot).

    fingers crossed, but it leads me to believe my problem was a corrupted software issue, not one of faulty hardware or wireless radio frequency interference.
  • anorton Level 1 Level 1 (10 points)
    spoke too soon. it's coming back.
  • anorton Level 1 Level 1 (10 points)
    absolutely not fixed. still think it's a software problem, as a restart resetting the pram (command/option + p + r) often seems to make it work correctly for at least 2 minutes. sometimes it works ok for hours, but it always comes back. i can't find a correlation to it's faulty performance and any other activities (turning off wifi doesn't make a difference, for example, and i can't tell if playing video aggrevates it). i am in an apartment, so it's possible that neighboring wifi might be interfering, but i can't seem to distinguish any pattern to when the problem occurs that might support this. as the problem began shortly after upgrading to 10.6.5, i was going to reinstall to an earlier version of osX and see if that cured it, but the video card would no longer work with 10.6.3, so i had to upgrade. my next try is to get a wired track ball and compare that to the macbook's integrated pad. not a great solution, as i don't use the macbook at a desk: i need the integrated pad to work correctly. without a working track pad, this mac is just an very expensive piece of junk.
  • anorton Level 1 Level 1 (10 points)
    knock on wood, it's gone away for a couple of weeks. now running 10.6.5, so maybe that's why. have the track ball in its box, just in case.
  • Peter Godsell Level 1 Level 1 (0 points)
    I too have had this frustrating problem. Noticed that it seemed worse when air was very dry and wondered if statice electricity had anything to do with it.I have earthed my laptop and so far so good, but too early to be conclusive.
    Seems a bit far fetched, but I am getting desperate!
  • Randall Olson1 Level 2 Level 2 (175 points)
    Thanks for this post. I was having similar issues with my MacBook Pro selecting text on it's own, the cursor jumping around, even when I typed text....I would type a few words, then they would disappear or the cursor would jump around within the sentence. It turned out that my battery was bulging badly and pushing up on the trackpad to the point where I couldn't even push down on the trackpad anymore because it was being pushed upward by the battery. The microswitch under the trackpad was activated almost all the time. A new battery at the genius bar solved the problem immediately.
  • chipperz Level 2 Level 2 (205 points)
    I have a 2 month old MB, 2.8GHz i7 that has the same type problem. I got a tip from someone else on this board and they suggested I turn off all the swipes and stuff available with the trackpad. I did that and everything is now fine and has been for over a month. I plan to take the computer back to Apple store and have them run some tests on it. Give it a try and see if it helps you. Just go into System Preferences, click on trackpad and make the adjustments.
  • callipygian Level 1 Level 1 (0 points)
    I had a client with the same issue this week. After much research online, these are the troubleshooting steps we tried until we found a solution:

    Symptoms:
    2010 MacBook Pro running OS 10.6, cursor is moving around, even when not touching the computer at all.

    Troubleshooting steps:
    - Unplug all USB devices (ensures it's not a problem with your mouse or interference from another device)
    - Turn off Bluetooth (ensures there aren't any wireless mice messing with stuff)
    - Try turning off your AirPort (seems unrelated but some people report this helped)
    - Try unplugging your AC Adapter (could be caused by unclean power or a faulty adapter)
    - Try removing the battery (not an option with the 2010 MBP, the battery is not removeable)
    - Under System Preferences, Trackpad, make sure "ignore accidental trackpad input" is checked
    - Under System Preferences, Universal Access, Mouse & Trackpad, turn on "Ignore built in trackpad when mouse is present", plug in a mouse. (if the problem goes away, this proves the trackpad is at fault)
    - Try booting from the system restore CD that came with your computer (if the problem still exists, this proves it's not a software issue)
    - Clean the trackpad with a lint free cloth, small circles, light pressure
    - Clean the trackpad with a lint free cloth and rubbing alcohol

    That last step finally fixed it for us.

    Good luck!!