4 Replies Latest reply: Dec 5, 2010 4:54 AM by HenryS
HenryS Level 2 Level 2 (295 points)
Hi All,

Just bought the Magic Trackpad. Attempting to use with MacPro desktop (1,1) and USB/Bluetooth device (Broadcom as shown below). No joy on first try or ever. Desktop did not discover my Pad after I installed the Magic Trackpad 1.0 Software Update (which does add the Trackpad to the System Prefs).

This isn't described in the instructions with the Magic Trackpad. There is a KB which indicated to download this software and install it, restart. So I did. Still no joy. This device can supposedly discover other devices or be discoverable. It doesn't discover the Trackpad and gives some misleading indications.

The window in the Trackpad Pref says "Discovering..." However, nothing happens from there after turning on the Pad, following the instructions with Magic Trackpad. There is no Setup Bluetooth Trackpad in lower right as described on the page.

The Bluetooth System Pref also shows Searching and never does the Trackpad appear. Although the Bluetooth appears to be "On" according to the check box, there is also a comment that the Bluetooth hardware is off, but the checkbox is on when the bluetooth device is plugged in and grayed out. This is very confusing and can't be sure that the Bluetooth device is properly functional. I do know that the system recognizes the device because the Bluetooth adapter device appears as follows when it is inserted into a USB port and starts up.

After all the testing on the MacPro (unsuccessful), tried on my MacBook Pro and it works OK. This proves the Trackpad is working OK and its Bluetooth is OK. The problem is apparently with the Bluetooth on the MacPro. What can I do about getting it to run?

+System Profiler Report on the USB/Bluetooth adapter:+
+Apple Bluetooth Software Version: 2.3.7f1+
+Hardware Settings:+
+Address: 00-02-72-ac-cd-a9+
+Manufacturer: Broadcom+
+Name: BroadcomBluetoothDevice+
+Firmware Version: 14 (21298)+
+Bluetooth Power: On+
+Discoverable: No+
+Vendor ID: 0+
+Product ID: 0x1+
+HCI Version: 4 (0x4)+
+HCI Revision: 21298 (0x5332)+
+LMP Version: 4 (0x4)+
+LMP Subversion: 16910 (0x420e)+
+Device Type (Major): Miscellaneous+
+Device Type (Complete): Miscellaneous+
+Composite Class Of Device: 0 (0)+
+Device Class (Major): 0 (0)+
+Device Class (Minor): 0 (0)+
+Service Class: 0 (0)+
+Requires Authentication: No+


Henry

MacPro1,1 2.66GHz.,MBP 15" 6,1 i5 2.53GHz, MB2008 2.0GHz, Mac Mini (10.5.8), Mac OS X (10.6.4), iPhone 3GS OS4, AEBS 802.11n v7.4.2
  • HenryS Level 2 Level 2 (295 points)
    The Bluetooth Dongle I am using on my MacPro is the IOGear Bluetooth Dongle GB421, which seems fine as per the the Profiler report but sees no devices on the MacPro.
  • HenryS Level 2 Level 2 (295 points)
    Found out that many 3rd party USB dongles won't work with Snow Leopard (maybe due to drivers?) and it's basically a finger pointing exercise to proceed further. Apple really should support those, but apparently hasn't as yet.
  • jdaw1 Level 1 Level 1 (0 points)
    Same problem here. 2006 iMac, no bluetooth, so I bought a €2 dongle, which worked intermittently. No better joy with a second dongle: now I know why. Trackpad useless.

    Thank you for posting the reason.
  • HenryS Level 2 Level 2 (295 points)
    jdaw1 wrote:
    Thank you for posting the reason.



    Jdaw,

    FYI, I mentioned earlier in the post....Using (successfully) an internal hardware Bluetooth card that attached to my motherboard from Apple on the MacPro. It was easy to install. That works very well and supports both the Magic Trackpad and other wireless devices. Luckily I was able to return the dongles for credit through Amazon. The submodule was about $45 and installing it took 15 minutes. Let me know privately if you need the name and/or Ebay location where these are sold.