5 Replies Latest reply: Oct 2, 2010 9:36 AM by phpguru
phpguru Level 1 Level 1 (5 points)
I have 3 Seagate 1.5TB external USB drives. Two of which I am using with a MacbookPro 17" first gen. Latest snow leopard. The third one I am tethering to a Dell XPS server. The one attached to the Dell works fine.

On the MBP17 Every now and again (randomly) the disk disappears from finder and I get this dialog:
--------------------------
|
| The disk was not ejected properly. If
| possible, always eject a disk before
| unplugging it or turning it off.
|
| To eject a disk, select it in the finder and choose File
| > Eject. The next time you connect the disk, Mac OS
| X will attempt to repair any damage to the
| information on the disk.
|
| ( OK )
------------------------------------------

I've replaced one of the drives through Seagate RMA and the same thing happens with the returned/refurbished drive. So, I really don't think there's anything wrong with the drives.

I've tried at least 3 different USB cables of different lengths from different vendors. One is only 1.5feet & gold plated. Still, random ejects. Using the disk attached to an old dual G5 I have... I don't have this problem.

Anyway, I am thus quite leery of using it for anything other than backups. I've never had the problem while actually copying files, only when I'm doing something else (like typing an email, or browsing the net).

I recall having read some older Macbook Pro 17" owners having similar issues with >= 1TB drives on these forums [http://discussions.apple.com/thread.jspa?threadID=2151621&start=120&tstart=0] but no solutions.

If someone can point me to a solution I would be very grateful.

Message was edited by: phpguru

Macbook Pro, Mac OS X (10.6.4)
  • cornelius Level 6 Level 6 (17,825 points)
    phpguru:

    In my experience this is usually a mechanical/physical issue. It may be the an ill-fitting cable terminal, a USB port either on the computer or the HDD, or a problem with the USB bridge on the drive itself. If successive drives and cables don't eliminate the issue, it may be with the computer itself.

    cornelius
  • Allan Jones Level 7 Level 7 (32,230 points)
    Are these drives bus-powered (no separate power brick; sometimes called "portable" class drives) or self-powered (have a power brick)?

    If they are bus-powered, they could be asking for more power than the MBP's USB ports can provide. If that's the case. consider buying a self-powered USB hub (again, has a brick) and installing it between the computer and the externals.

    Yesterday I found that OWC has a hub on sale that works in both portable bus-powered mode and in self-powered mode. Best of both worlds:

    http://eshop.macsales.com/item/Belkin/F5U403P/
  • gizmolab Level 1 Level 1 (0 points)
    i may have a solution for this. my working theory is that the drive is going to sleep on its own, and snow leopard interprets this as an improper drive ejection. after hunting around for several hours, i finally found and downloaded the Seagate Diagnostics application for the Free Agent drive family. After running the diagnostic test, the problem went away. i read that (despite the uninformative name) this application installs a driver that manages sleep in a way which is compatible with snow leopard.
  • phpguru Level 1 Level 1 (5 points)
    The drives are plugged into their own power source.
  • phpguru Level 1 Level 1 (5 points)
    @Gizmolab - Thanks for that reply. It seems like a decent theory. I found Seagate Diagnostics for Mac. It says it's only for drives that have a FireWire800 port. The ones I am using have USB only. I installed it anyway. When I run diagnostics it says no drives found so I cannot diagnose them. I'll see how it goes though, maybe it updated the driver.

    To add some more info to this thread... I figured I'd try Disk Utility to manage the drives manually. I've tried dismounting them and also just dragging the volumes to the trash when they are not in use, and using Disk Utility to mount them again when they are needed.

    What I've found is that in addition to the drives automagically ejecting themselves (and remounting again automatically about 20 to 30 seconds later)... is that a dismounted drive will automagically mount, too. Okay fine, I'll dismount them and unplug the USB cables, and reattach them when I need them.

    Disk Utility reports that there appears to be no problems with the disk... thankfully. While typing this reply, I heard the disk go to sleep and about 3 minutes later it just ejected itself dang it. So Seagate Diagnostics appears to be only for Firewire800 drives.