Previous 1 2 3 Next 71 Replies Latest reply: Jan 23, 2016 2:36 PM by foxberg
krusdublin Level 1 (0 points)
Hello Forum, New user to this forum, I have a problem, I have bought Mac Mini ( August,2010) for home use and recently bought LG -32LD450 - 32". I have connected my TV directly to Mac Mini using a 1.3X HDMI cable. I have video/ display - however no sound. All i can hear is sound from the Mac Mini's internal speaker. I tried to change the setting through - System preference/sound/output. It displays - LG / HDMI - however i cannot select, the setting is active with internal speakers only. Please advise how i can obtain audio from the TV.

I forgot to mention the message seen in System Preference/Sound/Output - LG TV HDMI - Settings for the Selected Device : The Selected Device has no output controls.

In addition to the above, i have tried to check the output controls through Utilities/Audio Midi Setup. Here too i am not in a position to alter HDMI Settings.

Help in this regards is highly appreciated...thanks

Please help

Mac Mini ( August,2010), Mac Book Pro, Mac OS X (10.6.4), Iphone 3GS, Mac OS 4.1
  • MAJM Level 1 (0 points)
    Krusdublin: I am experiencing similar issues with no real solution yet:

    I have a Mac Mini 2010 connected to a Sony Bravia HD TV via an HDMI cable
    sound output via TV speakers was not working when I first connected the two (about 4 mos ago)
    couldn't figure it out- and just used an headphone cable to connect the mac mini to a stereo
    somewhere between then and a month ago I disconnected all incl. power, and reconnected as I had to re-setup my tv (all reconnected in the same outlets via HDMI) (also got rid of the stereo at this point)
    then about a month ago I was back in the Sound preferences and found that I was able to get audio output via the TV speakers.
    about a week or so ago I disconnected all incl. power, and reconnected as I had to re-setup my tv (all reconnected in the same outlets via HDMI)
    however, about 3 days ago, sound output via TV was no longer an option
    when I say it is not an option, I have two lines under name and types as follows:
    "Internal Speakers" > "Built-In Output"
    "SONY TV" > "HDMI"
    when I switch from internal speakers to HDMI, I notice that the sound volume bar at the bottom of the screen goes faint, and I can't adjust the volume using the sound keys on my keyboard (bluetooth)
    the speaker icon in the top right of the screen is also greyed-out and not changeable...
    I notice that when I switch input on my TV aerial to the MacMini (HDMI 1) I get a little yellow triangle with exclamation mark in it, and the text: "AUDIO only" at the bottom right of the tv screen. (In not sure if I had this before or not - dont completely remember seeing it, but vaguely do...)
    I've also updated my macmini whenever an update is released (within a few days)...
    I've spoken with an Apple tech over the phone and went through a number of reboot (while holding down certain keys, etc.) to no avail. She then recommended that I go into the Apple store and have the mini checked out....
    At the apple store, the apple tech took the machine to the back, out of sight, and returned about 20 mins later to say that it was working fine. I asked to have it hooked up to one on display - so I could see for myself. We hooked it up to an HDTV via HDMI and booted up. Went to System Preferences > Sound and selected: "Panasonic TV" as the output device. I still could not adjust the volume bar (it went greyed out) - but I could crank up the tv volume directly and get sound. Great! Sort of... While now I could get sound - it was not the same as before where I could control the sound through the mac - only directly through the TV. The Apple guy said that he didn't know what I was talking about - and said that they way the machine was now working was the proper way. He unhooked my mac mini, and gave it to me, and walked away.
    Frustrated, I walked down to the Sony Store to try out the mac mini there. Same result as in the Apple store. I could control sound directly via the TV, but not through the mac mini controls.
    Took the mac mini home, reconnected everything and now get sound through the TV - but I cant control it with the mac mini on-screen controls, nor the volume buttons on the mac blue tooth keyboard.
    Today, I was watching a movie via itunes, hit pause, and went to do something for a few minutes. When I returned, the TV indicated 'no signal' via the HDMI (I assume because the mini went to sleep.) Tried to wake the mini - but couldn't. Had to resort to pressing the button at the back. When the mini came back, I had no sound at all coming through the TV speakers, even though the sound preferences settings were still the same. I had to resort to shutting down the mac mini, and then unplugging the power on the mini for a few minutes. Powering back up, sound was again able to comefromt eh mac through the TV speakers - but still could not control sound using the mac mini controls.......

    Thats where Im at so far....


    Thanks in advance,
  • Level 1 (0 points)
    I had the same problem - using a Yamaha RX-V661 to an LG 42LB5D. Same symptoms, but the Yamaha was able to tell me that the audio stream to the HDMI was analog. I think the problem is in the HDMI handshaking processs. I turned everything off, then turned each component on again, first the TV, then the Yamaha, then the Mac. Great sound! Now the units HDMI interfaces seem to handshake OK. It is all about content protectin - you would probably have no trouble if you could send the sudio separately via the optical interface.BTW the volume control in Safart won't work, but the one in iTunes works fine.
  • overwilhelmed Level 1 (0 points)
    I know I am new here but I just experienced the same problem with my new MacBook Pro running 10.6.4. It appears to be a handshake issue. In some random combination of turning one thing off and turning the other on, I managed to get audio to work. My video and display are a bit dated but I got it to work. My equipment is listed below.

    Display: Panasonic TH50PZ80U
    Audio: Onkyo HTR667

    Hope this helps others.
  • skiflier Level 1 (0 points)
    Had same issue. "Sound" saw my TV (Samsung LCD) and HDMI. I just ignored the message: "Selected Device has no output controls." Use the volume control on your television remote. Works fine.
  • TedBell Level 1 (0 points)
    Had the same problem. To fix it, I went to the sound utility in the "control panel." In there, I had to select my output as my home theater receiver and it worked perfectly. Need to do this under two separate tabs in the sound utility. Don't think it's a handshake issue after all. Maybe it is for other people. Hopefully it helps someone else.
  • BurnabyITManager Level 1 (0 points)
    Same problem.

    I just installed a $12000 display ($17k project) and fished HDMI to the control cabinet based on Apple's specs. (No kidding; email me for pics of the display and the invoice.)

    Apparently "HDMI port supports multichannel audio output" doesn't mean what I thought.

    Apple: the world's most vertically-integrated advertising agency.
  • Level 1 (0 points)
    A handshake failure could prevent the Mac from recognizing your A/V system and presenting it to you as an option for output.
  • klaag Level 1 (0 points)
    Solution for me was to open Audio Midi and just click around a bit and check speaker setup. I know I changed from 7.1 to 5.1 and I clicked the speaker and voila! I had sounds in all speakers.
  • thang324 Level 1 (0 points)
    My problem with Mac Mini HDMI is erratic.

    Initially when I configured my new Mac Mini to my home theater system via HDMI, everything works fine. Couple of days later, I can see picture but no sound except sound from the Mac Mini internal speakers. Regardless of whether I recheck System Preferences > Sound > my HTS AVR to select HDMI for both Sound Effects & Output, it is to no avail. I have other set top boxes connected to my HTS AVR via HDMI, they all works perfectly fine.

    Other things that I've tried including quitting Plex (Media Server) first then restart, change HDMI cable, & to the extent of restarting Mac Mini, the sound will still only come from the Mac Mini internal speakers. Almost at my wits end on the next course of action.

    Any prompt advice is much appreciated.

    Thanks in advance.

  • Level 1 (0 points)
    Try powering down everything and powering up in various orders. I think it is a handshaking problem of the HDMI. The Mac needs to see and recognize the audio device on the HDMI output.
  • travyo Level 1 (0 points)
    I'm having the same problem with my Onkyo TX-SR805. I've done all the latest software updates on the Mac Mini (2010). I think I've tried every setting in MIDI, have tried unplugging, restarting and even factory resetting my receiver and am not finding any success. I also get the message: "The selected device has no output controls". Plugged-in my Playstation and Wii, did the normal minimal receiver setup and everything worked perfectly with those consoles.

    Apple, can you please address this problem?
  • travyo Level 1 (0 points)
    I found the answer to my problem here:

    Basically, I had to go into and select: 8 channel 24-bit audio at 192kHz, then into speaker setup and choose 5.1 surround, although it also worked with the 7.1 settings. The problem I have now is that my receiver won't pick-up the Dolby handshake and stays stuck in either stereo or something called "multich" which both sound like crap compared to my Vista box that I bought this to replace. I love my other Apple products, but this is just wrong. They need to figure out how to make this product consumer friendly and a real solution to building an HTPC/IPTV.
  • alex.bayati Level 1 (0 points)

    Open Audio Midi
    Plug your HDMI cable into mini
    Right click on HDMI and click on "use this device for sound output"

    should work now...
  • Bart1975 Level 1 (0 points)
    Thank you very much. I recently started having this problem also. It seemed like every time I would watch p0rn on my big screen tv the HDMI sound would not work correctly. Thanks to Alex's solution I can now hear every moan and scream.

    Message was edited by: Bart1975
Previous 1 2 3 Next