4 Replies Latest reply: Oct 2, 2010 6:34 PM by 2wenty6
tala.halawi Level 1 Level 1
My iphone was working perfectly today and then suddenly it kept giving me call failed over and over again and has been doing the same ever since. I purchased the phone from Canada and am currently using it in Beirut so returning it to the apple store is not a viable option at this moment. Please guys help me fix this

Sony Vaio, Windows 7
  • flexina Level 1 Level 1
    I just got my iPhone 4 on Friday. It is now tuesday. Yesterday I was able to make calls and sms and also receive them. Today, nothing. Also, I am also having the "credit card declined" response that has been so popular with everyone else. If anyone has any insight I would also appreciate it.
  • flexina Level 1 Level 1
    dear Tala,
    upon restarting my iPhone and putting in the SIM PIN, once it came back on, it was fine. All the luck to you.
  • matthew.s.w Level 1 Level 1
    Someone just helped me in one of the other discussion board topics. If you turn off 3G, that should work. It did for me. BUT, I obviously still want 3G capabilities, so I'm not out of trouble yet.
  • 2wenty6 Level 1 Level 1
    I was having this problem, call ended and immediately followed by call failed right after I dial out. I found this one another forum, and it helped me. Hope it works for you too.

    Originally Posted by Tico-iPhone View Post
    If you see "Call Ended" and then "Call Failed" immediately after trying to dial out from your iPhone.....

    There probably is no problem with the phone. I had the same thing happen to me - iPhone 1.1.4

    Just remember these 2 steps:
    1) Settings > General > Date and Time > (Here, switch off "Set Automatically" and manually select your hometown). Then manually set the date and time.

    Apparently the SIM and carrier wont work if date and time aren't set well, make sure date and time are the current ones

    2) Settings > Phone > Show My Caller ID > Switch ON

    Usually people who virginize or upgrade or even first time unlockers - forget to change the default Location setting - which is Cupertino. If you dont change it, you will not be able to make outgoing calls. But the wierd part is, you will still be able to receive incoming calls.

    Hope that helps!

    All the best