11 Replies Latest reply: Sep 23, 2010 8:44 AM by oldsnwbrdr
sloong1 Level 1 Level 1 (0 points)
not sure what i did recently but start from two days ago i cannot access only google and yahoo and all related sites. the rest of the sites are fine.

I tried installing firefox and it is experiencing the same problem. However if I access using my ipad safari then everything is fine. using openDNS also does not fix the problem.

help please?

Mac Book Pro
  • Carolyn Samit Level 10 Level 10 (100,365 points)
    Hi,

    For Safari... from your Safari menu bar click Safari / Preferences then select the Security tab.

    Click: Show Cookies

    Delete all Yahoo and Google "only google and yahoo and all related sites" Cookies.

    And from your Safari menu bar click Safari / Empty Cache...

    Relaunch Safari. Try accessing those sites.

    if I access using my ipad safari then everything is fine


    That rules out your internet connection.

    If that didn't help, Quit Safari. Open the Keychain Access application (Applications / Utilities) Select Passwords on the left.

    Delete the Yahoo and Google keychains.

    Relaunch Safari. Navigate to either Yahoo or Google. Login with your user name and password. Click Yes when prompted.

    If you still have problems accessing those sites, delete the "Safari Forms Autofill" keychain. Relaunch Safari and try again.











    Carolyn
  • TeenTitan Level 4 Level 4 (2,410 points)
    what happens you try to go to google? do you get an error message, if so what dose the message say? or do you go to google and it takes you to another website?

    you could try using googles DNS server 8.8.8.8 and or 8.8.4.4
    you could try flushing the DNS cash. open terminal and use the command "sudo dscacheutil -flushcache
    "

    you could use network utility to trace path to server, and see where it's getting stuck.
  • sloong1 Level 1 Level 1 (0 points)
    Thanks both. Sorry tried everything suggested but still does not work.

    The warning on Safari said "Safari can’t open the page “http://www.google.com/” because Safari can’t connect to the server “www.google.com”."

    If I use traceroute it said:


    traceroute: Warning: www.google.com has multiple addresses; using 74.125.53.106
    traceroute to www.l.google.com (74.125.53.106), 64 hops max, 40 byte packets
    traceroute: sendto: No route to host
    1 traceroute: wrote www.l.google.com 40 chars, ret=-1
    *traceroute: sendto: No route to host
    traceroute: wrote www.l.google.com 40 chars, ret=-1
    *traceroute: sendto: No route to host
    traceroute: wrote www.l.google.com 40 chars, ret=-1
    *
    traceroute: sendto: No route to host
    2 traceroute: wrote www.l.google.com 40 chars, ret=-1
    "
  • giant_28 Level 1 Level 1 (0 points)
    I'd like to bump this thread because this is happening to me with google, as well as youtube. I've tried changing DNS, disabling prefetching, flushing DNS, downgrading to Safari 4.0.5 but no luck. Still get the "Safari can't connect to the server", which has been happening since last wednesday.

    When I traceroute I get the same as the OP above:

    traceroute: Warning: www.google.com has multiple addresses; using 66.102.7.104
    traceroute to www.l.google.com (66.102.7.104), 64 hops max, 52 byte packets
    traceroute: sendto: No route to host
    1 traceroute: wrote www.l.google.com 52 chars, ret=-1
    *traceroute: sendto: No route to host
    traceroute: wrote www.l.google.com 52 chars, ret=-1
    *traceroute: sendto: No route to host
    traceroute: wrote www.l.google.com 52 chars, ret=-1


    When I ping google I get:

    www.l.google.com ping statistics ---
    10 packets transmitted, 10 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 25.506/28.514/31.763/1.987 ms
  • sloong1 Level 1 Level 1 (0 points)
    I have exactly the same problem with Yahoo and youtube as well? is it some attack on the most popular websites?

    I also tried booting up the same laptop with bootcamp running Windows and all the websites are loading perfectly.

    Any ideas?
  • giant_28 Level 1 Level 1 (0 points)
    Hey sloong1 I just got google and youtube to work. Yesterday I downgraded to safari 4.0.5 following these instructions here http://appletoolbox.com/2010/06/downgrade-from-safari-5-0-to-safari-4-0-5/

    Tonight I just reinstalled safari 5.0.2 and voila everything works. If your still having trouble try uninstalling 5.0.2, restarting and then reinstalling 5.0.2, if that works then cool, otherwise try downgrading then reinstalling 5.0.2

    Hope this helps, I know this is super irritating...good luck
  • sloong1 Level 1 Level 1 (0 points)
    Sorry still not working. The problem is with the Mac network setting but not Safari. i.e. I cannot ping google from traceroute. Anyhow i did try downgrading to Safari and the same problem exist. Any ideas?
  • sloong1 Level 1 Level 1 (0 points)
    Finally resolved it. It is my PeerGuardian. Once i disabled it, my machine is back to normal!
  • oldsnwbrdr Level 1 Level 1 (5 points)
    I have a brand new iMac.

    Using my administrator account, anyone can log into yahoo or google just fine.

    When we use my wife or son's iMac accounts (not set up as administrators), we get the connection error every time we try to log on to one of these popular sites.

    I do not have peer guardian installed, whatever that is. Any other ideas?
  • oldsnwbrdr Level 1 Level 1 (5 points)
    ^^^ In my above, post, I forgot to mention that it happens whether we use Safari, OR Firefox!!!
  • oldsnwbrdr Level 1 Level 1 (5 points)
    Issue solved... in checking the parental controls, the box to try to filter out adult content when going to websites was checked. When I unchecked that box for my wife's and son's accounts, they became able to log into yahoo and google.

    However, I don't know:
    1) How or why those boxes were checked, or;
    2) Why email accounts are considered adult content.

    There was no warning in either browser about a parental control, just an error message about not being able to connect to the servers.