6 Replies Latest reply: Sep 20, 2010 2:08 PM by rriteli
facetious_fly Level 1 (0 points)
This machine has been updated to 10.6.4 and we have had trouble connecting to the printer. I have been trying to add it with various methods. Then I found a few posts online regarding other people's issues with printing from 10.6.4 so it started to make more sense. Now I just could really use some assistance in successfully adding the printer and actually being able to print from it.

Imac G5, Mac OS X (10.6.4), refurbished
  • DaddyPaycheck Level 6 (16,030 points)
    Have you tried removing it altogether and reinstalling the driver?
  • facetious_fly Level 1 (0 points)
    I went to HP's website only to find that the driver was unavailable for download due to the fact that Snow Leopard provides the drivers automatically... It's an HP 4000 LaserJet, yes very old.
  • facetious_fly Level 1 (0 points)
    All of the other computers in our office print just fine, they are all 10.5 or lower...
  • rriteli Level 1 (5 points)
    OS X 10.6 will not run on an G5 Mac. Are you sure it's a G5? Check the specs. for Snow Leopard. *http://support.apple.com/kb/SP575* It needs an Intel processor. You say that the other macs print fine, but are running 10.5. Makes sense, right? So, something doesn't add up here.
  • facetious_fly Level 1 (0 points)
    Sorry it does have an intel processor and it is an Imac G5, it was purchase at the beginning of 2010. It has been printing fine since we first set it up. Then a month ago the jobs would just hang there, or say it was unable to connect to printer. I noticed that in the Printer Info on MY computer has a URI: //*/HPLaserJet_4000series/LaserWriter. But the URI on the G5 is: ipp://localhost/HPLaserJet_4000Series.

    Of course that is what the URI was when I had tried adding it in various ways. At first I was trying to add it with the IP address and using LPD for the protocol. I'm probably going about this all wrong. I have tried using the shared printers with no luck... help?
  • rriteli Level 1 (5 points)
    Then we have a problem with semantics, since "G5" was the designation of the processor used in Apple computers prior to switching to Intel processors.
    Have you done as "DaddyPaycheck" suggested. Removing the printer and re-installing the the driver?
    You don't need anything from the HP web site to do that since the driver should be in the 10.6 software that was loaded . What kind of connection do you have from the iMac to the printer? Is it ethernet? What happens when you try to print from the iMac? Do you get the print screen with the printer showing up in the top window? The more detailed info you can provide, the easier it would be to troubleshoot.