1 7 8 9 10 11 Previous Next 216 Replies Latest reply: Jul 11, 2014 3:28 AM by Mushplim15 Go to original post Branched to a new discussion.
  • 120. Re: macbook pro trackpad problem
    JerryBirdwell Level 1 Level 1 (0 points)

    Running my fingernail around the edge resolved this problem on my 2010 MBP with built-in trackpad. Don't know why, because nothing came out ... but this did definitely do the trick.

  • 121. Re: macbook pro trackpad problem
    subieguy Level 1 Level 1 (0 points)

    So after having this macbook for a year and surviving a deployment to afghanistan i came home from work today to discover that i indeed have the same issue as everyone else. so i removed the battery. nothing. i removed the trackpad and cleaned it. nothing. apple care says its not in the software but how in the **** does it just start all of a sudden. i even deleted my macbook and reinstalled osx and still nothing. am i missing something. please help!!!

  • 122. Re: macbook pro trackpad problem
    Alvar0 Level 1 Level 1 (0 points)

    Hi guys,

     

    I just uploaded this video showing just one of the thousand problems I have with the trackpad. Sorry about the quality. I was playing Starcraft 2 today and I had to gave it up since it is impossible to play with this issues. I took it to a reseller and they told me, after a few days, that this is a permission problem. I reinstalled Lion, installed Windows and so on and the problem still persists. I don't think they even checked the baterry, which I bet my finger that is a faulty one.

  • 123. Re: macbook pro trackpad problem
    brettwa Level 1 Level 1 (0 points)

    I was having th same problem with my macbook that is about 18 months old. I cleaned the trackpad with a damp cloth and it worked for a minute or so, then went back to how it was before. I then tried cleaning it with spectical lens cleaner (as it is used on plastic and glass lenses) and now the trackpad is working perfectly..... there was no visable signs of dirt or oil but it has fixed the problem....give it a try and see !!!!

  • 124. Re: macbook pro trackpad problem
    Alvar0 Level 1 Level 1 (0 points)

    Thanks for the advice, but I'm still getting the same problem.

  • 125. Re: macbook pro trackpad problem
    mijaviles89 Level 1 Level 1 (0 points)

    I just bought mine today and when i plug in the power chord the trackpad doesn't react how it does without it

  • 126. Re: macbook pro trackpad problem
    subieguy Level 1 Level 1 (0 points)

    so after posting and finding no solution to my problem, i left my MBP on the desk for about a week. came back and suddenly it was good to go. im a half hour in and not one problem yet. so i will keep you all posted. hoping its gone for good.

  • 127. Re: macbook pro trackpad problem
    joejena Level 1 Level 1 (0 points)

    Does this happen ONLY when your macbook is plugged in to the charger?

     

    I've been having this same problem and figured out that since the capacitive trackpad picks up residual capacitance from any leakage current on your macbook pro's body it might start misbehaving.

     

    Options to fix this are:

     

    1. Use a three pin plug instead of a two pin one.

    2. Place palm over macbook body while using the trackpad to keep it grounded.

     

    The first option is the best. Let me know if this worked for you.

  • 128. Re: macbook pro trackpad problem
    joejena Level 1 Level 1 (0 points)

    There's a third option.

     

    Clean the edges of your trackpad so that there's no dust between the glass and the aluminum body. Dust conducts electricity and any residual current on the MacBook body will make your trackpad misbehave.

  • 129. Re: macbook pro trackpad problem
    Rudy_2001 Level 1 Level 1 (0 points)

    I'm having the same problem with a 2011 13" Macbook Air :/  Can't check the battery to see if that's the issue because it's built in....I guess I'll have to go to the Apple Store

  • 130. Re: macbook pro trackpad problem
    Rudy_2001 Level 1 Level 1 (0 points)

    They replaced the trackpad and that fixed it for me

  • 131. Re: macbook pro trackpad problem
    david skovgaard Level 1 Level 1 (0 points)

    Look, its amazing but true?

    It seems that dust and what else that can hide between the trackpad and the aluminium body is making some kind of electric interference.

     

    To Joejena: For me it isnt only happening when my m-book pro is plugged-in to the charger, but also when running battery power, so the 3-pinned plug wont work after all, just sayin'

     

    Anyway cleaning the trackpad around the edges with my nail works, and i guess a cleaning of the trackpad would work for anyone having the same problem as me...

    Also it can be one of the problems with a aluminium body, that the constructers of the mac-book hasn't thought about? After all aluminium conducts electricity, plastic don't.

  • 132. Re: macbook pro trackpad problem
    Sarah's stuff Level 1 Level 1 (0 points)

    Thank you so much you solved the problem! This is ridiculous but true! 4x fast clicks and it works again! What's wrong with these people at apple!

     

    Incidentally my sim card reader has stopped working! Any ideas on this?

  • 133. Re: macbook pro trackpad problem
    Pierre Froelicher1 Level 1 Level 1 (85 points)

    Dear all, dera Joejena,

    what you write makes it seem possible that it is a electrical residual current problem. I have seen that when you "connect" the palm of your hand to the macboosk body, the erratic beahaviour seems to vanish.

    So... it looks like hardware.. some freak current.

    Pierre

  • 134. Re: macbook pro trackpad problem
    subieguy Level 1 Level 1 (0 points)

    So here it is. After posting the last comment, I jinxed myself. About 10 minutes after that I got the issues back. Who would have though. So I was subdued to a life of Mac comp+Microsoft mouse. Well I figured I would at least try lion out hoping I would like it better. No thought towards the trackpad at all. I bought and installed it last night and went to bed waiting for my install to finish. This morning i had a crashed hard drive. I then called and Apple said to take it to genius. 1 hour later and all data lost I had my 2010 MBP back with lion and a wonderfully functional trackpad again. So lesson to be learned here is that it's not hardware at all. It's software. Proof? I'm 5 hours in on my MacBook and not one glitch from the trackpad.

1 7 8 9 10 11 Previous Next