1 10 11 12 13 14 15 Previous Next 215 Replies Latest reply: May 15, 2014 10:37 AM by chinisimo Go to original post Branched to a new discussion.
  • 165. Re: macbook pro trackpad problem
    epicbaby Level 1 Level 1 (0 points)

    Has there been a fix or update to this at all?

     

    I'm running 10.6.8.

     

    The battery is not the issue nor is the actual trackpad itself. The same issue happens when I plug in my mouse.

  • 166. Re: macbook pro trackpad problem
    ArturoSaCo Level 1 Level 1 (0 points)

    I have the same issue running OSX 10.7.5 on a late 2011 MBP, I've noticed the problem only happens I'm ussing the power adapter, if I'm running on the battery there is no problem at all.

  • 167. Re: macbook pro trackpad problem
    Landon from South Level 1 Level 1 (0 points)

    No update, that's for sure. However my trackpad is back to normal. I used my microsoft mouse for two days and since then the trackpad has been fine. All I can think is that my MBPr is temperamental and is gonna skitz like this randomly. Recently though things have been good.

  • 168. Re: macbook pro trackpad problem
    Landon from South Level 1 Level 1 (0 points)

    I found this

     

    http://support.apple.com/kb/TS1449?viewlocale=en_US&locale=en_US

     

    The suggestions didn't apply to me but I thought they might help.

  • 169. Re: macbook pro trackpad problem
    OKDANIEL Level 1 Level 1 (0 points)

    I have a MBP 17" late 2011. My trackpad became a little worse for not clicking (i could tap etc) over the last 6 months or so. I tried everything, battery, adjusting the screw etc etc.

     

    I just cleaned all along the edges of the top of the pad with a Q-TIp slightly damp with isopropyl (not rubbing) alcohol. I saw a little blackness on the q-tip after I went around with some force a few times. My trackpad is now working fine again.

     

    Every time I took out the battery and checked the inside, and put it back together it would work for a few hours and then go back to not working. I guess it was dirty on the edges all along., (I never checked becuase I keep it pretty clean always).

  • 170. Re: macbook pro trackpad problem
    Kris_2999 Level 1 Level 1 (0 points)

    Jadnash, thank you.  I have a Late 2008 MacBook Pro and was experiencing the same issues.  I removed the battery after reading your post and it works perfect!  Thanks for solving my issue.  You've saved me having to buy a new computer sooner, rather than later!  Cheers!

  • 171. Re: macbook pro trackpad problem
    chpeak Level 1 Level 1 (5 points)

    Yes, it is either a swollen battery, or in my case, with a new MBP, a fault in the battery wrapping adhesion. The solution, in my case, where the wrapping was losing its adhesion, was to just remove the wrappig entirely and replace it with black duct tape.

     

    I havent had one problem throughout this cold Boston winter since doing this. Ive already visited the Apple store and told their engineers about this as a possible fix.

     

    They wanted to replace the trackpad at  $90.00

  • 172. Re: macbook pro trackpad problem
    lewismedlock Level 1 Level 1 (0 points)

    Ok, I had the intermittent trackpad problem. I tried many of the proposed solutions and none worked. T'wasn't the battery nor a dirty trackpad, and no amount of deleting stored files helped. Finally the trackpad stopped working altogether, and I figured I'd have to lug my iMac to the Genius Bar, but  I found the fix on  an entirely different troubleshooting page. Go the Mac Dev Center, register as a developer, go to Additional Downloads, click on Xcode and download Bluetooth Explorer.  Delete the offending device from the Device Cache, then add it again using Bluetooth in Sys Prefs. Worked for me and many others.  No, I don't know why deleting and adding it in the traditional method does nothing, but I'm thrilled to have what has become indispensable back.

  • 173. Re: macbook pro trackpad problem
    unaffected2 Level 1 Level 1 (10 points)

    i faced this problem with my mbp 13" 2012  and i fixed it by replacing the power charger (60w "L" version) that came with it with my old cable (60w "T" version) hope it helps

  • 174. Re: macbook pro trackpad problem
    Smallworld74 Level 1 Level 1 (0 points)

    Looks as though there are several possible faults.  On my mid-2010 MBP I've reset the PRAM etc, taken the trackpad out & cleaned it, tried using it with and without the power cable, checked the battery (it's not swollen) & the problem didn't coincide with any software update, though there was a firmware update a couple of weeks before I started getting the problem. I'm currently using the thing with a USB mouse. I had to change the settings to "ignore trackpad when external mouse is being used" (or whatever the actual wording is) or else there was still a bit of weirdness even with the external mouse. I took the machine to the genius bar where I was told that all the software was working fine & that I need a new trackpad. I'm now awaiting delivery of a replacement trackpad (approx $30) which I'll fit myself. Hope that solves the problem, otherwise I'll be looking into malware issues (anyone got any experience with this side of things???) or previous Time Machine states.

     

    Good luck to everyone!

  • 175. Re: macbook pro trackpad problem
    Freerun88 Level 1 Level 1 (0 points)

    I just reset my PRAM and my trackpad worked fine!!!

  • 176. Re: macbook pro trackpad problem
    darkos50 Level 1 Level 1 (0 points)

    Just push down firmly on the entire trackpad !!!  IT WORKS!!!!!!

  • 177. Re: macbook pro trackpad problem
    Carlos Alberto Boton Level 1 Level 1 (30 points)

    Thank you - but thank you very much! That is bloody good! IT IS WORKING AGAIN!!!

  • 178. Re: macbook pro trackpad problem
    Michael1952 Level 1 Level 1 (0 points)

    OMG!! It worked for me too! Thanks for sharing

  • 179. Re: macbook pro trackpad problem
    Smallworld74 Level 1 Level 1 (0 points)

    Further to my last post, my replacement trackpad (salvaged, ebay) has solved my problem. All back to normal now!