Previous 1 11 12 13 14 15 16 Next 233 Replies Latest reply: Apr 3, 2016 2:29 PM by rkaner Go to original post Branched to a new discussion.
  • antoniofromsan antonio Level 1 Level 1

    if you have a wireless trackpad, make sure it is turned off, or turn your bluetooth off. if anything is resting, or pressing on the wireless trackpad it will interfere with the trackpad on your computer.

  • Maggie Joyce Level 1 Level 1

    For what it's worth:


    I took my MacBook Pro, 15", OS 10.8.4 to the Genius Bar at the Apple Store.

    I described my problem with my trackpad not responding or automatically selecting or clicking on random things.

    My pad had no give when I pressed on it. It would work for a short period of time after I restarted.


    I was told my BATTERY was getting old and was SWELLING, causing the trackpad to malfunction since the battery is direcdtly underneath the trackpad.


    It was the battery. Problem solved.

  • LadyBlacktronika Level 1 Level 1

    This seems to have fixed the problem. Hopefully it will remain fixed. Thanks. Pushing down on the entire trackpad with my palm seems to have fixed the issue.

  • anyarayne Level 1 Level 1

    The battery may be swollen:


    Also, an external mouse may be a temporary fix.

  • cbrinley Level 1 Level 1

    wow i've been trying everything under the sun to figure this out. Who knew the solution was in my grasp the whole time! Thanks this was drving me crazy!!!!

  • Red Sweater Level 1 Level 1

    Same problem for my Macbook Pro early 2011. It started spontaneously, with no apparent cause and made my MBP nearly useless. Trackpad was clean, haven't travelled with or dropped it, nothing out of the ordinary. I scoured the internet and here's my fix: 


    Disk Utility "Repair Disk Permissions."


    I had trouble at first as the mouse/trackpad repeatedly clicked "Stop Disk Repair" and interrupted the process. Once I was able to move the cursor, DU found printer permissions that needed repair ("should be 80; set at 0"). Problem solved ... for now.

  • Bob Bujic Level 1 Level 1

    My experience


    I have an older MacBook 13 with trackpad and a clicker. Well, strange things started to happen: no response, weird issues on the screen, typos flying all over while using some apps... terrible.


    I took the battery out and disconnected power supply. Instead of using thin paper to clean the clicker as someone suggested (being afaraid that a piece of paper may stick underneath), I found a film negative, scrapped down the emulsion, cut 1/4 of an inch piece of film and with that, I was able to clean the space between alum. plates. After that, using compressed air in a can, I did thorough cleaning of the area.


    But the problem persisted although the clicking pad was/is working perfectly.


    Then I realised that I installed Dropbox a few days ago. I uninstaled the app, repaired the permissions, and the MacBook is working like a charm.


    Was it the cleaning or Dropbox or a combo... but this is my case.

  • chpeak Level 1 Level 1

    If you (generalized) have a '11 MBP or newer, the cause of this ghost trackpad, is likely the battery wrapping. The new MBP have the battery directly under the track pad.


    Per my original post in January, it very well could the adhesion on battery separating from the battery, creating pockets of air and rubbing against the underside of the trackpad.


    For me... removing the wrapping and replacing it with black duct tape solved the issue.

  • Bob Bujic Level 1 Level 1

    Well, now with some certainity I can say that on my 'oldie' MacBook (not Pro) with OS 10.6, the problem was Dropbox. Since removing it, I still sometimes have to click again on my trackpad clicker, but there is no ghosting or freezing.

  • TamerAliAwwad Level 1 Level 1

    it didnt work out????

  • Solo Keita Level 1 Level 1

    I just fixed my friend's MacBook Pro's crazy trackpad by cleaning around the edges with a toothpick and getting out a lot of gunk.  And to my surprise it started wirking normally again!

  • Prulleman Level 1 Level 1

    well... after trying probably everything in this thread.. cleaning  the trackpad, running it without battery, resetting SMC, PRAM, disk repair, fixing permissions, remove startup items, and god knows what else.


    Then I finally came to the last page of this thread and completly despared removed dropbox, and ALL the trackpad problems seem te be gone. (was experiencing erratic beheaviour, spontanious clicks and multitouch swipes).


    Can't recall any dropbox update, but something is messed up with dropbox and my late 2009 MBP (5,5) with osx 10.7.5

  • Sass Level 2 Level 2

    I’m having thre same problem except with my Kensington mouse on my MacBook Air and also on my MacBook Pro with a cordless Logitech mouse.   I suspect it is some kind of change in the systen since it is happening on 2 different computers with 2 different types of mice. Maybe something n a security upgrade?  Whatever the cause, it is driving me crazy!!!!

  • Bob Bujic Level 1 Level 1

    As I indicated above, I did solve my MacBook issues by uninstaling Dropbox.


    I must add that Dropbox was causing problem with Google Drive as well. Every time my Mac woke-up after sleep, Mac was unable to find Google Drive on the Web. Same was if there was an interruption in Internet services by my provider: the Google Drive triangle would become gray and not responsive. Then I had to restart my Mac and repeatedly 'allow' my system to load and accept/recognize Google Drive.


    Since Dropbox was removed, I have no issues with Google Drive anymore.


    Note that I have no association with Dropbox competitors in any way or with Google itself. This is only my personal experience.


    I own MacBook 13' utilising OS 10.6.8 (Snow)

  • Widber Level 1 Level 1
    Mac OS X

    ArturoSaCo wrote:


    I have the same issue running OSX 10.7.5 on a late 2011 MBP, I've noticed the problem only happens I'm ussing the power adapter, if I'm running on the battery there is no problem at all.

    Arthuro, I have also absolutelly the same issue on my early 2011, 13" MBP running OS X 10.8.5.

    I have this problem with all of my 3 original power adapters. If I disconnect the PA - the pointer movement will be immediately smooth and comfortable again.
    Of course, everything on MBP is clean