9 Replies Latest reply: May 29, 2014 9:10 PM by 18842
Kylie Williams Level 1 Level 1 (0 points)
Ok, I have a second generation itouch and I want to download content on it, one app in particular Epic Citadel, but it keeps saying its incompatible. It says I need OpenGL ES 2.0 graphic capabilities. I've tried just about everything, but the tutorials are for all different kinds of things. Could you possibly, first, explain to me what OpenGL ES 2.0 is and what I can do with it? And then would you please link me to where I can download it, please?

I've always loved apple. I just need some help.

mac os x, Mac OS X (10.5.5)
  • Splinemodel Level 1 Level 1 (10 points)
    OpenGL is a system for the rendering of graphics. The ES part means "Embedded Systems," so OpenGL ES 2.0 is a system for rendering graphics on things like phones, iPods, cable boxes, etc. As part of the total system, there is usually a hardware component and a software component. The software component can be upgraded, but the hardware component cannot be upgraded on something like the iPod Touch.

    As far as I can find, the 2nd generation iPod Touch uses the PowerVR MBX Lite Hardware, which is designed to the ES 1.1 spec. The newer models (gen 3 & 4) have a newer chip (or more accurately a core, but I digress), which is capable of running programs that use OpenGL ES 2.0. So I'm afraid you are out of luck.
  • Kylie Williams Level 1 Level 1 (0 points)
    Okay thanks for your help I really appreciate it.
  • help with things Level 1 Level 1 (0 points)
    so wait my lil bro wants lego harry potter and im trying to get it for him and the thing saysapp requires OpenGl ES 2.0 graphics capability and we have the ipod touch 4 generation so what should i do and how do i get opengl es 2.0 help plz!!!!
  • no one cares 555 Level 1 Level 1 (0 points)
    the same thing happened to me. this is gay. it says for ipod 3rd and 4th gen and i have the 3rd gen ipod touch 8g but i think it is probably because it is 8g. apple needs to do a better job of label what ****** works and what doesnt because i just wasted 5 bucks on this app that i can do nothing with.......thanks a lot apple
  • Bob1234569 Level 1 Level 1 (0 points)
    My iPod touch 8 GB 3G with iOS 4.1 tells me that message where you need OpenGL es 2.00 to play eden world builder. How do I download the file if possible
  • jacka$$ Level 1 Level 1 (0 points)

    Hey, guess what. You got an iPod 2nd gen right there! 8 gb is more likely to be a 2nd gen than any other. And by the way, if you had bought the app on your iPod, it would have cancelled the purchase. If you had bought it on your computer, there's a little section that tells you what type of device you need to use that app. Besides, it's only $5, and by the way, NOBODY CARES!

  • RandyMolly12 Level 1 Level 1 (0 points)

    Either way, apple *****! people buy old ipods on ebay all the time obviously for nothing because no app works on them anymore. its a waaaaaaaste.

  • remonekamal Level 1 Level 1 (0 points)

    hey i want to know if this open gl es is downlodable app or program for ios4.2.1 or what to do

  • 18842 Level 1 Level 1 (0 points)

    What is the minimum iPhone and iPod touch for OpenGL ES 2.0?