13 Replies Latest reply: Feb 2, 2015 8:55 PM by nhatducnguyen
iGreenie Level 1 (0 points)
I had to restore my Mac today from a Time Machine backup. Everything went swimmingly, except for now I can't seem to unzip files using Archive Utility.app. In any folder under the root path / on Macintosh HD I get following error:

Error identifying a writable temporary folder. Try moving the archive to another volume.

However, if I move the archive to one of my Firewire external drives and unzip it from there, it works.

I've tried the standard Repair Disk Permissions from Disk Utility, using the diskutil repairpermissions / command and booting into my install disk and trying both of the previous from there. Unfortunatly it didn't solved the problem.

I noticed that when Time Machine restored my Mac the /private folder became visible, so I used Terminal and set it back to hidden. Could there be a problem with the permissions of my /private folder that Repair Disk Permissions hasn't fixed?

Any more suggestions would be ace as I can't seem to find anybody with the same issue via Google. Thanks in advance!

MacBook Pro, Mac OS X (10.6.4)